EmojiOne in forums

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
iorG19
Registered User
Posts: 57
Joined: Sun Sep 28, 2014 10:25 am
Name: Georgian Iordache
Contact:

EmojiOne in forums

Post by iorG19 » Wed Dec 21, 2016 12:06 am

I made a copy/paste from Emoji as code and paste into forum/category name in my forum list; when i submit the changes i have this:

Code: Select all

SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x93\x96' for column 'forum_name' at row 1 [1366]

SQL

UPDATE phpbb_forums SET parent_id = 0, forum_type = 0, forum_status = 0, forum_parents = '', forum_name = 'BIBLIOTECA', forum_link = '', forum_desc = '', forum_desc_uid = '', forum_desc_options = 7, forum_desc_bitfield = '', forum_rules = '', forum_rules_uid = '', forum_rules_options = 7, forum_rules_bitfield = '', forum_rules_link = 'http://ior-g.net/viewtopic.php?f=2&t=24', forum_image = '', forum_style = 0, display_subforum_list = 1, display_on_index = 1, forum_topics_per_page = 0, enable_indexing = 1, enable_icons = 1, enable_prune = 0, enable_shadow_prune = 0, prune_days = 0, prune_viewed = 0, prune_freq = 0, prune_shadow_days = 7, prune_shadow_freq = 1, forum_flags = 96 WHERE forum_id = 1

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 1363
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 199
CALL: acp_forums->update_forum_data()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_forums->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
Even here (creating this topic) i was errors :oops:
phpBB_SS4.png
phpBB_SS4.png (10.48 KiB) Viewed 629 times
"What is Untold is Uknown" ---Don Francisco Lopez
"Si pones el corazón, eres un ganador". ---Georgian Iordache @iorG19

User avatar
david63
Registered User
Posts: 16317
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: EmojiOne in forums

Post by david63 » Wed Dec 21, 2016 12:57 pm

Firstly - if you try to post an Emoji on the current phpBB forum it will not work as phpBB.com is currently running phpBB 3.1 and Emojis are not supported - they only become available in phpBB 3.2

I doubt that Emojis are supported in forum/category titles - but if you believe that this is a bug then I would suggest that you post it in the Bug Tracker
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Post Reply

Return to “[3.2.x] Support Forum”