[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
odf
Registered User
Posts: 119
Joined: Sun Jan 22, 2017 8:55 pm

Re: [DEV] Thanks for posts

Post by odf » Sun Jan 22, 2017 9:02 pm

John45 wrote:
Tue Oct 20, 2015 5:45 pm
Leinad4Mind wrote:
John45 wrote:
rxu wrote:
John45 wrote:I want one image not 4.
What style are you using?
Metro
Read the documentation of that style. There is a code where you can on .css put the correspondent for the like button. it's a 4 char code.

Best regards

I figured it out. :D

Is there a way to remove the confirmation page when you thank a post or topic, so it just does the thank or removes the thank without it.
Hi John45, how did you figure this out? I've the same problem, four images instead of one show up as thanks button!

krafyt
Registered User
Posts: 52
Joined: Sun Aug 23, 2009 11:13 pm

Re: [DEV] Thanks for posts

Post by krafyt » Sat Jan 28, 2017 5:20 am

I cannot get it to work on phpBB 3.2.0. The settings reset themselves after applying and because of that the necessary permissions cannot be set. :cry:

Has anyone any luck in getting it to work on v.3.2.0 ? Really?

User avatar
strelok-by
Registered User
Posts: 102
Joined: Fri Nov 21, 2014 10:22 am
Location: Mozyr / Belarus
Name: Stanislav
Contact:

Re: [DEV] Thanks for posts

Post by strelok-by » Sat Jan 28, 2017 6:05 am

krafyt wrote:
Sat Jan 28, 2017 5:20 am
I cannot get it to work on phpBB 3.2.0. The settings reset themselves after applying and because of that the necessary permissions cannot be set. :cry:

Has anyone any luck in getting it to work on v.3.2.0 ? Really?
I work in 3.2

MaFeSa
Registered User
Posts: 174
Joined: Wed Feb 11, 2009 7:48 am

Re: [DEV] Thanks for posts

Post by MaFeSa » Sat Jan 28, 2017 8:09 am

krafyt wrote:
Sat Jan 28, 2017 5:20 am
Has anyone any luck in getting it to work on v.3.2.0 ? Really?
Yes but with this
https://github.com/rxu/thanks_for_posts ... elop-3.2.x

krafyt
Registered User
Posts: 52
Joined: Sun Aug 23, 2009 11:13 pm

Re: [DEV] Thanks for posts

Post by krafyt » Mon Jan 30, 2017 9:14 pm

Thanks. It works now but I have one more problem: The icons won't show up. I use a home-made style which is a mixture of prosilver 3.1.10 & 3.2.0.

User avatar
zpintar
Registered User
Posts: 30
Joined: Fri Jan 18, 2013 8:51 am
Location: Croatia
Name: Žarko Pintar
Contact:

Re: [DEV] Thanks for posts

Post by zpintar » Sat Feb 04, 2017 9:28 pm

Hello,

I've just installed version 2.0.3-dev from GIT and everything works well except rating stars.
I've chosen blue stars in settings, but always get yellow stars in posts (in topic lists I get blue stars).

Why I'm getting yellow stars in posts? Is it a bug?

Image
Image

Exabot
Translator
Posts: 174
Joined: Sun Jan 18, 2015 8:21 pm
Location: Estonia

Re: [DEV] Thanks for posts

Post by Exabot » Sun Feb 05, 2017 11:35 am

'CLEAR_LIST_THANKS_CONFIRM' => 'Do you really want to clear the user`s Thanks List?',
YES/NO
error

Code: Select all

[phpBB Debug] PHP Notice: in file [ROOT]/ext/gfksx/ThanksForPosts/core/helper.php on line 317: Undefined variable: forum_id
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 2423: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925)
phpBB 3.1.10

User avatar
ALXGS
Registered User
Posts: 60
Joined: Wed Jan 11, 2017 4:27 pm

Re: [DEV] Thanks for posts

Post by ALXGS » Mon Feb 06, 2017 6:51 am

I run 3.1.10 and I will upgrade to 3.2 soon. I have installed the thanks for post in 3.1.10 and I wonder if there is a way to keep the data from the old version when I upgrade to 3.2. Is there possibility or need to restart the counters from the beginning?

Sorry for my bad english

Swen
Registered User
Posts: 72
Joined: Sun Oct 04, 2015 5:44 pm

Re: [DEV] Thanks for posts

Post by Swen » Mon Feb 06, 2017 7:31 am

This extension won't work on my phpBB 3.2 installation.
Regards Swen

MaFeSa
Registered User
Posts: 174
Joined: Wed Feb 11, 2009 7:48 am

Re: [DEV] Thanks for posts

Post by MaFeSa » Mon Feb 06, 2017 9:54 am

Swen wrote:
Mon Feb 06, 2017 7:31 am
This extension won't work on my phpBB 3.2 installation.
MaFeSa wrote:
Sat Jan 28, 2017 8:09 am
With phpBB 3.2.x use
https://github.com/rxu/thanks_for_posts ... elop-3.2.x

Swen
Registered User
Posts: 72
Joined: Sun Oct 04, 2015 5:44 pm

Re: [DEV] Thanks for posts

Post by Swen » Mon Feb 06, 2017 10:23 am

OK will give a try.
Regards Swen

Piipz
Registered User
Posts: 1
Joined: Mon Feb 06, 2017 11:31 am

Re: [DEV] Thanks for posts

Post by Piipz » Mon Feb 06, 2017 11:47 am

Hi, my forum is phpbb 3.1.9
I use Thanks for posts 2.0.2

When user wants to see his/her own thanks list or who he/she has thanked, then the user gets an error message:
"You are not authorised to view the Thanks List."


What could I do?

krafyt
Registered User
Posts: 52
Joined: Sun Aug 23, 2009 11:13 pm

Re: [DEV] Thanks for posts

Post by krafyt » Fri Feb 10, 2017 1:39 pm

Maybe there's a small bug in the layout?

Here: "Quick links" --> Posts toplist" --> "RATING TOPICS", the icons seem to be positioned wrong?

Image

I'm using prosilver 3.2.0.

Besides of that it works perfect.

User avatar
Scanialady
Registered User
Posts: 281
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: [DEV] Thanks for posts

Post by Scanialady » Sun Feb 19, 2017 12:24 pm

Is this extension abandoned?
Webseite, Blog, Wiki Deutsche Übersetzungen - german language files
My 2 cents: Whether an extension is in the CDB says nothing about its quality. It is more important to read the support topics for it. Better to avoid authors who do not answer support questions themselves, who do not update their stuff, and who do not fix bugs for years.

construaprende
Registered User
Posts: 59
Joined: Tue May 18, 2004 7:40 pm
Location: Mexico
Contact:

Re: [DEV] Thanks for posts

Post by construaprende » Tue Feb 21, 2017 7:08 am

I had an old mod, wich I never could make work
Version 1.3.3

NOw I recently upgraded my phpbb forum from 3.010 to 3.2

I tried to install this extension, and it gaves me the next error:
SQL ERROR [ mysqli ]

Table 'phpbb_thanks' doesn't exist [1146]

SQL

SHOW KEYS FROM phpbb_thanks

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 936
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 666
CALL: phpbb\db\tools\tools->sql_index_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 400
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()

FILE: [ROOT]/ext/gfksx/ThanksForPosts/ext.php
LINE: 52
CALL: phpbb\extension\base->enable_step()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 185
CALL: gfksx\ThanksForPosts\ext->enable_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 197
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
If I go to pypmyadmin, and make a search after this failure, and search for
thanks


It shows me this data:

in phpbb_config, this two results

thanks_mod_version
1.3.3
thanks_notice_on
0


In phpbb_migrations
migration name
\gfksx\ThanksForPosts\migrations\v_0_4_0
migration_depends_on
a:1:{i:0;s:33:"\phpbb\db\migration\data\v310\dev";}

migration name
\gfksx\ThanksForPosts\migrations\v_1_2_5
migration_depends_on
a:1:{i:0;s:40:"\gfksx\ThanksForPosts\migrations\v_0_4_0";}

migration name
\gfksx\ThanksForPosts\migrations\v_1_2_6
migration_depends_on
a:1:{i:0;s:40:"\gfksx\ThanksForPosts\migrations\v_1_2_5";}

migration name
\gfksx\ThanksForPosts\migrations\v_1_3_4
migration_depends_on
a:1:{i:0;s:40:"\gfksx\ThanksForPosts\migrations\v_1_3_3";}


Any idea how to solve this?

Thank you

Locked

Return to “Extensions in Development”