Admin login always fails; unable to create new users.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
rmmartel1982
Registered User
Posts: 4
Joined: Thu Feb 23, 2017 6:26 pm

Admin login always fails; unable to create new users.

Post by rmmartel1982 » Thu Feb 23, 2017 6:45 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.0
What is your board's URL? http://nacc.urban.csuohio.edu/phpBB3/
Who do you host your board with? my own server
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? stock
What language(s) is your board currently using? British English - stock
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Performed fresh install
Please describe your problem. Performed fresh install - once admin logged out was unable to log in again. Wiped all and reloaded, same thing happened again. wiped and reloaded, logged out admin and tried to register as a new user - form always said that I was typing the captcha wrong - so unable to add new user. Tried to log back in as admin, and fails.
Generated by SRT Generator


That about covers it. I have tried multiple fresh installs of the phpBB 3.2 package and it seems to be installed okay until the admin logs out, then is unable to log back in. Even after having the software generate a new password, activating it, and trying to use it - it still fails.

Attempts to create a new user always fails with form reporting that the captcha was typed incorrectly.

This host/board is not yet accessible from the outside world

Thank you,
Bob

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50926
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Admin login always fails; unable to create new users.

Post by stevemaury » Thu Feb 23, 2017 6:47 pm

Which CAPTCHA? What are your cookie settings and server settings?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

rmmartel1982
Registered User
Posts: 4
Joined: Thu Feb 23, 2017 6:26 pm

Re: Admin login always fails; unable to create new users.

Post by rmmartel1982 » Thu Feb 23, 2017 7:06 pm

What ever settings phpBB 3.2 comes with "out of the box"

Regardless of how carefully I type the captcha I see the attached screen.

Can't do much else since the admin login always says I am using the wrong password.
Attachments
register2.png

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50926
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Admin login always fails; unable to create new users.

Post by stevemaury » Thu Feb 23, 2017 7:30 pm

That CAPTCHA is useless, particularly as your board is not accessible from the internet. Turn off Spambot countermeasures and reset the admin password by using this SQL ( Executing SQL Queries in phpMyAdmin )

Code: Select all

UPDATE phpbb_config SET config_value = 0 WHERE config_name = 'enable_confirm";
UPDATE phpbb_users SET user_password = '5f4dcc3b5aa765d61d8327deb882cf99' WHERE user_name = 'your username';
If your table prefix is not phpbb_, change accordingly.

This will disable CAPTCHA and change your password to "password" (without quotes). Change it immediately in the UCP after you log in.

Backup the config and users table before running the queries.

What are your cookie settings and server settings?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

rmmartel1982
Registered User
Posts: 4
Joined: Thu Feb 23, 2017 6:26 pm

Re: Admin login always fails; unable to create new users.

Post by rmmartel1982 » Fri Feb 24, 2017 9:10 pm

Wiped and reloaded one more time. With the captcha disabled I was able to create a user. Once logged out however I was still unable to log back in as the administrator or the new user while using Firefox 51.0.1 on debian. When I tried using the Epiphany web browser I was able to log in.

The Firefox browser is set to accept cookies. It is not throwing any warnings.

Attached are shots of the server settings and cookies settings from in the ACP.
Attachments
cookies.png
server_settings.png

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Re: Admin login always fails; unable to create new users.

Post by MichaelTunnell » Tue Feb 28, 2017 2:33 am

rmmartel1982 wrote:
Fri Feb 24, 2017 9:10 pm
Once logged out however I was still unable to log back in as the administrator or the new user while using Firefox 51.0.1 on debian. When I tried using the Epiphany web browser I was able to log in.
I have this exact same problem with not being able to login or create a user on Firefox.

I have been racking my brain for a couple hours of this and rebuilt phpbb3 at least 5 times now with different tests to see where it goes wrong.

Upon seeing the above comment I decided to test admin logins with other browsers than Firefox . . .

Firefox = failure
Chrome = successful
Vivaldi = successful
Epiphany = successful

Then I decided to test creating a new account with other browsers . . .

Firefox = failure (claims captcha is wrong but certainly is correct)
Chrome = successful (captcha worked fine)
Vivaldi = successful (captcha worked fine)
Epiphany = successful (captcha worked fine)

Conclusion:
something is broken with phpbb 3.2 and Firefox 51.0.1

Note: I use KDE Neon as my operating system. (KDE Neon is based on Ubuntu 16.04 which is based on Debian)

---------------------------------------------

Edit: so I did some more testing and it turns out that it has something to do with the session being created. I closed Firefox and reopened it for more testing. After closing and reopening the login worked fine. However, if I were to logout and try to log back in, failure. If I repeat the closing and reopening of Firefox then the login works again.

So I think there is some issue with Firefox 51.0.1 plus phpBB's session and/or cookies.

rmmartel1982
Registered User
Posts: 4
Joined: Thu Feb 23, 2017 6:26 pm

Re: Admin login always fails; unable to create new users.

Post by rmmartel1982 » Tue Feb 28, 2017 2:13 pm

Greetings,

You beat me to it. Had to work some other tasks and upon getting back to this one I was just starting to check with different browsers and finding i did NOT have a problem.

Thank you for sharing!

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Re: Admin login always fails; unable to create new users.

Post by MichaelTunnell » Thu Mar 23, 2017 10:36 pm

This issue was 100% Firefox's fault and as of Firefox 52 it has been fixed.

Onsemeliot
Registered User
Posts: 10
Joined: Tue Sep 25, 2012 1:10 pm

Re: Admin login always fails; unable to create new users.

Post by Onsemeliot » Sun Mar 04, 2018 12:04 pm

Hm, I'm having the same problem with Firefox ESR 52.6 on Debian. But I discovered that I suddenly can login again today without changing anything. So I am under the impression this has something to do with the session management. I will see if it stops working again after some time. Then this would be a strong hint. I downloaded Chromium just to check if I will still be able to login when it fails again in Firefox.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21736
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Admin login always fails; unable to create new users.

Post by Mick » Sun Mar 04, 2018 12:34 pm

This topic is over a year old, you should start your own if you have an issue with phpBB.

Edit: I see you have another topic on the go, please stick to that rather than cross posting, thanks.
"The more connected we get the more alone we become" - Kyle Broflovski

Post Reply

Return to “[3.2.x] Support Forum”