No emails

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 20828
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - probably.

Re: No emails

Post by Mick » Fri Oct 12, 2018 2:50 pm

Replace the existing email address with the new one you have in ’From email address’ and ‘Contact email address‘, and if you’re trying to use SMTP try turning it off and see how it goes. (Use SMTP server for email: yes/no)
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
EA117
Registered User
Posts: 351
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: No emails

Post by EA117 » Fri Oct 12, 2018 2:59 pm

Agreed; set "From email address" and "Contact email address" to the new @modelrailwayforum.co.uk address, and then simply set "Use SMTP server for email" back to "No", and that alone could now result in successful email.

We won't bother trying to use use One.com-specific SMTP settings unless for some reason the PHP mail() function (which One.com also controls) doesn't already work now that you're sending with an @modelrailwayforum.co.uk email address.

Note you can leave all the VirginMedia-related settings in the "SMTP Settings" field without worry, because with "Use SMTP server for email" set to "No" all those SMTP-specific settings are being ignored.

Brian Lambert
Registered User
Posts: 41
Joined: Tue Oct 09, 2018 7:13 am

Re: No emails

Post by Brian Lambert » Fri Oct 12, 2018 3:44 pm

#EA117 You're a genius! At long, long, long, last I've got a message from the forum Test and no error message!! Yeah!
Then I went into forum and tested Contact Us and sent a second message. Its arrived in my Virginmedia.com email in box. Double Yeah!!! :D :D
Test message..
Received.jpg


Now, about those members emails...... No we wont go there today!!! :shock:

User avatar
EA117
Registered User
Posts: 351
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: No emails

Post by EA117 » Fri Oct 12, 2018 4:43 pm

Brian Lambert wrote:
Fri Oct 12, 2018 3:44 pm
At long, long, long, last I've got a message from the forum Test and no error message!! Yeah!
Ultimately it was required to create a @modelrailwayforum.co.uk email address, which is what everyone else was already recommending. 😉

We were just so close to testing the correct @virginmedia.com SMTP settings, it seemed like testing whether those might already work was something to confirm first. But they did not work; at least from inside the One.com hosting account, apparently.

Glad you found the working solution.
Brian Lambert wrote:
Fri Oct 12, 2018 11:27 am
How does all this factor in on the membership being emailed with notifications of new posts when they check that box in a topic? Or is that a totally different area??
These same email settings are used to send the notifications that members request for new topics, private messages, replies, etc. Everything that the phpBB board sends is "from" whatever board email you have configured, regardless of the purpose.

Even the member-accessible "send email" option, if enabled, sends the initial email "from the board" and not from member-specific email addresses. If the receiving member chooses to reply to the email, the subsequent email exchange is between the two members directly, and doesn't involve the phpBB board or its email configuration.

Brian Lambert
Registered User
Posts: 41
Joined: Tue Oct 09, 2018 7:13 am

Re: No emails

Post by Brian Lambert » Fri Oct 12, 2018 5:05 pm

Yeah... I was hoping SMTP would work. But happy it works with the One.com settings. Sorry I took so long to understand. All this SMTP bit is new to me!
Thanks for the heads up re members post messages.

Just have to sort out now how to add a new icon to the forum.. I've managed so far to delete the php one, but need to upload my GIF and then insert it. The 'How To' instructions are being followed! :o

Need now to attend night school to learn exactly how to write or at least understand HTML.. :)

Thank you again for 'holding my hand' through the process.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20828
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - probably.

Re: No emails

Post by Mick » Fri Oct 12, 2018 6:24 pm

You should start a new topic in the relevant forum for each of your other questions, if you have any ;)
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

Brian Lambert
Registered User
Posts: 41
Joined: Tue Oct 09, 2018 7:13 am

Re: No emails

Post by Brian Lambert » Fri Oct 12, 2018 6:48 pm

Hi Mick, Yes I know..
My remarks re other matters were meant purely as a 'Tongue in Cheek' comment. ;)

User avatar
Lumpy Burgertushie
Registered User
Posts: 66006
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: No emails

Post by Lumpy Burgertushie » Fri Oct 12, 2018 7:07 pm

I guess I did not make it clear above about the host not allowing relaying through their servers.

that is the reason that you almost always have to create a email address at your host control panel. that way, the emails coming and going are based at the same server your site is on.

trying to send or receive emails using the virginmedia address was trying to relay that through the host's servers and many if not most of them block that these days because of spammers.

glad you got it working.

also, you do not need to learn any php or html to be able to use a phpbb board.
'
you most likely will have to have and understand how to use ftp for installing the board and any styles and/or extensions you may want to install.

luck,
robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: invenio and 25 guests