[DEV] Post Love

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
KungFuJosh
Registered User
Posts: 84
Joined: Sun Aug 21, 2016 1:26 am
Location: USA
Name: Joshua
Contact:

Re: [DEV] Post Love

Post by KungFuJosh » Thu Nov 15, 2018 12:31 pm

jefmcg wrote:
Mon Oct 29, 2018 2:58 pm
I installed this extension (via git clone) in August - which as far as tell is the latest version.

First off, it's great - thanks.

The only issue I have is that we only get notifications sometimes. i.e. Sometimes when someone likes my post, there is a notification. Other times there isn't. The likes seem to show up fine on the posts, and you can review them in your profile. There seems to be no pattern, and no error popups or messages in the error log.

(ok, one other issue: I'd like to be able to click on number to know who the like was from, I'm mostly using a phone, so hover doesn't work)
+1 - me too. I've been using this extension for well over a year. Same thing, doesn't always notify. Or, if two people like the same post, for example, I might only get a notification of 1 of them, if at all.

KungFuJosh
Registered User
Posts: 84
Joined: Sun Aug 21, 2016 1:26 am
Location: USA
Name: Joshua
Contact:

Re: [DEV] Post Love

Post by KungFuJosh » Thu Nov 15, 2018 12:31 pm

jefmcg wrote:
Mon Oct 29, 2018 2:58 pm
I installed this extension (via git clone) in August - which as far as tell is the latest version.

First off, it's great - thanks.

The only issue I have is that we only get notifications sometimes. i.e. Sometimes when someone likes my post, there is a notification. Other times there isn't. The likes seem to show up fine on the posts, and you can review them in your profile. There seems to be no pattern, and no error popups or messages in the error log.

(ok, one other issue: I'd like to be able to click on number to know who the like was from, I'm mostly using a phone, so hover doesn't work)
+1 - me too. I've been using this extension for well over a year. Same thing, doesn't always notify. Or, if two people like the same post, for example, I might only get a notification of 1 of them, if at all.

Thanks,
Josh

jefmcg
Registered User
Posts: 40
Joined: Mon Aug 13, 2018 11:04 am

Re: [BETA] Post Love

Post by jefmcg » Thu Dec 27, 2018 1:23 pm

mikepetro wrote:
Mon Sep 05, 2016 12:45 am
I encountered a problem where the array display when viewing "All likes" from a User profile, worked, but did not take you directly to the post that was liked.

The change I made that fixed it was in the Lovelist.php file, line 148:

Original

Code: Select all

$post_link = '<a href="' . $this->root_path .($short == 1 ? '' : ($page > 1 ? '../../../' : '../')) .'viewtopic.php?p=' . $row['post_id'] . '#'. $row['post_id'] .'" target="_blank" >' . $row['post_subject'] . '</a>';
Modification: Notice the added "p' in the '#p'. $row['post_id]'' bit

Code: Select all

$post_link = '<a href="' . $this->root_path .($short == 1 ? '' : ($page > 1 ? '../../../' : '../')) .'viewtopic.php?p=' . $row['post_id'] . '#p'. $row['post_id'] .'" target="_blank" >' . $row['post_subject'] . '</a>';
This worked an it now scrolls to the exact post that was liked.
I was starting to draft almost exactly the same message, as I found and fixed the same bug. Then I thought of searching for it, and found your 2 year old post.

Sadly, even though lovelist.php has been edited a few times since you flagged this bug, the fix hasn't been made.

So just bumping this bug/bugfix report.

TheButcher2
Registered User
Posts: 659
Joined: Tue May 13, 2014 11:38 pm
Contact:

Re: [DEV] Post Love

Post by TheButcher2 » Wed Jan 09, 2019 7:43 pm

I downloaded it and can't see it on my "customize" page to enable it, I am running 3.2.2

Any ideas why.


Peace

jefmcg
Registered User
Posts: 40
Joined: Mon Aug 13, 2018 11:04 am

Re: [DEV] Post Love

Post by jefmcg » Wed Jan 09, 2019 9:04 pm

TheButcher2 wrote:
Wed Jan 09, 2019 7:43 pm
I downloaded it and can't see it on my "customize" page to enable it, I am running 3.2.2

Any ideas why.


Peace
I had it working with that version.

Is this the first extension you've installed? It should be in your ext directory, ie ext/anavaro/postlove

Is it there?

(this is the first help I have offered on phpbb.com, so be patient)

TheButcher2
Registered User
Posts: 659
Joined: Tue May 13, 2014 11:38 pm
Contact:

Re: [DEV] Post Love

Post by TheButcher2 » Wed Jan 09, 2019 9:43 pm

jefmcg wrote:
Wed Jan 09, 2019 9:04 pm
TheButcher2 wrote:
Wed Jan 09, 2019 7:43 pm
I downloaded it and can't see it on my "customize" page to enable it, I am running 3.2.2

Any ideas why.


Peace
I had it working with that version.

Is this the first extension you've installed? It should be in your ext directory, ie ext/anavaro/postlove

Is it there?

(this is the first help I have offered on phpbb.com, so be patient)

Not my first extension, I renamed the extension to anavaro/postlove and it worked, when I click on the little heart if seems to count but also shows this warning popup. please extension. And advise if you may.

"AJAX error

Service Unavailable"


Peace

jefmcg
Registered User
Posts: 40
Joined: Mon Aug 13, 2018 11:04 am

Re: [DEV] Post Love

Post by jefmcg » Thu Jan 10, 2019 5:14 pm

TheButcher2 wrote:
Wed Jan 09, 2019 9:43 pm
Not my first extension, I renamed the extension to anavaro/postlove and it worked, when I click on the little heart if seems to count but also shows this warning popup. please extension. And advise if you may.

"AJAX error

Service Unavailable"
I don't know!! Sorry.

Try purging the cache?

You aren't the only one to experience this problem .... viewtopic.php?f=456&t=2246576&p=14595951&#p14595951 and I see the advice include purging the cached and turning debug off viewtopic.php?f=456&t=2246576&p=14595951&#p14597981

Good luck! It's not a bad little extension. The only problems (when it's working properly) is you don't always get notifications, and you have to tweak it to make the links work on your postlove summary page. But it's a good little low-key like facility.

User avatar
Tin Soldier
Registered User
Posts: 35
Joined: Wed Dec 05, 2018 1:20 am

Re: [DEV] Post Love

Post by Tin Soldier » Sat Feb 02, 2019 2:44 pm

Tried installing on 3.2.5. and while I see settings available on the extensions tab after being enabled, I see no integration on the board. No like options on any posts. Is there an issue with 3.2.5. or am I missing something?

jefmcg
Registered User
Posts: 40
Joined: Mon Aug 13, 2018 11:04 am

Re: [DEV] Post Love

Post by jefmcg » Sat Feb 02, 2019 6:23 pm

Tin Soldier wrote:
Sat Feb 02, 2019 2:44 pm
Tried installing on 3.2.5. and while I see settings available on the extensions tab after being enabled, I see no integration on the board. No like options on any posts. Is there an issue with 3.2.5. or am I missing something?
I've had it working for several versions, including 3.2.5. Nothing broke when I upgraded from 3.2.4.

Sorry I can't be more helpful.

User avatar
Tin Soldier
Registered User
Posts: 35
Joined: Wed Dec 05, 2018 1:20 am

Re: [DEV] Post Love

Post by Tin Soldier » Sat Feb 02, 2019 7:46 pm

jefmcg wrote:
Sat Feb 02, 2019 6:23 pm
Tin Soldier wrote:
Sat Feb 02, 2019 2:44 pm
Tried installing on 3.2.5. and while I see settings available on the extensions tab after being enabled, I see no integration on the board. No like options on any posts. Is there an issue with 3.2.5. or am I missing something?
I've had it working for several versions, including 3.2.5. Nothing broke when I upgraded from 3.2.4.

Sorry I can't be more helpful.
Thanks.

Well, I've enabled and disabled, deleted and reinstalled, and not seeing the buttons on posts, nor index info on likes (I don't want the latter, mind you. I'd disable that). Not sure if there's a conflict with another extension, or what.

User avatar
mrgoldy
Jr. Extension Validator
Posts: 1163
Joined: Tue Oct 06, 2009 7:34 pm
Location: The Netherlands
Name: Gijs
Contact:

Re: [DEV] Post Love

Post by mrgoldy » Sun Feb 03, 2019 10:52 am

Did you set permissions / forum settings, if there are any?

User avatar
janus_zonstraal
Registered User
Posts: 3623
Joined: Sat Aug 30, 2014 1:30 pm

Re: [DEV] Post Love

Post by janus_zonstraal » Thu Feb 07, 2019 11:28 pm

Very weird problem, when I enable the Post love extension then the language from the navbar is following the default language.
So if the default language from the board is Dutch en the users chooses English than everything is in English except the navbar and a few things in the ACP.

Anybody else notice this?
Sorry! My English is bat ;) !!!

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3898
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [DEV] Post Love

Post by kasimi » Fri Feb 08, 2019 9:05 am


El_Lagarto
Registered User
Posts: 43
Joined: Tue Apr 08, 2014 1:21 pm

Re: [DEV] Post Love

Post by El_Lagarto » Thu Feb 14, 2019 3:00 pm

Tin Soldier wrote:
Sat Feb 02, 2019 7:46 pm
jefmcg wrote:
Sat Feb 02, 2019 6:23 pm
Tin Soldier wrote:
Sat Feb 02, 2019 2:44 pm
Tried installing on 3.2.5. and while I see settings available on the extensions tab after being enabled, I see no integration on the board. No like options on any posts. Is there an issue with 3.2.5. or am I missing something?
I've had it working for several versions, including 3.2.5. Nothing broke when I upgraded from 3.2.4.

Sorry I can't be more helpful.
Thanks.

Well, I've enabled and disabled, deleted and reinstalled, and not seeing the buttons on posts, nor index info on likes (I don't want the latter, mind you. I'd disable that). Not sure if there's a conflict with another extension, or what.
I'm in the same boat. Not a permissions issue, as there are no permissions to set. I do see a small "x" at the lower right hand corner of every post, but it doesn't do anything.

User avatar
ivailo95
Registered User
Posts: 770
Joined: Tue Sep 05, 2017 8:00 am
Location: Bulgaria
Name: Ivailo
Contact:

Re: [DEV] Post Love

Post by ivailo95 » Wed Feb 20, 2019 2:13 pm

i suggest to add option "show Most liked posts on index - yes/no" i think would be better :idea:
https://i.imgur.com/hccUPAo.png

Post Reply

Return to “Extensions in Development”