Issue updated from 3.2.5 to 3.2.7

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
hellohappy
Registered User
Posts: 2
Joined: Tue May 14, 2019 8:19 am

Issue updated from 3.2.5 to 3.2.7

Post by hellohappy » Tue May 14, 2019 8:42 am

My phpbb forum code was slightly modified, so I used the [AUTOMATIC UPDATE PACKAGE] to complete the upgrade. Everything is normal in the forum before upgrading. After upgrading, the display of some posts has become abnormal. Now I have turned off all plug-ins and used the prosilver theme. But the page layout is still wrong. This is not a problem with style sheets, because the output php is the wrong label hierarchy. However, I am not very familiar with phpbb code, and I hope someone can give me some guidance. The website with the problem can visit here directly. https://www.postgraduate.top/viewtopic.php?f=2&t=101
Other pages of the website also have some typographical problems, such as this one:https://www.postgraduate.top/viewtopic.php?f=2&t=97
If there is any more information, I will reply in time, thank you
Attachments
1557822865(1).png

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2309
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: Issue updated from 3.2.5 to 3.2.7

Post by kinerity » Tue May 14, 2019 11:24 am

hellohappy wrote:
Tue May 14, 2019 8:42 am
My phpbb forum code was slightly modified, so I used the [AUTOMATIC UPDATE PACKAGE] to complete the upgrade.
Did you happen to keep a copy of the changes you made to the code? I would suggest restoring you're backup and follow the instructions in Knowledge Base - Updating 3.2.x. Then, redo the code modifications. The automatic update package isn't the suggest way to upgrade.
Kailey Truscott - Community Team

hellohappy
Registered User
Posts: 2
Joined: Tue May 14, 2019 8:19 am

Re: Issue updated from 3.2.5 to 3.2.7

Post by hellohappy » Tue May 14, 2019 12:49 pm

kinerity wrote:
Tue May 14, 2019 11:24 am
hellohappy wrote:
Tue May 14, 2019 8:42 am
My phpbb forum code was slightly modified, so I used the [AUTOMATIC UPDATE PACKAGE] to complete the upgrade.
Did you happen to keep a copy of the changes you made to the code? I would suggest restoring you're backup and follow the instructions in Knowledge Base - Updating 3.2.x. Then, redo the code modifications. The automatic update package isn't the suggest way to upgrade.
Thank you very much for your proposal.
I have always updated the files by updating them, so it may be a bit troublesome to replace all the original files.
Just now I ruled out one by one and finally found the cause of the mistake! It is an error caused by the bbcode of my previous extension -->https://github.com/AlfredoRamos/phpbb-e ... le-spoiler.
I am a little curious about what part of the new source code this bbcode conflicts with. This problem has been solved. Forgive me for not deleting the redundant bbcode before asking the question. The discussion and process of solving this problem are here: https://www.phpbb.com/customise/db/exte ... pic/203966

Code: Select all

<section class="spoiler">
	<header class="spoiler-header spoiler-trigger">
		<div class="spoiler-title">
			<xsl:choose>
				<!-- deprecated:start -->
				<!-- kept just for backward compatibility -->
				<xsl:when test="@spoiler and string-length(normalize-space(@spoiler)) > 0">
					<xsl:choose>
						<xsl:when test="string-length(normalize-space(@spoiler)) > 85">
							<xsl:value-of select="concat(normalize-space(substring(normalize-space(@spoiler), 0, 85)), '…')"/>
						</xsl:when>
						<xsl:otherwise>
							<xsl:value-of select="normalize-space(@spoiler)"/>
						</xsl:otherwise>
					</xsl:choose>
				</xsl:when>
				<!-- deprecated:end -->
				<xsl:when test="@title and string-length(normalize-space(@title)) > 0">
					<xsl:choose>
						<xsl:when test="string-length(normalize-space(@title)) > 85">
							<xsl:value-of select="concat(normalize-space(substring(normalize-space(@title), 0, 85)), '…')"/>
						</xsl:when>
						<xsl:otherwise>
							<xsl:value-of select="normalize-space(@title)"/>
						</xsl:otherwise>
					</xsl:choose>
				</xsl:when>
				<xsl:otherwise>{L_SPOILER}</xsl:otherwise>
			</xsl:choose>
		</div>
		<div class="spoiler-status">{L_SPOILER_SHOW}</div>
	</header>
	<div class="spoiler-body">{TEXT1}</div>
</section>
Finally, I know that this should not be a new bug, but the extension. Thank you very much.
Attachments
1557837874(1).png

Post Reply

Return to “[3.2.x] Support Forum”