[phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
BeBop
Registered User
Posts: 45
Joined: Tue Sep 05, 2017 1:07 pm

[phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by BeBop » Wed Jul 10, 2019 10:08 am

Good morning all super-techs, it's the two old giffers back again.

As of late last night the following message below suddenly displayed on our forum home page and most board POST titles and content, also when accessing ACP below login name. Basically plastered all across the forum

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Has anybody any ideas as to what might have happened please? Need advice as soon as possible please.

FORUM ID: http://www.973-eht-namuh-973.com/forum/ ... mode=login

Many thanks in advance
and Kind Regards

BeBop
Last edited by BeBop on Wed Jul 10, 2019 10:20 am, edited 1 time in total.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69427
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA

Post by KevC » Wed Jul 10, 2019 10:14 am

You're running phpBB 3.2.2 and your host has updated the server php version to 7.2

They are not compatible. You either need to ask them to downgrade to 7.1 or you need to bring the board up to v3.2.7
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

BeBop
Registered User
Posts: 45
Joined: Tue Sep 05, 2017 1:07 pm

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by BeBop » Wed Jul 10, 2019 10:27 am

Dear KevC

Thanks for you prompt reply. Our hosting provider upgraded to PHP 7.2 last year at this time and we upgraded to phpBB 3.2.2 because it WAS compatible with PHP it's been running fine since then.

Kind Regards BeBop

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69427
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by KevC » Wed Jul 10, 2019 10:30 am

They've probably gone up a couple of steps in the php version and it's broken it again. Ask them to put it back to what it was on or update the board version.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

BeBop
Registered User
Posts: 45
Joined: Tue Sep 05, 2017 1:07 pm

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by BeBop » Wed Jul 10, 2019 11:19 am

KevC thank you for the advice, we will check with THE HOST, but this presents a serious security issue as our hosting provider only warns us in advance of major PHP changes, say from PHP 7.2 to 7.3, not interim upgrades within the same major version i.e. 7.2.8 to 7.2.10 which render our board software incompatible.

Regards BeBop

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69427
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by KevC » Wed Jul 10, 2019 11:40 am

The flip side of that is that you're 5 versions behind on your phpBB version. If you're up to date, those small steps shouldn't be a problem.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

BeBop
Registered User
Posts: 45
Joined: Tue Sep 05, 2017 1:07 pm

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by BeBop » Thu Jul 11, 2019 10:21 pm

Dear support and KevC,

Two old giffers back here again. We followed your advice KevC, rather than getting our hosting provider to roll back a PHP 7.2 update or two we upgraded phpBB board from version 3.2.2 to 3.2.7 yesterday.

http://www.973-eht-namuh-973.com/forum/ ... mode=login

While everything seemed to be working, one problem we have uncovered is that we appear to have lost very inline attachment image posted since the last upgrade from version 3.2.1 to 3.2.2 completed last year during the first week of September 2018.

We still have a copy of the system before the upgrade, is there a file that contains those attached images in the pre-uugrade copy mentioned that we failed to include and use in the upgrade to 3.2.7. If so can which get it back and install it in 3.2.7 or would that require doing the whole upgrade again.

Please advise

Thank you in advance and
kind regards
BeBop

User avatar
Lumpy Burgertushie
Registered User
Posts: 66849
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by Lumpy Burgertushie » Fri Jul 12, 2019 12:39 am

how did you update?

did you download/backup the folder named "files" using filezilla ftp program?

did you then delete the folder on the server? if so then you may be out of luck.

by default, filezilla transfers files with no extension as ascii and your images in the files folder should be transferred using binary.

according to all the update instructions here you are supposed to leave that folder alone on the server and not delete it during updating.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

BeBop
Registered User
Posts: 45
Joined: Tue Sep 05, 2017 1:07 pm

Re: [phpBB Debug] PHP Warning suddenly diplayed NO IDEA WHY

Post by BeBop » Fri Jul 12, 2019 4:26 pm

OK Lumpy Burgertushie thank you for your help we will check that and report back.

Regards BeBop

Post Reply

Return to “[3.2.x] Support Forum”