[SOLVED] Blank Page on Starting New Topic

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Acorn
Registered User
Posts: 402
Joined: Tue Sep 26, 2006 8:11 am
Location: UK
Contact:

[SOLVED] Blank Page on Starting New Topic

Post by Acorn »

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
Who do you host your board with? Rackspace
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3, but this was months ago
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.1
What extensions do you have installed? Add User
Board Announcements
Large Fonts
Obscure Contact Us
phpBB Media Embed PlugIn
Privacy Policy
Right Side Header Image
Stop Forum Spam
What styles do you currently have installed? My own customised Prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? None at all.
Please describe your problem. No changes have been made to my board since late last year. This morning a member tried to post a new thread in a specific forum and got the error message 'This Page isn't Working' in Chrome (blank white page in Firefox) although the thread was posted. I have the same issue when I try to start a new thread in this forum, but not in other forums in the same category. Posting a reply on a thread that has had this problem also triggers the error message, but existing threads do not have a problem.

There is nothing in the error log.

I know that the site needs updating, but I am currently unable to do so because my broadband speed is too low. I will update it as soon as possible (hopefully later this week), but would like to sort out this problem as soon as possible.
Generated by SRT Generator
Last edited by Acorn on Mon Aug 05, 2019 2:17 pm, edited 1 time in total.
Getting braver all the time. :D
User avatar
warmweer
Jr. Extension Validator
Posts: 6501
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Blank Page on Starting New Topic

Post by warmweer »

Acorn wrote:
Mon Aug 05, 2019 11:37 am
I know that the site needs updating, but I am currently unable to do so because my broadband speed is too low. I will update it as soon as possible (hopefully later this week), but would like to sort out this problem as soon as possible.
You can update on your PC using a personal webserver, and then upload the new files and database at your leisure.
Since you have personalised your prosilver, this will allow you to test the changes with the update before actually using it online.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Acorn
Registered User
Posts: 402
Joined: Tue Sep 26, 2006 8:11 am
Location: UK
Contact:

Re: Blank Page on Starting New Topic

Post by Acorn »

I have a feeling I did this at some point in the past, but I have completely forgotten how I did it. Do you have a link to an idiot's guide? I do have a full, up-to-date backup on my PC.
Getting braver all the time. :D
User avatar
warmweer
Jr. Extension Validator
Posts: 6501
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Blank Page on Starting New Topic

Post by warmweer »

Acorn wrote:
Mon Aug 05, 2019 11:52 am
I have a feeling I did this at some point in the past, but I have completely forgotten how I did it. Do you have a link to an idiot's guide? I do have a full, up-to-date backup on my PC.
https://www.phpbb.com/support/docs/en/3 ... eb-server/

https://www.phpbb.com/support/docs/en/3 ... or-domain/ (also applicable for copying your board to localhost).

The easiest personal webserver to use is USBWEBSERVER https://usbwebserver.yura.mk.ua/ (this is the one for idiots ;) )
If you do have experience, then WAMP/LAMP/XAMP/DevServer are better
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
janus_zonstraal
Registered User
Posts: 5124
Joined: Sat Aug 30, 2014 1:30 pm

Re: Blank Page on Starting New Topic

Post by janus_zonstraal »

Did you ask if your host change something?
Sorry! My English is bat ;) !!!
User avatar
Acorn
Registered User
Posts: 402
Joined: Tue Sep 26, 2006 8:11 am
Location: UK
Contact:

Re: Blank Page on Starting New Topic

Post by Acorn »

I haven't - we have shared hosting and I have to go all around the houses to get to them, but in any case I would have thought that any change would have affected all of the forums in the Category, if not the whole board. It is just one out of 6 forums in the Category, and the other 4 Categories are all fine too.
Getting braver all the time. :D
User avatar
david63
Registered User
Posts: 19038
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Blank Page on Starting New Topic

Post by david63 »

Have you looked in your server error logs as to why you are getting the error (blank page)?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
Acorn
Registered User
Posts: 402
Joined: Tue Sep 26, 2006 8:11 am
Location: UK
Contact:

Re: Blank Page on Starting New Topic

Post by Acorn »

Thank you! I found this error:

AH01071: Got error 'PHP message: PHP Parse error: syntax error, unexpected '$', expecting variable (T_VARIABLE) in /var/www/vhosts/xxxxx.xxx/httpdocs/courtyard/includes/functions_messenger.php on line 28\n', referer: https://www.xxxxx.xxx/courtyard/posting ... ff3d401fd7

I replaced functions_messenger.php with the one from my backup, and everything appears to be fine now.

I'm going to go and compare the old and new files now...
Getting braver all the time. :D
User avatar
Acorn
Registered User
Posts: 402
Joined: Tue Sep 26, 2006 8:11 am
Location: UK
Contact:

Re: [SOLVED] Blank Page on Starting New Topic

Post by Acorn »

warmweer - thank you! It was definitely XAMP I used before. I can't really have got more stupid, so I will take a look at it. :D
Getting braver all the time. :D
User avatar
warmweer
Jr. Extension Validator
Posts: 6501
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: [SOLVED] Blank Page on Starting New Topic

Post by warmweer »

Acorn wrote:
Mon Aug 05, 2019 4:05 pm
warmweer - thank you! It was definitely XAMP I used before. I can't really have got more stupid, so I will take a look at it. :D
Perfect way to keep your backups readable all the time and to test updates/modifications/extensions/styles, etc...
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.2.x] Support Forum”