Problem after updating to 3.3

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Problem after updating to 3.3

Post by jartugas »

After updating to 3.3 I get this error in red in the ACP:

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.

Exception: Class "shredder\sitemap\event\listener" used for service "shredder.sitemap.listener" cannot be found.

This error only stops appearing if I manually desactive all extensions

Wold you have any idea of what can do? Thanks for any help
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Problem after updating to 3.3

Post by Mick »

Did you try activating the extensions one at a time to see which one is causing the problem? I’m guessing but maybe it’s the SEO sitemap?
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
User avatar
david63
Registered User
Posts: 20646
Joined: Thu Dec 19, 2002 8:08 am

Re: Problem after updating to 3.3

Post by david63 »

Extension support should be sought in the support topic for the extension but as that extension is marked as abandoned I would suggest that you disable it.
David
Remember: You only know what you know and - you don't know what you don't know!

I now no longer support any of my extensions but they will start to become available here
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Re: Problem after updating to 3.3

Post by jartugas »

Mick wrote: Thu Jan 30, 2020 3:50 pm Did you try activating the extensions one at a time to see which one is causing the problem? I’m guessing but maybe it’s the SEO sitemap?
Thank you, I enabled the extensions in different order but the problem appears after I activate the first one, regardless which one. the full error I get is:

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.


Exception: Class "shredder\sitemap\event\listener" used for service "shredder.sitemap.listener" cannot be found.

#0 /usr/home/jartigas59/public_html/cichlidae.com/askpam/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\EventDispatcher\DependencyInjection\RegisterListenersPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#1 /usr/home/jartigas59/public_html/cichlidae.com/askpam/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#2 /usr/home/jartigas59/public_html/cichlidae.com/askpam/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#3 /usr/home/jartigas59/public_html/cichlidae.com/askpam/common.php(115): phpbb\di\container_builder->get_container()
#4 /usr/home/jartigas59/public_html/cichlidae.com/askpam/adm/index.php(23): require('/usr/home/jarti...')
#5 {main}

I deleted and uploaded again all files in vendor/symfony/ folder to no avail
User avatar
david63
Registered User
Posts: 20646
Joined: Thu Dec 19, 2002 8:08 am

Re: Problem after updating to 3.3

Post by david63 »

jartugas wrote: Thu Jan 30, 2020 3:56 pm Exception: Class "shredder\sitemap\event\listener" used for service "shredder.sitemap.listener" cannot be found.
The problem is with this extension
david63 wrote: Thu Jan 30, 2020 3:52 pm I would suggest that you disable it.
David
Remember: You only know what you know and - you don't know what you don't know!

I now no longer support any of my extensions but they will start to become available here
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Re: Problem after updating to 3.3

Post by jartugas »

david63 wrote: Thu Jan 30, 2020 3:59 pm
jartugas wrote: Thu Jan 30, 2020 3:56 pm Exception: Class "shredder\sitemap\event\listener" used for service "shredder.sitemap.listener" cannot be found.
The problem is with this extension
david63 wrote: Thu Jan 30, 2020 3:52 pm I would suggest that you disable it.
Interestingly, I dont have a SEO sitemap extension installed, all I have is google analytics (last version), OneAll Social Login and VigLink. The error just disappear if I deactivate all three extensions. Am I missing something? Thanks for your help
User avatar
Lumpy Burgertushie
Registered User
Posts: 69228
Joined: Mon May 02, 2005 3:11 am

Re: Problem after updating to 3.3

Post by Lumpy Burgertushie »

you apparently had it installed at one time.

find the extension, upload the files to the ext folder.
enable it if it is not already. then disable it, then delete the data, then remove the files from the ftp.

this could be because of the extension not being removed properly at some point.


robert
Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Re: Problem after updating to 3.3

Post by jartugas »

Thank you I followed the advice and it worked! Except that I cannot delete the shredder folder from ext/ because it produces a fatal error, but with the files in place and the extension disabled all works.
User avatar
Lumpy Burgertushie
Registered User
Posts: 69228
Joined: Mon May 02, 2005 3:11 am

Re: Problem after updating to 3.3

Post by Lumpy Burgertushie »

did you try deleting the data from the extension management area?

once you do that, it should not call for any of the files so you should not get any errors.

you should always delete data before you try to delete the actual files from ftp.


robert
Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Re: Problem after updating to 3.3

Post by jartugas »

Lumpy Burgertushie wrote: Thu Jan 30, 2020 7:23 pm did you try deleting the data from the extension management area?
I certainly did, I deleted the data before deleting the files, but the error was produced. When I added the extension files again I dont get the option to delete data so probably the extension does not delete all the data after all. I appreciate your help
User avatar
Lumpy Burgertushie
Registered User
Posts: 69228
Joined: Mon May 02, 2005 3:11 am

Re: Problem after updating to 3.3

Post by Lumpy Burgertushie »

try removing everything from the cache folder except for the index and htaccess files.


robert
Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
jartugas
Registered User
Posts: 30
Joined: Fri Aug 31, 2007 9:47 pm
Location: San Luis Potosi
Name: Juan Miguel Artigas Azas

Re: Problem after updating to 3.3

Post by jartugas »

Thanks, I tried again (previously erasing the cache), the error produced is:

phpBB encountered an error building the container due to an installed extension. For this reason, all extensions have been temporarily disabled. Please try purging your forum cache. All extensions will automatically be re-enabled once the container error is resolved. If this error continues, please visit phpBB.com for support.


Exception: Class "shredder\sitemap\event\listener" used for service "shredder.sitemap.listener" cannot be found.

#0 /usr/home/jartigas59/public_html/cichlidae.com/askpam/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\EventDispatcher\DependencyInjection\RegisterListenersPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#1 /usr/home/jartigas59/public_html/cichlidae.com/askpam/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#2 /usr/home/jartigas59/public_html/cichlidae.com/askpam/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#3 /usr/home/jartigas59/public_html/cichlidae.com/askpam/common.php(115): phpbb\di\container_builder->get_container()
#4 /usr/home/jartigas59/public_html/cichlidae.com/askpam/adm/index.php(23): require('/usr/home/jarti...')
#5 {main}
Geepers
Registered User
Posts: 215
Joined: Fri Apr 04, 2014 7:44 am
Location: Tasmania - Australia
Name: Glenn

Re: Problem after updating to 3.3

Post by Geepers »

Did you resolve this issue?
I'm having the same problem
User avatar
Lumpy Burgertushie
Registered User
Posts: 69228
Joined: Mon May 02, 2005 3:11 am

Re: Problem after updating to 3.3

Post by Lumpy Burgertushie »

if it is exactly the same error then it is exactly the same cure.

you need to upload all the files from that sitemap extension to the server where they belong.
the error is telling you that it can't find the files for that extension.

you probably deleted the files before you actually uninstalled the extension properly.


robert
Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
User avatar
warmweer
Jr. Extension Validator
Posts: 11460
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Problem after updating to 3.3

Post by warmweer »

If you can't get rid of the error, take the short route, use your backup and re-upgrade following Upgrading from 3.2 to 3.3
If by any chance you're upgrading from 3.1, use the link on the left (Upgrading from 3.1 to 3.3).

As to 5. Deactivate any extensions which are not compatible with phpBB 3.3. Check with the extension author to find out if an extension is compatible or not.
While still on the previous version: disable the extension, delete data and then delete the extension files.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.

Return to “[3.3.x] Support Forum”