Google webmaster breadcrumbs problems

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Google webmaster breadcrumbs problems

Post by auntie_biotics »

Please forgive me if answer is already given but Im not at all au fait with phpbb3 code.
After using google webmaster on my site https://tbandu.uk/ I have the following message:

BREADCRUMBS
Error: Either "name" or "item.name" should be specified 33items
Error: Missing field "item" 28 items

This has been so since update.
I am using ALLAN-STYLE SUBSILVER

My questions is: IS this the correct answer to set this right?
viewtopic.php?p=15401506#p15401506

or Is this the correct answer?
viewtopic.php?p=15405906#p15405906

or is it neither and do I need to do something else?

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Google webmaster breadcrumbs problems

Post by david63 »

This is fixed and will be in the next version.

There are several topic on this subject.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

Thx for your reply . You are right there are several topics on this. There are also several answers and that is why I asked in previous post which was the correct one.
I will however take your advice and await new version if no one points out correct answer.
I also suppose it will be best to remove site from google till new version available
Better not there at all than all my site pages in error

Swanny
Registered User
Posts: 454
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

Re: Google webmaster breadcrumbs problems

Post by Swanny »

There are more and more people reporting the breadcrumbs issue. How soon until 3.3.1 is released to include this fix and stop the new topics on this issue?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51350
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Google webmaster breadcrumbs problems

Post by stevemaury »

For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

Thankyou so much for link to patch.
Im sorry but have never done any code on phpbb3 .

Do I just copy and paste the whole code into navbar file?

And will this work on other styles based on prosilver?
Thankyou in advance

User avatar
3Di
Former Team Member
Posts: 15455
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Google webmaster breadcrumbs problems

Post by 3Di »

auntie_biotics wrote:
Thu Jan 30, 2020 7:39 pm
Do I just copy and paste the whole code into navbar file?

And will this work on other styles based on prosilver?
No.

For ALLAN-STYLE SUBSILVER ask the authors of that style.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

Thankyou I will switch to prosilver. I have been to github but cannot find instructions on what to do.
I am not sure do I copy and paste code into navbar file.?
I am very sorry if I am being a nuisance.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51350
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Google webmaster breadcrumbs problems

Post by stevemaury »

You should have the navbar_header.html file on your local computer. If not, download it from your phpBB installation. Open it in a good text editor ( Dreamweaver and Frontpage are not good choices when it comes to file editors (find out why). See Tools needed to set up and customise phpBB for suggestions. )

Delete the lines in red and add the lines in green. Save the file. Then, using FTP, rename the existing navbar_headr.html by adding a .bak extension. Then upload the file and purge the cache.

This should work on any prosilver based style, but test it.

EDIT - you are asking this in the 3.3. Support forum, but there is no Allan-style subsilver for 3.3.0. ???
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

I shouldnt kiss strangers but mwahhhhhh!
Im goiing to read carefullly two or three time and follow instructions.
Thankyou so much. :D

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51350
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Google webmaster breadcrumbs problems

Post by stevemaury »

EDIT - you are asking this in the 3.3. Support forum, but there is no Allan-style subsilver for 3.3.0. ???
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

I want to keep thing simple so will change back to original prosilver

User avatar
3Di
Former Team Member
Posts: 15455
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Google webmaster breadcrumbs problems

Post by 3Di »

This is for PROSILVER of phpBB 3.3.0, same applies for 3.2.9

OPEN ROOT\styles\prosilver\template\navbar_header.html

FIND

Code: Select all

	<ul id="nav-breadcrumbs" class="nav-breadcrumbs linklist navlinks" role="menubar">
		<!-- DEFINE $MICRODATA = ' itemtype="http://schema.org/ListItem" itemprop="itemListElement" itemscope' -->
		{% set navlink_position = 1 %}
		<!-- EVENT overall_header_breadcrumbs_before -->
		<li class="breadcrumbs" itemscope itemtype="http://schema.org/BreadcrumbList">
			<!-- IF U_SITE_HOME -->
				<span class="crumb" {$MICRODATA}><a href="{U_SITE_HOME}" itemtype="https://schema.org/Thing" itemscope itemprop="item" data-navbar-reference="home"><i class="icon fa-home fa-fw" aria-hidden="true"></i><span itemprop="name">{L_SITE_HOME}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
			<!-- ENDIF -->
			<!-- EVENT overall_header_breadcrumb_prepend -->
				<span class="crumb" {$MICRODATA}><a href="{U_INDEX}" itemtype="https://schema.org/Thing" itemscope itemprop="item" accesskey="h" data-navbar-reference="index"><!-- IF not U_SITE_HOME --><i class="icon fa-home fa-fw"></i><!-- ENDIF --><span itemprop="name">{L_INDEX}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>

			<!-- BEGIN navlinks -->
				<!-- EVENT overall_header_navlink_prepend -->
				<span class="crumb" {$MICRODATA}<!-- IF navlinks.MICRODATA --> {navlinks.MICRODATA}<!-- ENDIF -->><a href="{navlinks.U_VIEW_FORUM}" itemtype="https://schema.org/Thing" itemscope itemprop="item"><span itemprop="name">{navlinks.FORUM_NAME}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
				<!-- EVENT overall_header_navlink_append -->
			<!-- END navlinks -->
			<!-- EVENT overall_header_breadcrumb_append -->
		</li>
		<!-- EVENT overall_header_breadcrumbs_after -->

		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
			<li class="rightside responsive-search">
				<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}" role="menuitem">
					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
				</a>
			</li>
		<!-- ENDIF -->
	</ul>
REPLACE WITH

Code: Select all

	<ul id="nav-breadcrumbs" class="nav-breadcrumbs linklist navlinks" role="menubar">
		{% set MICRODATA = 'itemtype="https://schema.org/ListItem" itemprop="itemListElement" itemscope' %}
		{% set navlink_position = 1 %}

		{% EVENT overall_header_breadcrumbs_before %}

		<li class="breadcrumbs" itemscope itemtype="https://schema.org/BreadcrumbList">

			{% if U_SITE_HOME %}
				<span class="crumb" {{ MICRODATA }}><a itemprop="item" href="{{ U_SITE_HOME }}" data-navbar-reference="home"><i class="icon fa-home fa-fw" aria-hidden="true"></i><span itemprop="name">{{ L_SITE_HOME }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
			{% endif %}

			{% EVENT overall_header_breadcrumb_prepend %}
				<span class="crumb" {{ MICRODATA }}><a itemprop="item" href="{{ U_INDEX }}" accesskey="h" data-navbar-reference="index">{% if not U_SITE_HOME %}<i class="icon fa-home fa-fw"></i>{% endif %}<span itemprop="name">{{ L_INDEX }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>

			{% for navlinks in navlinks %}
				{% set NAVLINK_NAME = navlinks.BREADCRUMB_NAME | default(navlinks.FORUM_NAME) %}
				{% set NAVLINK_LINK = navlinks.U_BREADCRUMB | default(navlinks.U_VIEW_FORUM) %}

				{% EVENT overall_header_navlink_prepend %}
				<span class="crumb" {{ MICRODATA }}{% if navlinks.MICRODATA %} {{ navlinks.MICRODATA }}{% endif %}><a itemprop="item" href="{{ NAVLINK_LINK }}"><span itemprop="name">{{ NAVLINK_NAME }}</span></a><meta itemprop="position" content="{{ navlink_position }}{% set navlink_position = navlink_position + 1 %}" /></span>
				{% EVENT overall_header_navlink_append %}
			{% endfor %}

			{% EVENT overall_header_breadcrumb_append %}
		</li>

		{% EVENT overall_header_breadcrumbs_after %}

		{% if S_DISPLAY_SEARCH and not S_IN_SEARCH %}
			<li class="rightside responsive-search">
				<a href="{{ U_SEARCH }}" title="{{ lang('SEARCH_ADV_EXPLAIN') }}" role="menuitem">
					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{{ lang('SEARCH') }}</span>
				</a>
			</li>
		{% endif %}
	</ul>
PURGE THE CACHE.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

Wow I am sweating here... Feeling smug because I followed instructions in last post then I saw "Purge the cache"!
I did this logged in and out and my site is still working! I havent messed up!!!
Im off to let google webmaster now and will report back.
Many thx to the helpful AND patient AND clear replies!

User avatar
auntie_biotics
Registered User
Posts: 9
Joined: Thu Jan 30, 2020 2:07 pm
Contact:

Re: Google webmaster breadcrumbs problems

Post by auntie_biotics »

It has a taken a few days...Three in fact but after following the directions above, google now reports ALL pages are valid bar one.
That I can live with.
I would like again to give thanks to all who helped and explained to a newbie.
I am sure others who have the same problem will find this post helpful

Post Reply

Return to “[3.3.x] Support Forum”