Unable to update from 3.3.0 to 3.3.1

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
ccessex
Registered User
Posts: 408
Joined: Sat May 15, 2004 2:04 pm
Location: Stanstead Abbotts
Contact:

Unable to update from 3.3.0 to 3.3.1

Post by ccessex »

I have followed the instructions but keep getting this error

"The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI."

I don't see how this happens as it instantly comes up, it's not like it hangs for any amount of time?

What is CLI?
User avatar
P_I
Registered User
Posts: 1247
Joined: Tue Mar 01, 2011 8:35 pm
Location: Staying home - Calgary
Contact:

Re: Unable to update from 3.3.0 to 3.3.1

Post by P_I »

ccessex wrote:
Mon Aug 31, 2020 12:50 pm
I have followed the instructions but keep getting this error
Which instructions? See Minor Updates Within 3.3.x for the recommended approach and other options.
ccessex wrote:
Mon Aug 31, 2020 12:50 pm
What is CLI?
Command Line Interpreter (CLI). The most recent support topic that might be helpful is CLI Update Help.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
User avatar
ccessex
Registered User
Posts: 408
Joined: Sat May 15, 2004 2:04 pm
Location: Stanstead Abbotts
Contact:

Re: Unable to update from 3.3.0 to 3.3.1

Post by ccessex »

Hi, I was using the Automatic Update

I uploaded the Install & Vendor folders as instructed.

Then pointed the browser to the Install folder, it runs the checks then when clicking on the Update Files button I get the following and it will not proceed.
Screen Shot 09-03-20 at 09.00 PM.JPG
It does this instantly, there is no time passing..
User avatar
warmweer
Jr. Extension Validator
Posts: 5577
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Unable to update from 3.3.0 to 3.3.1

Post by warmweer »

Under the assumption you have no file edits

If you do have file edits: reapply those to the new files (from the Changed files package)

in /store: remove install_config.php, any migrationsXXX and io_lock.lock if present (leaving those will retsrat the autoupdate which is what you don't want).
From /cache remove the installer and production folders
use the Changed files package and upload the extracted directories and files
Start the update following the link posted by P_I

the CLI should only be necessary if you have a very large database.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.3.x] Support Forum”