Bug in the attachment-display

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Holger
Registered User
Posts: 1879
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Bug in the attachment-display

Post by Holger »

Hello,

what is that grey thing in the attachment box?

/Holger
Attachments
attachment-bug2.JPG
attachment-bug2.JPG (19.78 KiB) Viewed 570 times
User avatar
KevC
Support Team Member
Support Team Member
Posts: 71181
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Bug in the attachment-display

Post by KevC »

Scroll bar?
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
Holger
Registered User
Posts: 1879
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Bug in the attachment-display

Post by Holger »

Scroll bar? For what scrolling?
I noticed the same in the Extensions DB
And also here in the forum
Attachments
attachment-bug.JPG
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 5784
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Bug in the attachment-display

Post by HiFiKabin »

I have just checked a few things and it appears to be happening in Chrome and Edge but NOT in Firefox

So maybe its a browser update causing the error, or perhaps its always been there but 'hidden' until now in Chrome and Edge.

https://www.phpbb.com/customise/db/exte ... pic/177226 if you want to test on other browsers

EDIT:- Toggling overflow-x: auto; removes the error

Code: Select all

attachbox dd {
    margin-top: 4px;
    padding-top: 4px;
    clear: left;
    border-top: 1px solid transparent;
    overflow-x: auto; 
Holger
Registered User
Posts: 1879
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Bug in the attachment-display

Post by Holger »

Yes, I am using Chrome

I have this:

Code: Select all

.attachbox dd {
	margin-top: 4px;
	padding-top: 4px;
	clear: left;
	border-top: 1px solid transparent;
	overflow-x: auto;
	overflow-y: hidden;
}
What should I change overflow-x to?
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 5784
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Bug in the attachment-display

Post by HiFiKabin »

To remove it:-

OPEN

styles>{style name}>theme>content.css

FIND

Code: Select all

.attachbox dd {
	margin-top: 4px;
	padding-top: 4px;
	clear: left;
	border-top: 1px solid transparent;
	overflow-x: auto;
}

CHANGE

Code: Select all

	overflow-x: auto;
TO

Code: Select all

	overflow-x: visible;
SAVE>UPLOAD>PURGE BROWSER CACHE

REMEMBER Back up BEFORE editing and thoroughly check its working after you have changed the file. I do not think there should be any issues but you never know. In case of problems, just restore your backup.

EDIT:- Changed edited, and all seems to work OK on my test board.
Holger
Registered User
Posts: 1879
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Bug in the attachment-display

Post by Holger »

Thanks a lot!
User avatar
P_I
Community Team Member
Community Team Member
Posts: 1896
Joined: Tue Mar 01, 2011 8:35 pm
Location: Western Canada 🇨🇦
Contact:

Re: Bug in the attachment-display

Post by P_I »

Holger wrote: Thu Oct 08, 2020 12:23 pm Thanks a lot!
Please remember to open a ticket in phpBB's Issue Tracker, https://tracker.phpbb.com/secure/Create ... fault.jspa, so this problem will get resolved in a future phpBB release.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
Holger
Registered User
Posts: 1879
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: Bug in the attachment-display

Post by Holger »

Done
Post Reply

Return to “[3.3.x] Support Forum”