PHP 7.4 reached EOL

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Harewood
Registered User
Posts: 136
Joined: Sun Feb 17, 2013 12:16 pm

PHP 7.4 reached EOL

Post by Harewood »

Hi,

I'm running board version 3.3.9 and php version 7.4.33.

We received a cPanel notification this morning saying:

New Security Advisor notifications with High importance
PHP 7.4 reached EOL
We strongly recommend that you use a version that is still supported upstream.
If you do continue to use it, you will be susceptible to any remaining bugs or security issues.
We recommend that you use the MultiPHP Manager interface to upgrade your domains to a supported version. Then, uninstall this version in the EasyApache 4 interface. For more information, read PHP EOL Documentation.

When we change our php version to 8.0 and navigate to our homepage we get an error message saying: This page isnt working. HTTP error 500.

If we change our php version to 8.1 we get the error:
General Error
SQL ERROR [ mysqli ]
mysqli_connect function does not exist, is mysqli extension installed? []
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Any advice would be appreciated.

Many thanks,
Jason
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 28139
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: PHP 7.4 reached EOL

Post by Paul »

You, or your host, will need to install the mysqli extension.
User avatar
P_I
Community Team Member
Community Team Member
Posts: 2052
Joined: Tue Mar 01, 2011 8:35 pm
Location: Western Canada 🇨🇦
Contact:

Re: PHP 7.4 reached EOL on 28 Nov 2022

Post by P_I »

I would definitely chose PHP 8.1 based on PHP: Supported Versions. That is what I am using for all my boards.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
Harewood
Registered User
Posts: 136
Joined: Sun Feb 17, 2013 12:16 pm

Re: PHP 7.4 reached EOL

Post by Harewood »

Thank you for your assistance with this and will get the mysqli extension sorted with php 8.1 ;)
douza
Registered User
Posts: 9
Joined: Sun Jun 29, 2003 7:42 pm

Re: PHP 7.4 reached EOL

Post by douza »

We have the Mysqi extension added but it's still not working for some reason.
User avatar
janus_zonstraal
Registered User
Posts: 5934
Joined: Sat Aug 30, 2014 1:30 pm

Re: PHP 7.4 reached EOL

Post by janus_zonstraal »

douza wrote: Tue Jan 24, 2023 6:57 pm We have the Mysqi extension added but it's still not working for some reason.
It is better to start your own topic.
And:
When starting a new topic, be sure to fill out the Support Request Template. If you don't know the answer to something, leave it blank. Keep in mind, however, that more details will help us answer your question more accurately.
Sorry! My English is bat ;) !!!
Post Reply

Return to “[3.3.x] Support Forum”