3.3.11 - what is newest PHP & MySQL versions supported?

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Swanny
Registered User
Posts: 486
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

3.3.11 - what is newest PHP & MySQL versions supported?

Post by Swanny »

Hi, my forums run 3.3.11, I am running PHP 7.4.33 and MySQL 5.7

My web host provider has brought to my attention I need to update my server software. They recommend MySQL 8 and PHP 8.1 and 8.2.

Is MySQL 8 fine and PHP 8.2 or should I only go to 8.1 ? Thanks, I could only find minimum requirements in the knowledge base.

I don't know if it matters but O/S is CentOS 7 and they want me to switch to AlmaLinux.
Last edited by Mick on Fri Dec 08, 2023 8:00 am, edited 1 time in total.
Reason: Solved.
User avatar
warmweer
Jr. Extension Validator
Posts: 11407
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by warmweer »

Swanny wrote: Thu Dec 07, 2023 6:12 am Hi, my forums run 3.3.11, I am running PHP 7.4.33 and MySQL 5.7

My web host provider has brought to my attention I need to update my server software. They recommend MySQL 8 and PHP 8.1 and 8.2.

Is MySQL 8 fine and PHP 8.2 or should I only go to 8.1 ? Thanks, I could only find minimum requirements in the knowledge base.

I don't know if it matters but O/S is CentOS 7 and they want me to switch to AlmaLinux.
PHP 8.0, 8.1 are certainly OK.
As to PHP 8.2: I know a couple of boards using it, and I've got a testboard using PHP 8.2 without any issues up to now.

As to MySQL 8 ... no idea.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
rxu
Extensions Development Team
Posts: 3773
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by rxu »

Automated tests pass successfully on PHP 8.2 (and PHP 8.3 for development 3.3.x branch -> upcomung v.3.3.12). Also tests pass for 3.3.11&MySQL 8 without errors.
https://github.com/phpbb/phpbb/actions/runs/6604327705
Swanny
Registered User
Posts: 486
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by Swanny »

warmweer wrote: Thu Dec 07, 2023 7:53 amPHP 8.0, 8.1 are certainly OK.
As to PHP 8.2: I know a couple of boards using it, and I've got a testboard using PHP 8.2 without any issues up to now.
As to MySQL 8 ... no idea.
Thanks.
rxu wrote: Thu Dec 07, 2023 8:19 am Automated tests pass successfully on PHP 8.2 (and PHP 8.3 for development 3.3.x branch -> upcomung v.3.3.12). Also tests pass for 3.3.11&MySQL 8 without errors.
https://github.com/phpbb/phpbb/actions/runs/6604327705
Thanks.

I forgot to mention that I can have multiple PHP installs but only one MySQL. So if I convert from MySQL 5.7 to 8 there is no going back. MySQL 8 support is important to know for sure.

Does the MySQL 8 automated testing mean I should be safe to switch to 8? I guess I should maybe do some more searching here to make sure people are actually running that on production forums..?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26679
Joined: Fri Aug 29, 2008 9:49 am

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by Mick »

Try it on a PWS first.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
Swanny
Registered User
Posts: 486
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by Swanny »

Mick wrote: Thu Dec 07, 2023 8:07 pm Try it on a PWS first.
What is PWS?
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 52780
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by stevemaury »

Private web server, like XAMPP.
I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
Swanny
Registered User
Posts: 486
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

Re: 3.3.11 - what is newest PHP & MySQL versions supported?

Post by Swanny »

I have switched all my forums from phpBB 7.4 to 8.1 and everything seems fine.

Return to “[3.3.x] Support Forum”