Front Page Not Loading + Extensions not showing [Solved]

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Front Page Not Loading + Extensions not showing

Post by Mick »

Those errors look like a WP issue to me and most of them are from January. Do you know what your host meant by using WP so that they can help you?

Incidentally, I notice you’re using nginx. When you installed phpBB did you use the nginx.sample.conf? I believe there’s a copy of this in the download package.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

Mick wrote: Fri Feb 23, 2024 8:30 pm Those errors look like a WP issue to me and most of them are from January. Do you know what your host meant by using WP so that they can help you?


Incidentally, I notice you’re using nginx. When you installed phpBB did you use the nginx.sample.conf? I believe there’s a copy of this in the download package.
They asked if I was working on WP and I clarified that I was using phpBB. Their response was that I should be using WP as they (Bluehost) can assist with WP issues, but that they don't help with third parties or phpBB. They largely ignored that I was only asking for the server logs as requested by phpBB support and wasn't seeking help otherwise.

I'm not sure about the nginx. warmweer would be correct that I did a different installation and that could be part of why I'm experiencing this issue. I don't know what the nginx is, honestly. I quite literally just uploaded files in the host based off of tutorial videos. The site worked for about a week and then started just giving the blank white screen, so I'm not sure what happened.
Last edited by nomadic one on Fri Feb 23, 2024 8:40 pm, edited 1 time in total.
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Front Page Not Loading + Extensions not showing

Post by Mick »

Mick wrote: Fri Feb 23, 2024 8:30 pmIncidentally, I notice you’re using nginx. When you installed phpBB did you use the nginx.sample.conf? I believe there’s a copy of this in the download package.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

I'm not sure about the nginx. warmweer would be correct that I did a different installation and that could be part of why I'm experiencing this issue. I don't know what the nginx is, honestly. I quite literally just uploaded files in the host based off of tutorial videos. The site worked for about a week and then started just giving the blank white screen, so I'm not sure what happened.

Sorry, I saw your edit after I'd replied. I'll give responses a few minutes in case there are other edits. This is to the nginx bit though.
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Front Page Not Loading + Extensions not showing

Post by Mick »

The issues you’re seeing could well be down to a failed nginx installation.

How many users and posts do you have?
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

Mick wrote: Fri Feb 23, 2024 8:47 pm The issues you’re seeing could well be down to a failed nginx installation.

How many users and posts do you have?
I'll take any tips on trying to do a proper nginx installation then and see if that helps, if you don't mind?

As for users, it's just my account and another administrator that hasn't done anything yet (outside of adding "left" "right" "justify" type stuff for posting options). As for posts, there's just the generic "this is your general board and forum" welcome post that was auto-generated. We intended to get the site set up properly before actually posting on there
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Front Page Not Loading + Extensions not showing

Post by Mick »

In that case I’d be inclined to delete what you have already and re-install in an Apache (or similar Linux based software) installation. You may have to ask your host but I see they offer Apache.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

Mick wrote: Fri Feb 23, 2024 8:58 pm In that case I’d be inclined to delete what you have already and re-install in an Apache (or similar) installation. You may have to ask your host but I see they offer Apache.
I have no idea what that is, but I'll do my best to find guides to figure it out. Thank you!
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: Front Page Not Loading + Extensions not showing

Post by Mick »

There is supplied Apache documentation on your host site but it might be easier to ask your host to do it for you it’s literally five minutes work.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

I will definitely give that a try!
I really appreciate everyone's help and patience with my problems so far. Fingers crossed I'll be out of your hair soon though!

Would I need to remove the phpBB before I contact them, do you think?
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
User avatar
P_I
Community Team Member
Community Team Member
Posts: 2403
Joined: Tue Mar 01, 2011 8:35 pm
Location: Western Canada 🇨🇦

Re: Front Page Not Loading + Extensions not showing

Post by P_I »

A data point to offer.

I have sites running on Bluehost shared hosting and it is my belief that they use nginx as some sort of front-end load-balancing/caching/reverse-proxy at the server configuration level that is NOT configurable by the phpBB board admin.

From the phpBB board admin perspective the site is running on Apache.

The OP should likely be able to find their PHP log file in the board's root directory in the file error_log.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

Bluehost support said they aren't authorized to help and to contact the developer.

P_I wrote: Fri Feb 23, 2024 10:09 pm A data point to offer.

I have sites running on Bluehost shared hosting and it is my belief that they use nginx as some sort of front-end load-balancing/caching/reverse-proxy at the server configuration level that is NOT configurable by the phpBB board admin.

From the phpBB board admin perspective the site is running on Apache.

The OP should likely be able to find their PHP log file in the board's root directory in the file error_log.
Is there a third spot for error logs? I've provided server error logs from the cpanel and I've checked in phpBB's ACP and found no error logs listed under Maintenance > Error Logs. I'm sorry to ask for further clarification but is this found in the phpBB admin control panel or in Bluehost's cPanel (and if so, where should I look to find it?)

--
Uninstalled phpBB successfully, but now I have to try to understand the installation instructions. Based on what I think I'm understanding, I have to manually create a database in my cPanel before I can upload it? I'm seeing mixed feedback on other support threads on whether or not you should use the cPanel in order to upload files.I have downloaded an FTP but I really don't understand how to use it. When I did finally manage to add an extension to the phpBB board prior to uninstalling, it was through the cPanel and it was the only way that the extension was showing up for me in the ACP, so I'm skeptical about using the FTP in the first place.
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)
nomadic one
Registered User
Posts: 22
Joined: Thu Feb 22, 2024 1:27 am

Re: Front Page Not Loading + Extensions not showing

Post by nomadic one »

This topic can be marked as solved! I'm editing the title as well to reflect that!

I've spent most of today with the handy ol' Google to look up....pretty much everything terminology-related, but I've successfully installed phpBB (the proper way this time) and an extension and everything looks like it ought to! (Fingers crossed the site doesn't go back to the white screen of death again in a week LOL)

My only feedback is that a lot of the manual, user guides, and responses assume that you have at least a bit of knowledge about coding, web design, etc., which obviously makes it challenging for anyone picking this up for the first time.
However, you all were very patient with my many questions & general lack of knowledge and I greatly appreciate all the help you've given!
total newbie and dummy when it comes to phpBB, coding, web design, etc. so please dumb things down like you're talking to a 1st grader (or preferably, the most computer illiterate grandmother ever)

Return to “[3.3.x] Support Forum”