New Install - https://localhost:80

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
kramem
Registered User
Posts: 5
Joined: Thu Feb 22, 2024 1:10 am

New Install - https://localhost:80

Post by kramem »

First HI EVERYONE!!! Newbie here.

I installed the current version of phpBB. Everything went smoothly but then....

Problem : After logging on I tried to go to the administrator panel. That's when the above started happening.

That is : https://localhost:80/phpbb/adm....

No matter what screen I went to the above is what I would get. I thought that maybe because I had put an SSL certificate for localhost that maybe that triggered phpBB to try to switch to HTTPS. HOWEVER, that weird LOCALHOST:80 kept coming up also. I have removed the localhost SSL certificate from my system. So now phpBB should just use HTTP - but it doesn't. I just rebooted and I am still getting this https://localhost:80.

Ideas on what is wrong?

Also, if this is a known issue - can you point me to the link I need to go read? Thanks!

And as always - Thank you SO much for reading this post and answering. I really appreciate it. :-)

Mark
Last edited by Mick on Sat Mar 02, 2024 9:55 am, edited 1 time in total.
Reason: Solved.
User avatar
warmweer
Jr. Extension Validator
Posts: 11450
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: New Install - https://localhost:80

Post by warmweer »

kramem wrote: Thu Feb 22, 2024 2:19 am
That is : https://localhost:80/phpbb/adm....

Edit:
I'm not very alert this morning: deleted an incorrect answer I gave.

janus_zonstraal's answer (next post) is correct :thumbsup:
Last edited by warmweer on Thu Feb 22, 2024 8:31 am, edited 1 time in total.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
janus_zonstraal
Registered User
Posts: 6476
Joined: Sat Aug 30, 2014 1:30 pm

Re: New Install - https://localhost:80

Post by janus_zonstraal »

Try to disable the "Force server URL settings:" in ACP general => Server settings
Sorry! My English is bat ;) !!!
kramem
Registered User
Posts: 5
Joined: Thu Feb 22, 2024 1:10 am

Re: New Install - https://localhost:80

Post by kramem »

Hi Janus_zonstraal! Thanks for answering.

As I posted - Newbie here.

I looked for "force server", "URL settings" and for all ACP files.

There isn't an ACP "general" file. I did find 'acp board.php' but no general file. Can you provide the actual file name? Thanks if you can!

I did find a couple of words (using FileLocator which can scan inside of files for text) and the only entry I found with URL in it is a radio button and I am pretty sure that is not what you are talking about. If you can show me the line I need to change I can copy/paste it into FileLocator and that will find it and allow me to change it.

I really appreciate your responding.
And I know - dumb newbie. :-)

Mark
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: New Install - https://localhost:80

Post by Mick »

Where you’re being pointed towards “General” that’s one of the tabs in the ACP index window not a file to look for:

IMG_0363.jpeg

so, in the ACP check that the “General” tab is selected then follow the list down on the left hand side to “SERVER CONFIGURATION” and click on “Server settings” then you’ll see “Force server URL settings:" yes/no.
You do not have the required permissions to view the files attached to this post.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
kramem
Registered User
Posts: 5
Joined: Thu Feb 22, 2024 1:10 am

Re: New Install - https://localhost:80

Post by kramem »

Got it! Thanks a million Mick!!!!

Still reading up on what all phpBB can do but this really - really helps a lot!
kramem
Registered User
Posts: 5
Joined: Thu Feb 22, 2024 1:10 am

Re: New Install - https://localhost:80

Post by kramem »

And (of course) what was the one thing I did NOT do?

Save.

Ugh. But I fought my way back to the same screen, changed everything again, and then saved it.

(Hits head against monitor)

Thanks again!
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: New Install - https://localhost:80

Post by Mick »

Did that fix you’re issue?
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
kramem
Registered User
Posts: 5
Joined: Thu Feb 22, 2024 1:10 am

Re: New Install - https://localhost:80

Post by kramem »

Yes, it did. Thanks again to you Mick!

Return to “[3.3.x] Support Forum”