Multiple.Users Unable to see Public Forum

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
deaddmwalking
Registered User
Posts: 2
Joined: Sun Apr 07, 2024 10:43 pm

Multiple.Users Unable to see Public Forum

Post by deaddmwalking »

We've had several users report the same issue. Whether logged in or logged out, when accessing a forum they get a page not found error. The page they're directed to is:
http://www.tgdmb.com/phpBB3/500.shtml

Which gives anyone accessing the error, but the link ends with viewforum.php?f=3 for everyone not having this error. Some users report it cleared after a few days, but it appears across different browsers and devices.

When using the admin function to emulate the user there were no issues. Since it is an issue whether logged in or out it doesn't appear to be a permissions issue and the forum is public. With three people confirming it has been an issue we'd like to figure out whether there's something in the forum code that drives it, but we're not doing anything special. I'm not the admin, but the admin is pretty busy so I volunteered to post about the issue and see if this is something anyone else has heard of?

Thanks in advance!
User avatar
SpIdErPiGgY
Registered User
Posts: 243
Joined: Sun May 02, 2021 2:11 pm
Location: Erpe-Mere, Aalst, BE
Name: Andy Dm

Re: Multiple.Users Unable to see Public Forum

Post by SpIdErPiGgY »

Chech the server error logs.
a 500 error is a misconfiguration on your server
phpBB NL Extension translations, also on request.
--> Click Here: Myarea51secrets.com <--
deaddmwalking
Registered User
Posts: 2
Joined: Sun Apr 07, 2024 10:43 pm

Re: Multiple.Users Unable to see Public Forum

Post by deaddmwalking »

I appreciate the response and I've asked the admin to check the logs. If it was a misconfiguration we'd expect it to apply to everyone, wouldn't we?

So far three different people have reported it but not at the same time. One said it was an issue for them for a few days then cleared up on its own. The person who reported it that started us looking says it was happening every time but now it is happening less often (and Chrome is the only browser that sometimes works).

If it were happening to everyone it would be simple; if it was user permissions it would be simple. If it happens to a user across browsers and devices whether they're logged in or not would it be plausible that a cookie or extension from another site could be causing an error? Something with an ad blocker maybe?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26708
Joined: Fri Aug 29, 2008 9:49 am

Re: Multiple.Users Unable to see Public Forum

Post by Mick »

Has the board been working as it is now ok before this issue started? If so something has changed to cause the problem and if you (speak: admin) has done nothing to cause it then the only other reason can be the host has done something such as changed the PHP version etc, hence interrogating the server error logs is likely to give you some idea of what’s causing the problem. It may be worth checking the nginx logs too. Also, although this is probably nothing to do with this issue there needs to be a redirect in .htaccess from http to https to stop users accessing the board via http, in fact the link you provided has http. I also note the board is version 3.2.11 so I’ll move this to the correct forum.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
User avatar
warmweer
Jr. Extension Validator
Posts: 11472
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Multiple.Users Unable to see Public Forum

Post by warmweer »

Assuming your certificate is valid, your cookie_secure setting has to be set to true (currently it's set to false). (and as Mick pointed out, you should add a redirect to https in .htaccess).
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.

Return to “[3.2.x] Support Forum”