Error after purging cache

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Stoker 4.0
Registered User
Posts: 1504
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen

Error after purging cache

Post by Stoker 4.0 »

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/symfony/config/FileLocator.php on line 60: file_exists(): open_basedir restriction in effect. File([ROOT]/../../default/routing/routing.yml) is not within the allowed path(s): (/var/www/vhosts/phpbb3bbcodes.com/:/tmp/)
I get this error everytime i purge cache. I only get it once. After refreshing the page it disappears.
I dont think its an open_basedir problem. I have other boards on same server also running latest phpbb version.

I used the full package update, replacing all files with newest files.
All extensions are disabled and data deleted.
Regards Stoker
User avatar
warmweer
Jr. Extension Validator
Posts: 11450
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error after purging cache

Post by warmweer »

I suspect it's an incompatibility between 3.3.11 and PHP 8.3.7.
Try switching to PHP 8.2.x just to test that.

Added: just tried on Wamp with PHP 8.3.4 on a clean board: not getting that error.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
Stoker 4.0
Registered User
Posts: 1504
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen

Re: Error after purging cache

Post by Stoker 4.0 »

warmweer wrote: Mon May 20, 2024 8:34 am I suspect it's an incompatibility between 3.3.11 and PHP 8.3.7.
Try switching to PHP 8.2.x just to test that.

Added: just tried on Wamp with PHP 8.3.4 on a clean board: not getting that error.
8.2.19 produces same error.
Also, another board on same server and php version produces no error
Regards Stoker
User avatar
warmweer
Jr. Extension Validator
Posts: 11450
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error after purging cache

Post by warmweer »

Stoker 4.0 wrote: Mon May 20, 2024 10:11 am ...
Also, another board on same server and php version produces no error
The board in your first post doesn't have cookie_secure enabled.
Does the other board have cookie_secure enabled?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
Stoker 4.0
Registered User
Posts: 1504
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen

Re: Error after purging cache

Post by Stoker 4.0 »

warmweer wrote: Mon May 20, 2024 11:21 am
Stoker 4.0 wrote: Mon May 20, 2024 10:11 am ...
Also, another board on same server and php version produces no error
The board in your first post doesn't have cookie_secure enabled.
Does the other board have cookie_secure enabled?
Yes, but changing it didnt do the trick
Regards Stoker
MortallCsAl3x
Registered User
Posts: 80
Joined: Fri Apr 14, 2023 5:01 pm
Location: Romania
Name: Alex Cornea

Re: Error after purging cache

Post by MortallCsAl3x »

Hy! Try to stop the gzip compression in your web panel.
And the php version i recomanded 7.4
:roll: Forum - https://www.worldcs.ro - Gaming Community PHPBB3
:arrow: Counter-Strike 1.6 download - https://www.cstrike16.eu
User avatar
Stoker 4.0
Registered User
Posts: 1504
Joined: Sun Feb 13, 2011 1:33 pm
Location: Funen, Denmark
Name: Ulrik Christensen

Re: Error after purging cache

Post by Stoker 4.0 »

Fixed it!
I did a wrong file edit to display load time.
Sorry ;)
Regards Stoker
User avatar
warmweer
Jr. Extension Validator
Posts: 11450
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error after purging cache

Post by warmweer »

MortallCsAl3x wrote: Mon May 20, 2024 2:51 pm And the php version i recomanded 7.4
Why?
It's outdated (not to mention EOL) and should really only be used if the host doesn't offer anything more recent.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.

Return to “[3.3.x] Support Forum”