[Tool] phpBB 2.0.15 to phpBB 2.0.16 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
71
80%
Very Good
9
10%
Good
2
2%
Fair
2
2%
Poor
5
6%
 
Total votes: 89

Forau
Registered User
Posts: 57
Joined: Sat Apr 26, 2003 9:44 pm
Contact:

Post by Forau » Mon Jun 27, 2005 9:00 pm

Heh, that's only partially possible, since the file ends at line 1334.

Code: Select all

	);
	display_post_attachments($postrow[$i]['post_id'], $postrow[$i]['post_attachment']);
}

if ( $show_qr_form )
{
	$template->assign_block_vars('switch_quick_reply', array());
	include($phpbb_root_path . 'includes/viewtopic_quickreply.'.$phpEx);
}

$template->pparse('body');

include($phpbb_root_path . 'includes/page_tail.'.$phpEx);

?>
Also, is this code correct? I copied it from the file, but it doesn't look right with the singular "else".

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 455
		$avatar_sql = user_avatar_delete($userdata['user_avatar_type'], $userdata['user_avatar']);
	}

#
#-----[ AFTER, ADD ]---------------------------------------------
# 
	else


# 
#-----[ OPEN ]--------------------------------------------- 
# 
modcp.php

Ex0dus
Registered User
Posts: 98
Joined: Mon Nov 01, 2004 1:17 am
Location: Zarasu, Lithuania
Contact:

Post by Ex0dus » Mon Jun 27, 2005 9:32 pm

Can anyone point out the exact sql changes between 2.0.15 and 2.0.16 for me? Other than the version number change, I dont see any. Are there any other changes between 2.0.15 and 2.0.16? Im just double checking before i run the install file (as i always like to know exactly what im changing in the db before i do it).

-Ex0dus

User avatar
mobilemick
Registered User
Posts: 86
Joined: Sun Mar 27, 2005 9:43 pm
Location: UK Bolton
Contact:

:) :) :) :) :) :)

Post by mobilemick » Mon Jun 27, 2005 9:33 pm

I am also stuck with 2.2 instructions, cant find that line anywhere, what i do..........

thanks
mick

Saint_hh
Registered User
Posts: 362
Joined: Thu Mar 31, 2005 5:16 pm
Location: Hamburg / Germany
Name: Kevin
Contact:

Post by Saint_hh » Mon Jun 27, 2005 9:34 pm

Ex0dus wrote: Can anyone point out the exact sql changes between 2.0.15 and 2.0.16 for me? Other than the version number change, I dont see any.

And thats it - there aren't any. :D

v-h
Registered User
Posts: 15
Joined: Mon Nov 22, 2004 3:49 pm

Post by v-h » Mon Jun 27, 2005 9:43 pm

everything went as expected :)

User avatar
mobilemick
Registered User
Posts: 86
Joined: Sun Mar 27, 2005 9:43 pm
Location: UK Bolton
Contact:

:) :) :) :) :) :)

Post by mobilemick » Mon Jun 27, 2005 9:45 pm

everything went as expected



So how did you manage part 2.2 then :)


Mick

ViPeR5000
Registered User
Posts: 34
Joined: Sat Dec 13, 2003 7:44 am
Location: Portugal
Contact:

Post by ViPeR5000 » Mon Jun 27, 2005 10:07 pm

very nice thks team

User avatar
ChrissySkyking
Registered User
Posts: 49
Joined: Fri Feb 04, 2005 6:44 pm

Post by ChrissySkyking » Mon Jun 27, 2005 10:23 pm

Great MOD!! Saved me so much time (I administer 9 installations of phpBB!!). Only one with a problem, and that seems to have been a previous mod that was the culprit.

Thanks!!!

egriz
Registered User
Posts: 441
Joined: Tue Jun 11, 2002 9:49 pm

Post by egriz » Mon Jun 27, 2005 11:06 pm

i did this and it is all ok except for the fact that I can;t get into my admin panel anymore. Everytime I click the link for admin panel it says I have to reauthenticate. So i reenter my info press enter and it just clears the login info and asks for it again!

Any ideas?

User avatar
panda317
Registered User
Posts: 18
Joined: Wed Apr 28, 2004 1:41 am
Location: Danvers, MA, USA
Contact:

here's my nickel...

Post by panda317 » Mon Jun 27, 2005 11:23 pm

Flawless...

...of *course*!

;-)
Regards,

Pat (Patrick E. Rosenheim)
http://patrosenheim.com

Desummoner
Registered User
Posts: 8
Joined: Wed Sep 03, 2003 1:36 am

Post by Desummoner » Mon Jun 27, 2005 11:25 pm

Hi, All.
The next in case someone needs it.

My board in not so heavily modded, but there's a little...
Original mod version conflicts with my installed categories hierarchy mod.
So, there're problems with directives

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$new_forum_id = intval($HTTP_POST_VARS['new_forum']);
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$new_forum_id = intval($HTTP_POST_VARS['new_forum_id']);
				$topic_time = time();
As second search string in each directive still unique (in my case, at least), directives can be fixed by removing first serch string of each directive so they are become respectively:

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$topic_time = time();
In my case it solved problem and EM had applied mod with no probs.

And big thanks to Acyd Burn for fast release of this mod (and prev. mods as well).

User avatar
3Di
Former Team Member
Posts: 14230
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Post by 3Di » Mon Jun 27, 2005 11:43 pm

Desummoner wrote: Hi, All.
The next in case someone needs it.

My board in not so heavily modded, but there's a little...
Original mod version conflicts with my installed categories hierarchy mod.
So, there're problems with directives

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$new_forum_id = intval($HTTP_POST_VARS['new_forum']);
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$new_forum_id = intval($HTTP_POST_VARS['new_forum_id']);
				$topic_time = time();
As second search string in each directive still unique (in my case, at least), directives can be fixed by removing first serch string of each directive so they are become respectively:

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$topic_time = time();
In my case it solved problem and EM had applied mod with no probs.

And big thanks to Acyd Burn for fast release of this mod (and prev. mods as well).


Yeah, this is related to modcp.php, i did it manually into a CH 2.1.1 RC5, so no probs. ;)

admin/admin_ug_auth.php it is Managed by CH RC5, so i missed to edit that file (it doesn't exists on CH).

Everything seems to be allright (just in case, I have the backup of files).

install/update_to_latest.php have to be executed, in order to change the phpbb2 version number.

Greets
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

stardotstar
Registered User
Posts: 70
Joined: Fri Aug 01, 2003 2:07 am
Location: Brisbane, Australia
Contact:

Heavily Modded 2.0.15 mod installed perf3ctly

Post by stardotstar » Mon Jun 27, 2005 11:49 pm

Everything went exactly as expected! Thanks once again for a great update :)

Regards,
Will.*
\x!\\_

Revo1
Registered User
Posts: 21
Joined: Wed Nov 26, 2003 2:23 am
Location: Michigan
Contact:

Post by Revo1 » Tue Jun 28, 2005 1:56 am

Smooth update! Thanks for the great tutorial.
www.pxalive.com - web design at your service.

chattalk
Registered User
Posts: 173
Joined: Fri Mar 18, 2005 3:42 am

Post by chattalk » Tue Jun 28, 2005 2:38 am

I did the code changes, and then just ran the update_to_latest.php and i get these warnings:

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 47

Warning: main(./../config.): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/chattalk/public_html/forums/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.

?? :?

Post Reply

Return to “[2.0.x] MOD Database Releases”