phpBB2 install issues

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
FiveO
Registered User
Posts: 5
Joined: Sun Sep 18, 2005 12:03 am
Location: Rochester, MN

phpBB2 install issues

Post by FiveO »

I keep getting the error:

The PHP configuration on your server doesn't support the database type that you chose

Now I have read here about phpbb not supporting php 5.0.5 but this is what I have.

OS: Red Hat Enterprise Linux 3
Web Server: Apache 2.0.46

PHP version returned when I run php -v command is php 5.0.5

PHP version returned when I use <?phpinfo()?> webpage is php 4.3.2

Now I realize that the server has php 5.0.5 but it appears that Apache is using the php4 module as it returns version 4.3.2 Would this cause me to receive the error that I am getting??

User avatar
Anon
Former Team Member
Posts: 7019
Joined: Fri Jan 02, 2004 7:33 am
Location: Christchurch, New Zealand

Post by Anon »

Try Downgrading to php4.4, as

a) phpBB is not supported on php5
b) MySQL supported out of the box, so you won't get this error

FiveO
Registered User
Posts: 5
Joined: Sun Sep 18, 2005 12:03 am
Location: Rochester, MN

Post by FiveO »

Sorry I forgot to mention that I was using MySQL 4.1

Is there going to be a version of phpbb that supports php 5.0.5 in the near future??

User avatar
tahoebuff
Registered User
Posts: 1429
Joined: Tue Jul 20, 2004 12:33 am
Location: Nevada
Name: Michael
Contact:

Post by tahoebuff »


FiveO
Registered User
Posts: 5
Joined: Sun Sep 18, 2005 12:03 am
Location: Rochester, MN

Post by FiveO »



Thanks for the link tahoebuff. :)

FiveO
Registered User
Posts: 5
Joined: Sun Sep 18, 2005 12:03 am
Location: Rochester, MN

Post by FiveO »

Ok so I still got the error with that version of phpbb.

So I downloaded and installed php 4.4.0

I used the --with-mysql option with the configure and installed it.

I stopped and restarted Apache and am still getting the error.

I verify php is version 4.4.0 with the php -v command.

When I run a <?phpinfo()?> it returns php 4.3.2.

Any other ideas?? I have never had an issue like this before. :?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29256
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

FiveO wrote: I verify php is version 4.4.0 with the php -v command.
When I run a <?phpinfo()?> it returns php 4.3.2.

Then something is clearly wrong
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

FiveO
Registered User
Posts: 5
Joined: Sun Sep 18, 2005 12:03 am
Location: Rochester, MN

Post by FiveO »

Marshalrusty wrote:
FiveO wrote:I verify php is version 4.4.0 with the php -v command.
When I run a <?phpinfo()?> it returns php 4.3.2.

Then something is clearly wrong


I know but I am not sure why I have the discrepancy in versions. Do I have to manually copy over the module into the modules directory for php 4.4.0?? Other than that I am unsure of what it could possibly be.

Locked

Return to “2.0.x Support Forum”