Solution Found.

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Solution Found.

Post by felguard »

I get this message:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
I had back up everything from my old host, so I'm trying to get things back to where they were with my new host. Heres what I've done:

1. Restored Home Directory in Cpanel (came with directory named forums)
2. Installed phpbb (in directory forum without the s)
3. Logged in to adminstration panel in phpbb, and restored phpbb_sql_db
4. I then changed the config.php in forums directory to the one in forum directory
5. I get the above message when accessing it
6. I have no idea how off my way of trying to restore was

I have no clue in how to restore a database, can anyone help me with this? Thank you.
Last edited by felguard on Sun Jan 08, 2006 8:59 am, edited 1 time in total.
iHeartLED.com - Love Your LED Endlessly

User avatar
Lumpy Burgertushie
Registered User
Posts: 67372
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

first , make sure that the install and contrib folders are deleted.

then make sure that the config.php file is not empty


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Post by felguard »

Both folders deleted.

The file config.php is not clear.

Thanks though.
iHeartLED.com - Love Your LED Endlessly

User avatar
Lumpy Burgertushie
Registered User
Posts: 67372
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

felguard wrote: Both folders deleted.

The file config.php is not clear.

Thanks though.


how about a link to your board so we can see.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Post by felguard »

http://www.deimonhigh.com/forums/

Could you tell me step by step how to restore the forums correctly please if possible? Thanks.
iHeartLED.com - Love Your LED Endlessly

User avatar
Lumpy Burgertushie
Registered User
Posts: 67372
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

your config.php file is either corrupted or blank.

open it in a text editor, like wordpad or even notepad

make sure it looks like this:

Code: Select all

<?php


// phpBB 2.x auto-generated config file
// Do not change anything in this file!

$dbms = 'mysql4';

$dbhost = 'localhost';   // this might be different for you
$dbname = 'your info here'; //your database name
$dbuser = 'your info here';  //your database username
$dbpasswd = 'your info here';  //your database password

$table_prefix = 'phpbb_'; //this is default, yours may be different

define('PHPBB_INSTALLED', true);

?>
and make sure there are no empty lines and/or spaces before the opening <? or after the ending ?>

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Post by felguard »

My config.php is:

Code: Select all

<?php


// phpBB 2.x auto-generated config file
// Do not change anything in this file!

$dbms = 'mysql';

$dbhost = 'localhost';
$dbname = 'dbnamehere';
$dbuser = 'dbuserhere';
$dbpasswd = 'dbpwhere';

$table_prefix = 'phpbb_';

define('PHPBB_INSTALLED', true);

?>
iHeartLED.com - Love Your LED Endlessly

User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Post by felguard »

Errr, I fixed the solution. Why am I going Err, when I fixed it? Heres why:

http://www.codedfx.com/forums/index.php?showtopic=6886

Thank you for your help though, means a lot especially when no one else is answering. :D
iHeartLED.com - Love Your LED Endlessly

User avatar
Lumpy Burgertushie
Registered User
Posts: 67372
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

felguard wrote: Errr, I fixed the solution. Why am I going Err, when I fixed it? Heres why:

http://www.codedfx.com/forums/index.php?showtopic=6886

Thank you for your help though, means a lot especially when no one else is answering. :D

that link requires registering or something.

how about just sharing what the problem was.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

User avatar
felguard
Registered User
Posts: 68
Joined: Tue Oct 18, 2005 7:41 am
Contact:

Post by felguard »

Install phpBB, export the queries on your old database with phpMyAdmin, run those same queries on your new database.

The end.

That was it. lol. :D
iHeartLED.com - Love Your LED Endlessly

Locked

Return to “2.0.x Support Forum”