Visual Confirmation Problem (FIXED!)

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
ckcelite
Registered User
Posts: 8
Joined: Wed Oct 04, 2006 5:10 pm

Visual Confirmation Problem (FIXED!)

Post by ckcelite » Wed Oct 04, 2006 5:31 pm

Hi everyone, i seem to have a problem with the stock visual confirmation.
if i enable it in the acp everything seems to work fine until soemone tries to register a new account: right after they click that they are over 13 the following error appears;

Code: Select all

General Error
 
Could not delete stale confirm data

DEBUG MODE

SQL Error : 1146 Table 'sccdb.sccdb_confirm' doesn't exist

DELETE FROM sccdb_confirm WHERE session_id NOT IN ('1b74ab39dbe6e74a703dbd132a2d5fe7', '75ec1fd0888a02b4529f54c2b4ec7c57', '9bba41ef8289ba19079793cc4665b9de')

Line : 981
File : usercp_register.php
I have tried uninstalling and reinstalling (while still using the same database, cant lose all the messages and such.) and had a vanilla board, still this error.

now i installed crackertracker, (hoping it will stop the once a week "turk hacker" bulls*** thats been making me have to restore my db all the time. turns my system black with heavy metal music in te background and redirects people... but thats another story..) that is the only mod on my system and still that same error is there.

i tried installing two different visual confirmations (yaavcm and captcha from amiga) and neither of THEM will work either.

No i have un-installed and reinstalled everything and like i said, other than crackertracker its all original.

considering i get about 50 to 100 fake robot users every single day i REALLY would like to have something to prevent or at least hinder the bots. any help as to why i am getting the error or of another way of preventing them would be greatly appreciated. thanks.

my host is www.dreamhost.com
i have the newest version of phpbb

PS. as of right now i have decided to just leave the visual confirmation enabled and prevent anyone from being able to log in until i fix the problem, to see the error for yourself feel free and visit www.secondchancecritic.com/forum and click REGISTER
Last edited by ckcelite on Sun Oct 08, 2006 2:53 am, edited 2 times in total.

User avatar
drathbun
Former Team Member
Posts: 12204
Joined: Thu Jun 06, 2002 3:51 pm
Location: TOPICS_TABLE
Contact:

Post by drathbun » Wed Oct 04, 2006 5:54 pm

You need to first verify that the visual confirmation table exists, the error message you posted implies that it does not.

Code: Select all

SQL Error : 1146 Table 'sccdb.sccdb_confirm' doesn't exist
You should be able to do that with phpMyAdmin, if you don't know how post back and someone can try to provide step-by-step instructions.
I blog about phpBB: phpBBDoctor blog
Still using phpbb2? So am I! Click below for details
Image

ckcelite
Registered User
Posts: 8
Joined: Wed Oct 04, 2006 5:10 pm

Post by ckcelite » Wed Oct 04, 2006 9:52 pm

well i am able to use the basic (very basic) features of phpmyadmin, like copy/paste run sql command.

i am not sure how to add a table or how to remove a line.

what i do is this, try something, if it doesnt work i restore a previous version of my database and try again.

if someone was to give me a little info on how to add that table i sure would appreciate it. thanks!

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Wed Oct 04, 2006 11:07 pm

first, you apparently are not completly up to date or you would have that table in your database.

try running the update_to_latest.php file that is part of the update files you got from here. you have to follow the instructions and upload the complete install folder , then in you browser, go to:

yourdomain.com/yourphpbb/install/update_to_latest.php

then delete the install folder.

if that does not work then you will need to add the table manually.
copy and paste the following into a query box in phpmyadmin:

Code: Select all

CREATE TABLE phpbb_confirm (
  confirm_id char(32) DEFAULT '' NOT NULL,
  session_id char(32) DEFAULT '' NOT NULL,
  code char(6) DEFAULT '' NOT NULL, 
  PRIMARY KEY  (session_id,confirm_id)
);
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

ckcelite
Registered User
Posts: 8
Joined: Wed Oct 04, 2006 5:10 pm

Post by ckcelite » Thu Oct 05, 2006 12:43 am

First off, I want to say THANK YOU for your help!

i checked my version and here is what it says in my acp:
Your installation is up to date, no updates are available for your version of phpBB. Powered by phpBB 2.0.21 ©


So, I attempted to put the following into my sql and i got the following;

Code: Select all

Error
SQL query: 

CREATE TABLE phpbb_confirm(

confirm_id char( 32 ) DEFAULT '' NOT NULL ,
session_id char( 32 ) DEFAULT '' NOT NULL ,
code char( 6 ) DEFAULT '' NOT NULL ,
PRIMARY KEY ( session_id, confirm_id ) 
);



MySQL said:  

#1050 - Table 'phpbb_confirm' already exists 
I am still new with mysql and i am wondering, if i attempt (like i did) to enter something into it, and it reports an error, did it still get entered? i think it must have because now when i try to register as a new user with the visual enabled in the acp i get the following;

Code: Select all

Could not delete stale confirm data

DEBUG MODE

SQL Error : 1146 Table 'sccdb.sccdb_confirm' doesn't exist

DELETE FROM sccdb_confirm WHERE session_id NOT IN ('054c2dd3bc14b908c78dba28685ae1bb', '055aadf0f81c1c5cc635b84ce2c9cdba', '0a3022a3a72a1205f5f0bf2672e9544e', '0bf209f4c5f37545b693d1239871d5c7', '13b26b225a2c3ed3739007d66027e082', '1ef1a462fcef12b89613ccd9a9cc8da4', '25d34313146fb87e86a68a39b063b0b2', '3004882ca8befb27e18fdaa6bf8d0c4c', '3b56dea412b8a2438bb47c479c3e86e9', '416b599cfaff952bd2ac793652477817', '46f559d7a84766447b3b0c5a30184eee', '4722862908f7d028cdc5e44163fc38e6', '4bfadd0b74a94d523d1c9db7aa9b6074', '52bde6ac7d0812884e674fee014c2011', '57b5dcf63c66bdd8c6f90067be210387', '5dd3476ec85e5765c776b56634751b2c', '7bae6915dda91aed434a853d45c85b83', '8e618c52059060d97c5f90b634665561', '9754f622e73338a618184f4d65707207', '99ad8bfaba58ab6e9c7caf399bb7d049', '9cd949e6d9d55f459669fbea4d565d9e', '9d5e957064fc063918d03795211adb30', 'a21aee2b1d68d8c32ebb2bd82941ea04', 'abca47357205a98f3d6977932dd9ae7e', 'aca6038c45c87269fe567e3f74ea1d16', 'b57468cbd1fd9ce6a0f0ab010191f138', 'b6cda3152d34b03ced3a56f1765c7b9d', 'be2139adb4132fcc1a0a0f2fce23c98a', 'bf11845d5f179ebcbc59a06733fff996', 'c1683593a5597f186c47f52a8d6b635a', 'c74fbd56f4261c7ba267042de7c1dc51', 'c9d0f4e27c616f4faa9a4e4f18f9a655', 'ca67c3da9eef6cf5a9e2761bac470e01', 'cee682354eff0af61025c8154e14e069', 'd1539be51725538ed680314c8040bda5', 'd733bf0cd8a7f951a0f8d0d013566600', 'd7b9663787919c6b98e51f656a8decef', 'dceccf44bd576b963a906c42353ff1cd', 'dfdf0bc17a31eccf7b36202a71535a73', 'e17a6b086c7149bc1c1841d26a0b432c', 'e88f6c6e3071e5db4a01e635eece7618', 'ebb8e58a792a48aa0817b4db4bc0f91c', 'ec465e5757b6cfdcfbe650b40dd10e32', 'f2413343592e59ea01688ac2594a71f6', 'f79957446e7314750c744af7b3f5ea19', 'f957cb6f19df3f77c693efe6574c72db', 'fa989d75ba332f3b3f2459d844333f87', 'fb34da20d94a0dbd5e30414254605f17', 'fc4e136753dedfc93cdd7c3a726dcf69')

Line : 981
File : usercp_register.php
since i do not know if my db was changed by my attempt at entering that, i am now going to restore the db. again, you guys are all great, hope i can get this fixed soon, : )

ckcelite
Registered User
Posts: 8
Joined: Wed Oct 04, 2006 5:10 pm

Post by ckcelite » Thu Oct 05, 2006 3:00 am

okay, after restoring my db i am back to the original error:

Code: Select all

Could not delete stale confirm data

DEBUG MODE

SQL Error : 1146 Table 'sccdb.sccdb_confirm' doesn't exist

DELETE FROM sccdb_confirm WHERE session_id NOT IN ('70a3cd633103f37271d2e3594b4906d3', 'bac4b7c07d8d75fd4d98254af1b52288', 'e17a6b086c7149bc1c1841d26a0b432c')

Line : 981
File : usercp_register.php

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Oct 05, 2006 4:02 am

You're talking two different tables here, "phpbb_confirm" and "sccdb_confirm". The first is the default name for the table, which exists; the second is the one your config.php script says to use, and it doesn't exist.

While I recommend that no one use the default "phpbb_" table prefix, heading that advice makes it harder for us to give you detailed instructions for modifying or creating tables, because we have to adjust to the proper names. YOU need to run this query:

Code: Select all

CREATE TABLE sccdb_confirm(
confirm_id char( 32 ) DEFAULT '' NOT NULL ,
session_id char( 32 ) DEFAULT '' NOT NULL ,
code char( 6 ) DEFAULT '' NOT NULL ,
PRIMARY KEY ( session_id, confirm_id )
); 
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

ckcelite
Registered User
Posts: 8
Joined: Wed Oct 04, 2006 5:10 pm

thanks!

Post by ckcelite » Thu Oct 05, 2006 1:10 pm

espicom, i would like to say
A BIG THANK YOU!
for your help, i entered that sql and it worked perfectly, for the first time ever my board works perfectly, no poblems (that i have found yet anyhow : ) and i owe it all to all the awesome people in the phpbb community. I was starting to hate php, i know html but php and mysql is all very new to me. i only learn from hacking apart code that i find, examining mods, etc. hope to learn enough to some day be able to offer some assistance to other newbies : )

thanks everyone!

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: thanks!

Post by Lumpy Burgertushie » Thu Oct 05, 2006 5:36 pm

ckcelite wrote: espicom, i would like to say
A BIG THANK YOU!
for your help, i entered that sql and it worked perfectly, for the first time ever my board works perfectly, no poblems (that i have found yet anyhow : ) and i owe it all to all the awesome people in the phpbb community. I was starting to hate php, i know html but php and mysql is all very new to me. i only learn from hacking apart code that i find, examining mods, etc. hope to learn enough to some day be able to offer some assistance to other newbies : )

thanks everyone!


good work. sorry I didn't see the different table prefix before.

luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

duderonomy
Registered User
Posts: 8
Joined: Fri Oct 06, 2006 9:22 am

Post by duderonomy » Sun Oct 15, 2006 11:33 pm

Hello,

I am investigating an issue related to a missing table which brings me to this discussion thread. While installing a Mod the community would likely consider stable, I experienced something similar to the OP. Perhaps this will shed additional light on an issue regarding the "phpbb_confirm" table and version 2.0.21.
first, you apparently are not completly up to date or you would have that table in your database.

In my case, I started a new forum installation with this package: phpBB-2.0.21.tar.gz.

During an installation of the Advanced Visual Confirmation it was evident a required table was missing.

After reading the boards, I noticed other discussion threads were assserting that table "phpbb_confirm" is in the latest phpBB package.

If one was not using the latest version there seemed to be a couple of approaches, such as running the script in kb article #329, or running the update_to_latest.php, or, as this thread suggests, adding a single table to the database.

Is it possible table "phpbb_confirm" is not created in phpBB version 2.0.21? I note that before installing Advanced Visual Confirmation I used the default captcha system (in a "virgin" 2.0.21 installation) to test the registration functionality. It operated properly.

Then afterwards, when attempting to install the mod, noticed the aforementioned table was not present.

Is this expected? Or did I fail to do some installation step which would yield this result?

Cheers,
D

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Sun Oct 15, 2006 11:38 pm

that table is created when installing and has been since about verison .15 or I think.

If the visual confirmation was working in your board, then that table was present. It does not work without it.

now, why, when you installed a MOD, it turned up missing, is the mystery.

files do not delete themselves nor do tables in the database.

8O

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

duderonomy
Registered User
Posts: 8
Joined: Fri Oct 06, 2006 9:22 am

Post by duderonomy » Mon Oct 16, 2006 12:07 am

that table is created when installing and has been since about verison .15 or I think.
Interesting...
I do not doubt what you say and I am familiar with the notion that data does not delete itself. Computers are not mysterious to me. I just made these changes a few minutes ago and still have the tables list as a BEFORE and AFTER. Here is the table list in the DB as created by 2.0.21's installation scripts:

Code: Select all

mysql> show tables;
+----------------------------+
| Tables_in_mediaweb_soforum |
+----------------------------+
| auth_access                | 
| banlist                    | 
| categories                 | 
| config                     | 
| confirm                    | 
| disallow                   | 
| forum_prune                | 
| forums                     | 
| groups                     | 
| posts                      | 
| posts_text                 | 
| privmsgs                   | 
| privmsgs_text              | 
| ranks                      | 
| search_results             | 
| search_wordlist            | 
| search_wordmatch           | 
| sessions                   | 
| sessions_keys              | 
| smilies                    | 
| themes                     | 
| themes_name                | 
| topics                     | 
| topics_watch               | 
| user_group                 | 
| users                      | 
| vote_desc                  | 
| vote_results               | 
| vote_voters                | 
| words                      | 
+----------------------------+
30 rows in set (0.06 sec)
And here is the list of tables after I added one table for Advanced Confirmation:

Code: Select all

mysql> show tables;
+----------------------------+
| Tables_in_mediaweb_soforum |
+----------------------------+
| auth_access                | 
| banlist                    | 
| categories                 | 
| config                     | 
| confirm                    | 
| disallow                   | 
| forum_prune                | 
| forums                     | 
| groups                     | 
| phpbb_captcha_config       | 
| posts                      | 
| posts_text                 | 
| privmsgs                   | 
| privmsgs_text              | 
| ranks                      | 
| search_results             | 
| search_wordlist            | 
| search_wordmatch           | 
| sessions                   | 
| sessions_keys              | 
| smilies                    | 
| themes                     | 
| themes_name                | 
| topics                     | 
| topics_watch               | 
| user_group                 | 
| users                      | 
| vote_desc                  | 
| vote_results               | 
| vote_voters                | 
| words                      | 
+----------------------------+
31 rows in set (0.00 sec)
If the visual confirmation was working in your board, then that table was present. It does not work without it.

now, why, when you installed a MOD, it turned up missing, is the mystery.


I have been quite methodical. I saw other threads of people talking like they were having trouble starting with version 20. Is it possible a phpBB database dump could disaffect the database. That is the only thing I have done "admin-wise" other than operate the BB as a regular user, making a few posts.

Does anyone know any other potential way for the "phpbb_confirm" to go missing?

Cheers,
D

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Mon Oct 16, 2006 12:20 am

I dont see anything strange with the two table lists you showed there.

the first one is the standard , with the confirm table there.

the second one is after you install that MOD and it ads one table:
phpbb_captcha_config

what is wrong with that?

like I said, that table has been in the install process ever since the visual confirmation was added as default.

it is in every download from every mirror etc.

if it goes missing, someone or some MOD installation removed it. plain and simple.
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

duderonomy
Registered User
Posts: 8
Joined: Fri Oct 06, 2006 9:22 am

Post by duderonomy » Mon Oct 16, 2006 12:34 am

I see, now, that I am not reading the table names properly. I see the "confirm" table but was failing to see the "phpbb_confirm". Do you see what I mean? I would be grateful for your opinion in the form of a "post" analysis of what I did to make things look like this. :)

Does it look like I mucked up the installation process somehow with a prefix that is not "phpbb"? Is that why I do not have a table named "phpbb_confirm"?

Cheers,
D

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Mon Oct 16, 2006 12:43 am

you don't have a table prefix on any of your tables.

that is fine, but anytime something calls for phpbb_whatever, you have to remember to take off the phpbb_


the only purpose in table prefix is so that you can tell the difference between phpbb tables and any other tables that you may have in your database.

you can put as many tables for as many different scripts as you want .

it is just better to have a prefix for each script or program tables so you can tell them apart.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Locked

Return to “2.0.x Support Forum”