[RC] QWiki (Combining the Wiki and the Bulletin Board)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
Quezza
Registered User
Posts: 212
Joined: Sat Oct 23, 2004 7:17 pm
Location: Hertfordshire, UK
Contact:

Post by Quezza » Wed Nov 08, 2006 10:10 pm

I may start developing this mod again soon. It will probably be like 2-3 weeks before I do though. I shall keep you posted, but if anyone else works out fixes then posting them here would be a great help.

User avatar
Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Post by Narnian » Wed Nov 08, 2006 10:19 pm

ericsh6 can you send me your functions_post.php?
cause my functions_post is very modificated

ericsh6
Registered User
Posts: 7
Joined: Wed Nov 08, 2006 4:18 am

Post by ericsh6 » Wed Nov 08, 2006 10:31 pm

ericsh6 can you send me your functions_post.php?



here is a link to the zipped file:

http://markopuff.com/animations/functions_post.zip

User avatar
Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Post by Narnian » Wed Nov 08, 2006 10:54 pm

replace your line 314 with

Code: Select all

	$sql = ($mode != 'editpost') ? "INSERT INTO " . POSTS_TEXT_TABLE . " (post_id, post_subject, bbcode_uid, post_text, scribble_string) VALUES ($post_id, '$post_subject', '$bbcode_uid', '$post_message', '".stripslashes($scribble_string)."')" : "UPDATE " . POSTS_TEXT_TABLE . " SET post_text = '".mysql_real_escape_string ($post_message)."',  bbcode_uid = '$bbcode_uid', post_subject = '$post_subject', scribble_string = '".stripslashes($scribble_string)."' WHERE post_id = $post_id";
and try again

ericsh6
Registered User
Posts: 7
Joined: Wed Nov 08, 2006 4:18 am

Post by ericsh6 » Thu Nov 09, 2006 1:01 am

I replaced my code with the code above. It doesn't quite work yet. This is what happens:

1a) I click "new topic" button, enter a subject and this text in the white text box: "it isn't eight yet" (without the quotes of course but with the apostraphe).

1b) I check the "This post may be edited by other users." box

1c) I submit the post and it works as expected


2a) I edit the post

2b) I enter "it is now eight" in the white text box

2c) I enter a comment

2d) I press the submit button


Now the first line I entered says "it isn''t eight yet"
notice that a second apostraphe was added.



But if I click on the "all revisions" link and revert back to the first entry - that all works just fine.

ericsh6
Registered User
Posts: 7
Joined: Wed Nov 08, 2006 4:18 am

Post by ericsh6 » Thu Nov 09, 2006 3:52 pm

I think the way to make this work is to detect if it is "edit mode" and also a "revert" operation and then add the backslashes for this case only. Is there a way to detect if a "revert" is being done?

User avatar
Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Post by Narnian » Thu Nov 09, 2006 4:14 pm

That will be a patch, bu the real problem is the $post_message
If it comes from the normal phpbb edition it comes escaped, but do not come escaped from teh qwiki revert.

Now i'm busy, but tonight I will check that.

ericsh6
Registered User
Posts: 7
Joined: Wed Nov 08, 2006 4:18 am

Post by ericsh6 » Thu Nov 09, 2006 6:17 pm

That will be a patch, bu the real problem is the $post_message


I agree 100% and I observed that the $post_message has the added apostrophe characters unless it goes throught the wiki process.

User avatar
stevemagruder
Registered User
Posts: 210
Joined: Wed Jul 02, 2003 2:05 pm
Location: Louisville, KY
Contact:

Working demo?

Post by stevemagruder » Mon Nov 13, 2006 5:34 pm

Is there a working demo of this somewhere? The link in the first post doesn't seem to lead to a demo.
Steve Magruder - WebCommons :: Media
Administrator for the Louisville History & Issues discussion board

User avatar
yexusbeliever
Registered User
Posts: 586
Joined: Mon Dec 08, 2003 8:49 pm
Location: Olympus phpBB3

Post by yexusbeliever » Fri Dec 01, 2006 2:56 am

Can anyone share the download link?

User avatar
Freitag
Registered User
Posts: 142
Joined: Mon Jul 11, 2005 10:17 pm

Post by Freitag » Thu Mar 08, 2007 10:59 pm

Dead thread?

sitwi
Registered User
Posts: 83
Joined: Fri Jul 21, 2006 10:53 am
Contact:

Re: [RC] QWiki (Combining the Wiki and the Bulletin Board)

Post by sitwi » Mon May 28, 2007 8:37 am

Outstanding job, guys - a great example of people teaming up to rescue a MOD. I just stumbled across it today and was able to fix most of my problems.

This is an old thread, but if anyone's able to help with my one remaining problem, I'd be grateful. It's actually the same as the one Narnian has earlier, but the fix quoted doesn't work.

If I try to turn an old post into a Wiki post (i.e. edit it and check the wiki check-box), it gives me an error message: "You must specify a subject when posting...".

No idea why the fix mentioned earlier doesn't work, as everything else has been so helpful.

Thanks all.

User avatar
Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Re: [RC] QWiki (Combining the Wiki and the Bulletin Board)

Post by Narnian » Mon May 28, 2007 7:02 pm

I'm really sorry im too busy with tests in my univ. now... but I hope someone could help you soon...

digitaldoctor
Registered User
Posts: 4
Joined: Sat Aug 02, 2008 5:46 pm

Re: [RC] QWiki (Combining the Wiki and the Bulletin Board)

Post by digitaldoctor » Sat Aug 02, 2008 5:54 pm

Any chance of something like this for phpBB3 ?
Wikis are super important for sites that are trying to create information, not just the back and forth banter of a forum.
Interesting how the phpBB team uses a wiki ...
:)

Post Reply

Return to “[2.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 7 guests