2.01 to 2.03 problem

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
CyberSpy
Registered User
Posts: 44
Joined: Mon May 06, 2002 3:09 pm
Location: Cyberspace
Contact:

2.01 to 2.03 problem

Post by CyberSpy »

I updated to 2.0 when it first came out. Then tonight when I went to update from 2.01 to 2.03 I ran a patch since I have many mods and got quite a few errors (hunk failed, etc). Then noticed that you have to have 2.02 first. I looked here and couldn't find it. So I did a search. Saw that I should go to sourceforge, and I got the 2.02 patch from there. I went to run it, and had massive errors again.. it seems the 2.02 patch on sourceforge is the cvs version.. look at this error:

Code: Select all

sh-2.04$ patch -p0 < phpBB-2.0.2-update.patch
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: install.php
|===================================================================
|RCS file: /cvsroot/phpbb/phpBB2/Attic/install.php,v
|retrieving revision 1.41.2.1
|diff -u -r1.41.2.1 install.php
|--- install.php        13 May 2002 13:18:17 -0000      1.41.2.1
|+++ install.php        8 Aug 2002 18:12:56 -0000
--------------------------
What do I do, my backup I made before the attempt won't restore, and I need to know what I should do to upgrade with the patch? I think the 2.03 from 2.02 was too quick and 2.02 should have remained here for a bit after 2.03 was released. Can someone help me?
Surreptitiously Yours,
CyberSpy
www.cyberspy.ws
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

You should have gotten 2.0.2 patch from here: http://prdownloads.sourceforge.net/phpb ... p?download
Proven Offensive Security Expertise. OSCP - GXPN
User avatar
CyberSpy
Registered User
Posts: 44
Joined: Mon May 06, 2002 3:09 pm
Location: Cyberspace
Contact:

Same error

Post by CyberSpy »

I tried that link, got that patch, and it's the same error..

It looks into /cvs/phpbb/attic I have no idea what dir that is.
Surreptitiously Yours,
CyberSpy
www.cyberspy.ws
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

I don't know either. I did the patch on both 2.0.1-2.0.2 and 2.0.2-2.0.3 and it works fine for me.
Proven Offensive Security Expertise. OSCP - GXPN
Flipper
Registered User
Posts: 436
Joined: Sun May 19, 2002 6:24 pm
Location: You are might here -&gt;
Contact:

Post by Flipper »

The Attic directory of CVS, is a place for files deleted from CVS (like a Windows Recycle Bin).
~Flipper
_____
Website - #Team.SoC - A Call of Duty clan
No PM/IM Support given :)
User avatar
CyberSpy
Registered User
Posts: 44
Joined: Mon May 06, 2002 3:09 pm
Location: Cyberspace
Contact:

Fixed (sort of) please delete these posts.

Post by CyberSpy »

I downloaded the 2.0.1 and 2.0.2 changed files, and just lost some mods and went back to origina1 2.0.1 files, did the same for 2.0.2 and then ran the patch for 2.0.3, It says 2.0.3 at the bottom of my pages, and I don't see any major errors so far, so I guess it worked. Now to find all the tweaks I made, heh
Surreptitiously Yours,
CyberSpy
www.cyberspy.ws
Locked

Return to “2.0.x Support Forum”