[2.0.21] User Shield

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
52
79%
Very Good
8
12%
Good
4
6%
Fair
1
2%
Poor
1
2%
 
Total votes: 66

mobile homeless
Registered User
Posts: 16
Joined: Sun Apr 30, 2006 2:24 pm

Re: [2.0.21] User Shield

Post by mobile homeless » Fri Mar 23, 2007 3:25 am

Wo1f wrote: I got all your files and will get back to you soon.

Well, I've been singing Wo1f's praises like banging a gong and here I go yet again. But I have to say, Wolf ALWAYS goes WAAAY above and beyond to help someone out.

I had a corrupt EASYMOD install that didnt change many of my files. Wolf took a look at all 11 files and made sure each was correct, then making them available to me, all within a few hours. I have to say, if all the world provided this type of service and competence, it would be a far different place.

Thanks again Wolf for your time and help here. Forum is working great, mod functioning perfectly, and all on track, spam members, all 423 of them, now deleted.

Excellent Mod. Excellent support. Thanks again!

kh

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 6:07 am

Excellent news mobile homeless! Glad we managed to take care of it and thank you for the kind words. ;-)

Best regards and good luck to you,
Wolf

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 12:46 pm

Wo1f,

I did switch the style back to subSilver and tried to install the mod. I got the same error:
FIND FAILED: In file [templates/Getaway/memberlist_body.tpl] could not find:

<th height="25" class="thCornerL" nowrap="nowrap">#</th>

MOD script line #717

then you need to edit all TPL files for each and everyone of your installed styles.

The TPL files are the following:
a] templates/yourTemplate/index_body.tpl --> 3 actions to integrate
b] templates/yourTemplate/memberlist_body.tpl --> 4 actions to integrate
c] templates/yourTemplate/admin/board_config_body.tpl --> 1 action to integrate


I am not sure how to do this manually? What needs to be changed?

Thanks!
:?

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 3:55 pm

Is this the only style you are using aside subSilver? If not, what styles do you have (complete list)? What I would like at this point is to make sure that User Shield is installed properly in subSilver, then it's just a question of manually editing 3 files for each problematic style. Can you remove the "Getaway" style temporarily so you can proceed with the installation?
jskor wrote: I am not sure how to do this manually? What needs to be changed?

Once User Shield is installed (subSilver), open the instruction template and look for the edits affecting only TPL files. For example, the first file to edit in your non-subSilver unrecognized style would be "index_body.tpl", which is:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/index_body.tpl

#
#-----[ FIND ]------------------------------------------
#
# this is a partial line match
#
	{TOTAL_POSTS}<br />{TOTAL_USERS}

#
#-----[ IN-LINE FIND ]------------------------------------------
#
{TOTAL_USERS}

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
{NON_ACTIVATED_FOR_ADMIN}
... and so on and so forth for both remaining files. Some styles will not offer you a recognizable snippet of code to find, so you'll have no choice but to improvise, but that's where I come in and give you a hand (if need be). ;-)

Let me know.

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 6:13 pm

Is this the only style you are using aside subSilver?


No I was using Getaway.

1. I have removed Getaway from the server - subSilver is now the default
2. I ran Easy Mod and installed User Shield
3. I the got the following errors


Error Detail

Warning

Function Trace: open_files[2]->modio_open[1]

Could not open [templates/Getaway/index_body.tpl] for reading.
MOD script line #669 ::

Error Detail

Warning

Function Trace: open_files[2]->modio_open[1]

Could not open [templates/Getaway/memberlist_body.tpl] for reading.
MOD script line #691 ::

Error Detail

Warning

Function Trace: open_files[2]->modio_open[1]

Could not open [templates/Getaway/admin/board_config_body.tpl] for reading.
MOD script line #777 ::


Additionally - notice below

Step 1 of 3
Processing completed successfully!
EasyMOD has completed processing of this MOD. Your original phpBB files remain unaltered. The next step will update your DB and replace your phpBB files with the newly altered ones. Your original phpBB files will automatically be backed up. However, this is beta quality software and you are urged to make your own backups!! Press the "Next Step" button to continue.

MOD Data
MOD Title: User Shield 1.2.1 install_user_shield_v1_2_1.txt
Author: Wo1f N/A J. C. Woof N/A
Processed Themes: subSilver; Getaway
Processed Languages: english; hebrew; greek
Files Edited: 15
Commands Processed: 88
Unprocessed Commands: 0


The following commands were not recognized by EasyMOD and were ignored. The MOD script line number is displayed.
Unprocessed Commands


What next?

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 6:51 pm

Complete the installation (including the database update). You can also ignored the DIY (do-it-yourself) instructions at the end since EasyMOD will be doing it for you.

Also, by removing the "Getaway" style, I meant to remove the folder from your server directory hierarchy completely. EasyMOD is still picking up on it, although this time, it seems to be willing to go through with it, because subSilver is now your default style. Changes will not be applied to the "Getaway" style, but that's ok since we need to do them manually anyways.

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 6:55 pm

Hmmmm...confused on this one as I had removed it from the heirarchy....

Ok.... I got installation complete and the DYI instructions to complete (which I am ignoring). Also not seeing the admin interface either.

Next up to the plate: Wolf. :)

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 7:05 pm

Allright, now is the time to check if User Shield is working as advertised under subSilver. You can refer to the 3rd post of the 1st page of this thread in order to review the screecaptures as to what to visually expect when logged in as an administrator and also as a user.

Let me know if things are good.

jskor wrote: Hmmmm...confused on this one as I had removed it from the heirarchy....

Let's not worry about this one for now.

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 7:13 pm

We have achieved Wolf-Shield Excellence!

Image


Alrighty, now we are getting somewhere. (I didn't have any doubts by the way). :lol:

Where do we go from here? Will it be possible to upload Getaway again?

~jskor
Last edited by jskor on Fri Mar 23, 2007 7:23 pm, edited 1 time in total.

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 7:18 pm

8O It worked??? <never had a doubt either> :lol:

Hold on with "Getaway". What I need now is for you to package the 3 TPL files from your "Getaway" style so I can integrate User Shields edits. You know which 3 I'm talking about? And also renamed with a TXT extension.

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 7:25 pm

Wolf,

no I do not know which ones.

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 7:32 pm

The TPL files are the following:
a] templates/Getaway/index_body.tpl
b] templates/Getaway/memberlist_body.tpl
c] templates/Getaway/admin/board_config_body.tpl


Rename each one with a TXT extension and link me to them. You can reintegrate the "Getaway" folders on your server but..., in your ACP, under configuration, do not change the default subSilver style yet and I would suggest that you "Override user style = YES" until we're done with the Getaway style.


Nice job on my avatar btw. 8)

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 7:48 pm

Wolf,

they are off to you via PM.

Glad you liked the .gif. It was the least I could do far all the work you are doing for me. We have exchanged "Wolf-Shields" ;-)

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Re: [2.0.21] User Shield

Post by Wo1f » Fri Mar 23, 2007 8:02 pm

Here we go (the style author did do a good job btw, and the adjustments were straithforward).
  • Link removed
  • Link removed
  • Link removed
1 ] Click on the above links and "Save" to your local computer
2 ] Rename files appropriately
3 ] Upload (copy) to your server and overwrite the old ones in your templates/getaway/ folder only

After you've done this, you can change the default style in your ACP along wih the restriction to override user's styles. This should do it, but please take the time to verify this, as you have done with the subSilver style.
Last edited by Wo1f on Fri Apr 13, 2007 7:20 pm, edited 1 time in total.

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

Re: [2.0.21] User Shield

Post by jskor » Fri Mar 23, 2007 8:24 pm

Wolf,

not sure what happened:

1. I renamed and uploaded as required.
2. I changed the restriction to override user's styles to yes
3. I switched back to Getaway and the structure of the forum is gone. Just about a paragraph worth of data appears at the top of the window.

Thoughts?

I did try switching overrride to no - same issue
subSilver is working

Post Reply

Return to “[2.0.x] MOD Database Releases”