Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

zarmenas wrote:
DavidIQ wrote: How big is the file?


it seems the filesize has no influence. no matter if I try to upload 2Kb or 2Mb - the same error...

What about max_execution_time and max_input_time?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

DavidIQ wrote: What about max_execution_time and max_input_time?


max_execution_time = 30
max_input_time = 60

one more thing I found:

disable_functions = <...> max_execution_time <...> (where <...> means other mentioned functions)

the whole phpinfo.php could be found at:
www.archiforum.lt/tmphp/phpinfo.htm
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

passthru, max_execution_time, and maybe some of the others that are in the disable_functions list will need to be un-disabled.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

DavidIQ wrote: passthru, max_execution_time, and maybe some of the others that are in the disable_functions list will need to be un-disabled.


thanks, I'll try that right away. can this be done by php.ini file in site's root? or, maybe by .htaccess file?
or do I have to contact the providers to to that for me?

thanks again, I'm glad there's someone out-there who knows things :)
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

It would be easier to just go through the php.ini file than to use .htaccess files. These disabled functions would be listed after the disable_functions =
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

DavidIQ wrote: It would be easier to just go through the php.ini file than to use .htaccess files. These disabled functions would be listed after the disable_functions =


thanks again for support :)
User avatar
wads24
Registered User
Posts: 595
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

Brf wrote:
wads24 wrote: Am I missing a setting?

You might be missing this line in usercp_viewprofile:

Code: Select all

display_upload_attach_box_limits($profiledata['user_id']); 
The quotas should show if you are viewing your own profile, or if you are an admin.


nope, i have that ling in the usercp_viewprofile.php file...
Thanks in advance for a reply.
hponce
Registered User
Posts: 40
Joined: Mon Apr 10, 2006 2:22 pm

Re: Attachment Mod

Post by hponce »

DavidIQ wrote: Do you have the page that confirms your posting after you hit submit? Because if you do then you most likely missed the viewtopic.php or viewtopic_body.tpl edits.


Was correct solution

Thanx
User avatar
Keno2113
Registered User
Posts: 21
Joined: Tue Nov 14, 2006 2:13 pm

Re: Attachment Mod

Post by Keno2113 »

I just installed your MOD and as you said it is intensive and long but, I had no problems and it is working great. Just wanted to say "Great Job" and thank you! :D
I don't suffer from insanity, I enjoy every minute of it!
Crazy-S
Registered User
Posts: 138
Joined: Wed Feb 07, 2007 12:41 am
Contact:

Re: Attachment Mod

Post by Crazy-S »

Brf wrote:
Crazy-S wrote: when uploading large files...
Error 500 - Internal server error
The default server limit for uploaded files is 2M. If you need to upload something larger than that, you will need to change your php.ini file on the server.
transparent images, like .png files, is there any way to change the default color from black background to either white, or an offset of white?


The HTML for that is found in viewtopic_attach_body.tpl

Code: Select all

		<td colspan="2" align="center"><br /><img src="{postrow.attach.cat_images.IMG_SRC}" alt="{postrow.attach.cat_images.DOWNLOAD_NAME}" border="0" /><br /><br /></td>

There is no "class" on that TD, so it is inheriting the standard TD classes for your template.If you want to change it, you could always tack in a style="background-color: #F0F0F0" or something between the "align="center" and the ">"



Thanks BRF.... It did change the background color of the attachment box, BUT I cannot get it to change the background color of the image itself... I am using the Subsilver template without any changes to the style...
I do have several MODS installed though, but I cannot see any problems causing this.
Visit Crazy-Software.com for some great personalized gift making software!

Like Personalized candy Wrappers? Then visit Our Community
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52141
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

If the PNG file is truly transparent, it will use the background-color of the TD as its background. If you are not seeing that happen, then the PNG is not transparent.
Johnny8
Registered User
Posts: 1
Joined: Sat May 05, 2007 1:00 am

Re: Attachment Mod

Post by Johnny8 »

GREAT MOD!!!!
Question or Problem?
When I followed all the step to install the attachment MOD, I ran across a problem that relate to the user profile view...

includes/usercp_viewprofile.php

#
#-----[ FIND ]---------------------------------------------
# around line 175
include($phpbb_root_path . 'includes/page_header.'.$phpEx);

#
#-----[ AFTER, ADD ]---------------------------------------
#
display_upload_attach_box_limits($profiledata['user_id']);

#
#-----[ OPEN ]---------------------------------------------
When I added this step, I recieved a line error and was not able to view the profile. Editing didn't remove the problem, only when I copied the original file usercp_viewprofile.php over the existing. Not sure if this matters but I had to leave this line out. Any thoughts?
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

What you said doesn't help. Sharing the error message would definitely help.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

DavidIQ wrote: It would be easier to just go through the php.ini file than to use .htaccess files. These disabled functions would be listed after the disable_functions =


OK, something worked out - I e-mailed provider and gave him your suggestions. today the problem is gone. :)

anywys, I got another issue - when I press on a thumbnail, new window pops out, where the image is supposed to be, but insted there is "HTTP 404 - NOT FOUND" error message.

any thougts?
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17328
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Look at the URL and see if the path actually exists. You might have forgotten to upload the download.php file to the forum's root folder.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
Post Reply

Return to “[2.0.x] MOD Database Releases”