[ABD] Custom Title MOD

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

[ABD] Custom Title MOD

Post by Aexoden » Wed Aug 15, 2007 6:41 am

MOD Title: Custom Title MOD
MOD Description: Adds a custom title field to a user's profile. phpBB 3.0.x version of the popular 2.0.x MOD.
MOD Version: 2.0.0-rc1

MOD Download: http://www.aexoden.com/projects/custom- ... .0-rc1.zip

This is almost a straight port of the phpBB 2.0.x version of the MOD. There is really only one major change in functionality: Instead of enabling or disabling a user's custom title via the user editor, it's become a set of full-fledged permissions. The two new permissions are "Can edit own custom title" and "Can ignore custom title requirements", which should allow the same range of functionality as before, in addition to allowing group-level control.

This version has passed my limited testing, but it's possible I've made an error in the installation script. Due to my familiarity with the MOD, I often correct errors in my head without even noticing. (This happened once or twice with the old phpBB 2.0.x version.) In addition, the time required for installation is an estimate, and I'd like to get some real numbers from people less familiar with it.

Installation with AutoMOD is highly recommended. (Upgrading with AutoMOD is possible, but more complicated than it needs to be, however.)

Any testing, comments, or suggestions would be appreciated. Thanks!
Last edited by Aexoden on Fri Aug 20, 2010 5:59 pm, edited 6 times in total.

RedTrinity
Registered User
Posts: 1327
Joined: Sat May 06, 2006 3:32 am

Re: [ALPHA] Custom Title MOD

Post by RedTrinity » Wed Aug 15, 2007 6:46 am

Awesome! Gonna install it tonight and see how it goes :D

Nice one Aexoden, this is gonna be a popular one ;)

User avatar
stickerboy
Former Team Member
Posts: 7349
Joined: Mon Mar 29, 2004 2:27 pm
Location: Airdrie, UK (127.0.0.1)
Name: Kenny Cameron
Contact:

Re: [ALPHA] Custom Title MOD

Post by stickerboy » Wed Aug 15, 2007 8:55 am

Excellent work Aexoden.
I loved this MOD for 2.0.x :D
Will give it a whirl on my test board as soon as I can (may be a few days though, I'm getting Guitar Hero tonight \o/ :ugeek: )
I'm a web-designing code-decrypting tech-support musician
|| Twitter || Flickr || phpBB Snippets ||
Formerly known as cherokee red

Kleopatras_Sister
Registered User
Posts: 172
Joined: Sun Jul 08, 2007 5:37 pm

Re: [ALPHA] Custom Title MOD

Post by Kleopatras_Sister » Wed Aug 15, 2007 10:05 pm

thank you

i´ll try this one

endout.com
Registered User
Posts: 5
Joined: Fri Aug 17, 2007 6:42 am

Re: [ALPHA] Custom Title MOD

Post by endout.com » Fri Aug 17, 2007 6:44 am

Installed according to directions ...

Admin CP and Mod CP are now completely white, with an instant load. They are now just blank pages.

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Re: [ALPHA] Custom Title MOD

Post by Aexoden » Sat Aug 18, 2007 12:43 pm

endout.com wrote:Installed according to directions ...

Admin CP and Mod CP are now completely white, with an instant load. They are now just blank pages.
I'm not sure what would cause that, since I can't reproduce it here. You could try uncommenting the two lines in config.php that define DEBUG and DEBUG_EXTRA and see if that helps shed some light, but I'm not sure even that will help. All I can suggest is to make sure to clear your phpBB cache (delete all .php files in cache/) and try again. If I find time, I'll try to see if I can replicate it, but that's probably a couple of days away at least. (Friday, Saturday, and Sunday are really busy for me).

My best guess is a syntax error in one of the acp files, but that didn't produce the problem on my machine, so I don't know.

endout.com
Registered User
Posts: 5
Joined: Fri Aug 17, 2007 6:42 am

Re: [ALPHA] Custom Title MOD

Post by endout.com » Sat Aug 18, 2007 7:38 pm

I can replicate the forum onto a test site and give you access to the ftp if you want to take a look at it.

- plus I cleared the cache and still no goal.

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Re: [ALPHA] Custom Title MOD

Post by Aexoden » Sun Aug 19, 2007 2:05 am

endout.com wrote:I can replicate the forum onto a test site and give you access to the ftp if you want to take a look at it.

- plus I cleared the cache and still no goal.
That's fine if you want to do that. Just PM me the details or whatever and I'll take a look at it when I get a chance over the next couple of days. (And then assuming I figure it out, I'll make sure to post the solution so no one else runs into it. If there's one thing I learned from the phpBB 2.0.x version, it's that the same problem comes up again and again.)

There's also the possibility that I just broke something in the installation script. I haven't had any reports of a successful install, and I haven't had a chance to do a thorough test install myself. Boy, it'll be embarrassing if that's the cause. :shock:

Pinner
Registered User
Posts: 28
Joined: Sun Oct 08, 2006 7:56 pm
Location: New Jersey
Contact:

Re: [ALPHA] Custom Title MOD

Post by Pinner » Sun Aug 19, 2007 3:34 pm

Hey Aexoden.

I downloaded the mod (finally -- sorry it has taken so long for me to reply - and thanks so much for fulfilling my request!) the problem I seem to be having is that the download has no files in any of the folders except contrib.

Are there supposed to be files in root and whatnot?

I just want to check on this before I try to install this, I don't want to make any mistakes. :)
"I would rather live and love where death is king than have eternal life where love is not..." - Robert Green Ingersoll

The Dark Crusade
An Age of Conan Guild
http://www.thedarkcrusade.com

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Re: [ALPHA] Custom Title MOD

Post by Aexoden » Sun Aug 19, 2007 9:51 pm

Pinner wrote:Are there supposed to be files in root and whatnot?

I just want to check on this before I try to install this, I don't want to make any mistakes. :)
It looks like contrib should have README.txt and templates should have prosilver.xml. root is empty and so is languages. I'm not sure if the MODX standard requires me to include them if they're empty, so I did.

EDIT: See below for upgrade instructions from alpha1 to alpha2.

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Re: [ALPHA] Custom Title MOD

Post by Aexoden » Thu Aug 23, 2007 3:14 am

I'm just released 2.0 Alpha 2, which fixes the two problems I found with Alpha 1. Upgrade instructions are below for those of you who have already installed. The URL has been changed in the first post.

Successful install reports, failures, suggestions, feature requests, and bugs are, as always, fully appreciated. Thanks!

Upgrade From 2.0 Alpha 1 to 2.0 Alpha 2

Code: Select all

#
# ----- [ OPEN ] -----------------------------------------------------
#
includes/ucp/ucp_profile.php

#
#----- [ FIND ] -------------------------------------------------------
#
                         if ($submit)

#
#----- [ BEFORE, ADD ] ---------------------------------------------
#
                             if ($custom_title_enabled)
                                {
                                        $data['custom_title'] = utf8_normalize_nfc(request_var('custom_title', $user->data['user_custom_title'], true));
                                }

Code: Select all

#
# ----- [ OPEN ] -----------------------------------------------------
#
language/en/acp/common.php

#
#----- [ FIND ] -------------------------------------------------------
#
# Look for the second time this occurs. It'll be on a line by itself, right after a line that contains much the same thing.
	'ACP_CUSTOM_PROFILE_FIELDS'     =>

#
#----- [ REPLACE WITH ] ---------------------------------------------
#
	'ACP_CUSTOM_TITLE_SETTINGS'   => 'Custom title settings',

milplus
Registered User
Posts: 105
Joined: Thu Jun 14, 2007 11:03 am

Re: [ALPHA] Custom Title MOD

Post by milplus » Thu Aug 23, 2007 9:33 am

Hi Guys someone can say to me if this mode is suitale for:

2. I would like to understand if it's possible to get a name of a subforum composed by the country of the subscriber + a number that is the ID number picked up on the dbase of the forum. (so 1,2,3,4,5 etc) For instance A U.S. guy is gonna to create (as per point 1) a subforum . I want that the subscription form doesn't allow them to choice the name but the name must be US+"shop"+number = US-shop-05 that means the fifth shop opened so far in US.
Anyone has an idea on this issue?
I guess I need to go through the dbase structure as well as the phpbb3 code for modifying the subscription form more deeply. I need a rule that compose the name of the subforum nad get a message where is written:

"You've successfully created US-shop-05 . etc etc..."

any help by mod expertise is truly appreciated.
viktor

sixers33
Registered User
Posts: 152
Joined: Sun Jan 21, 2007 2:53 am

Re: [ALPHA] Custom Title MOD

Post by sixers33 » Sun Aug 26, 2007 12:24 am

will this work for PHPBB3 RC5?

Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Re: [ALPHA] Custom Title MOD

Post by Aexoden » Sun Aug 26, 2007 2:03 am

sixers33 wrote:will this work for PHPBB3 RC5?
There's no fundamental reason it shouldn't, though it looks like at least one of the template FIND instructions might need some changes. I'll take a look at it in a couple of days. Otherwise, I didn't notice anything too critical in my initial scan.

sixers33
Registered User
Posts: 152
Joined: Sun Jan 21, 2007 2:53 am

Re: [ALPHA] Custom Title MOD

Post by sixers33 » Sun Aug 26, 2007 2:23 am

thanks :)

Locked

Return to “[3.0.x] Abandoned MODs”