Please help me! - Problem with the automated mails

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Please help me! - Problem with the automated mails

Post by adrina » Tue Sep 18, 2007 10:04 am

Hi, I need some help. Please help me!
I am using the last version of phpBB and my problem is the next:
In the General Board Setting I am using this option to the registration of the members:
Enable account activation - Admin.
So if anyone want to be a member of my board, first, he/she has to register, and than I get an automated mail from the board system to the main mail address of the board about the new user account, and I have to approve this account.
The new member also get two autamated information mails from the board system.
The first one is going to his/her mailbox after the registration.
And the second automated mail is sending to the new member, after I aproved his/her accont.

The first month this system worked very well.
But now this autamated information mail system does not work anymore.
And I do not know what is the problem with it.
Why I do not get information mail about the new user, who already registered?
And also the new member does not get any information mail from the system.

Before this problem I already installed 3 special mod to my board:
1.ADDMIN USERLIST,
2.VIEW ALL POSTS SORTED BY TIME,
3.CENTER CODE
But I am sure these installations were correctly because everything worked wery well, after the installations.
And also I changed some text in these autameted mails, but there was no problem after these changes.

Is any idea, what would be the problem with the automated mail system, and how can I fix it?
Sorry for my terrible english, and thanks for your help.
Adrina

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Tue Sep 18, 2007 10:20 am

Are any other emails sent by the system still working?
(e.g. topic update notifications, and PM notifications)
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Tue Sep 18, 2007 4:42 pm

Hi Ric,
thanks for the question.
Seems the problem is more serious, because the system does not send any mails.
So nobody can get topic update notifications or PM notifications.
Do you have any idea what I have to do to correct this problem?
Thanks:
Adrina

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Tue Sep 18, 2007 10:49 pm

Do you see any error message when emails should be sent?
Even if you don't, it's worth working your way through this article: Knowledge Base - Explanation and solutions for emailer.php line 234 error

Also, some web hosts discard emails if the "From" address is not on the same domain as the forum (e.g. admin@your_forum.com ), or at least on one of the domains that is hosted on the same web server.
The "From" address used by phpBB is what you specify as "Admin Email address" in the Admin Control Panel.

It would be worth asking your web host if they have any restrictions on emails sent from their system.
The restrictions may differ, depending upon wether or not you use SMTP for sending mail.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Wed Sep 19, 2007 12:32 pm

Hi Ric,
thanks for the answere again.
Probably you are right.
I) checked the system with my phpBB 3 (I did not use that one, just I already installed it to my host server), and the mail notifications system does not work with pHpBB3 too.
I did not get any error messages about this problem or any other mistakes.
I asked about this problem the menagers of my host service today, but I did not get answere. Not yet. (I copied your messeage to my mail so I am interested in what they will answere?)

As wrote, the system worked very well and correctly more then two monthes (after I installed my phpBB messageboard) and I discovered this problem just a few days ago.
Thanks
Adrina
P.S.: Oh, yes, I have another question too: do you know where the messageboard store the messages? How does it work? If you - as a member - open a new topic, where the system is store your text and pics of your messages, and where are the replys of the memebres? Where the messageboard system store all the new data?

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Wed Sep 19, 2007 12:47 pm

All information (usernames, posts, forum names etc.) is stored in the database you setup when you installed phpBB.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Wed Sep 19, 2007 5:10 pm

ric323 wrote:All information (usernames, posts, forum names etc.) is stored in the database you setup when you installed phpBB.
Ric, I understand it, but where this database in fact? I mean where I can find it?
Can I check or see this database with my CuteFTP Professional (witch is my FTP client)?
If I delete the folder of my phpBB board, this database still exist on my host server?
Sorry for these stupid question, but I would like to understand how the board system is working.

About the notification mail problem:
I recieved this answere from the administrators of the host site:

"Please note that we do allow 200 mails sent in an hour. You may face problems if you exceed this limit. We will suggest you to use smtp2.servage.net to send mails for temporary purpose if you are facing problems with smtp.servage.net .
Else we have not made any changes on the server."


Just there is only one problem: my boards main mail address is a yahoo mail address, and I am sure there are no more then 200 mails in an hour, bacause I have only a very few members ( there are10 new registration per day). So what do you think about it? What I have to do?
Thanks so much for your very kindly help -
Adrina

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Wed Sep 19, 2007 11:10 pm

adrina wrote:Ric, I understand it, but where this database in fact? I mean where I can find it?
Can I check or see this database with my CuteFTP Professional (witch is my FTP client)?
It is stored on your web hot's database server. This may or may not be the same machine which is hosting your website. It is NOT accessable via FTP.
If I delete the folder of my phpBB board, this database still exist on my host server?
Yes.
There should be a "Database management" option in your web host's control panel software. Usually this will fire up a copy of the "phpMyAdmin" application, which lets you view your database.
I recieved this answere from the administrators of the host site:

"Please note that we do allow 200 mails sent in an hour. You may face problems if you exceed this limit. We will suggest you to use smtp2.servage.net to send mails for temporary purpose if you are facing problems with smtp.servage.net .
Else we have not made any changes on the server."


Just there is only one problem: my boards main mail address is a yahoo mail address, and I am sure there are no more then 200 mails in an hour, bacause I have only a very few members ( there are10 new registration per day). So what do you think about it? What I have to do?
Try changing your forum to use SMTP to that address they gave you: smtp2.servage.net
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Thu Sep 20, 2007 6:06 am

Thanks, Ric!
Your Useful resources give me some links to work with my the database. And I found it on the host server.
So if I have to change my host server I can import my saved database and my new messageboard will have all of the informations of my previous board (sturcture and messages, and pics and so on) except the look (header and footer pics and links). Or if I delete my existing phpBB board folder from the host server and I uploaded a new one (I downloaded the original phpBB folder from my host after the installation) the new board will keep all the privious informations. - Am I right?

About the mail problem:

As I wrote, I am using a yahoo mail address, as my board mail address (I did this setting in the general setting of the forum).
So the in or out mails do not use any smtp mail server of my host server (smtp2.servage.net).
I tried to make an smtp and pop address previously, but there was a problem with it: there were too much information about me in the header of this mails (I mean IP address, country code, and several others). This is the reason I am using yahoo.
Or the the mails from and into my yahoo mail address are using my host server SMTP just I do not know about it?
Sorry for the too much question and for this long conversation about my particular problems!
Thanks very much your help, and your messages:
Adrina

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Thu Sep 20, 2007 6:39 am

adrina wrote:Thanks, Ric!
Your Useful resources give me some links to work with my the database. And I found it on the host server.
So if I have to change my host server I can import my saved database and my new messageboard will have all of the informations of my previous board (sturcture and messages, and pics and so on) except the look (header and footer pics and links). Or if I delete my existing phpBB board folder from the host server and I uploaded a new one (I downloaded the original phpBB folder from my host after the installation) the new board will keep all the privious informations. - Am I right?
All your posts and forum names etc. are stored in the database and will be transferred with it.

Any custom images or themes you have installed are saved on your web server, and would require copying of those files across also.
About the mail problem:

As I wrote, I am using a yahoo mail address, as my board mail address (I did this setting in the general setting of the forum).
So the in or out mails do not use any smtp mail server of my host server (smtp2.servage.net).
I tried to make an smtp and pop address previously, but there was a problem with it: there were too much information about me in the header of this mails (I mean IP address, country code, and several others). This is the reason I am using yahoo.
Or the the mails from and into my yahoo mail address are using my host server SMTP just I do not know about it?
Sorry for the too much question and for this long conversation about my particular problems!
Thanks very much your help, and your messages:
Adrina
I'm not sure I see your problem.
If you use your host server's SMTP server for sending mail, the mails will indicate the same IP address as your web server, so there's no problem with that being revealed. Anyone who knows your forum address also knows its IP address.
Standard phpBB never receives email, so it does not use a POP server at all.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Thu Sep 20, 2007 2:50 pm

Dear Ric,
my last question:
My incoming or outgoung mails do not use the SMTP mail system of my host server, If I am using yahoo address, as the main address of my board. Am I right?
In this case the host server can not make any problems with the board's automated notification mails, isn't it?
So we can not know what is the reason of this problem.
Or....???
Adrina

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Please help me! - Problem with the automated mails

Post by ric323 » Thu Sep 20, 2007 2:55 pm

adrina wrote:Dear Ric,
my last question:
My incoming or outgoung mails do not use the SMTP mail system of my host server, If I am using yahoo address, as the main address of my board. Am I right?
I do not understand what you mean by " I am using yahoo address, as the main address of my board"
There are no "incoming mails" on the forum. What exactly are you currently using for the forum to send mails? i.e. do you have "Use SMTP" set to "off" (in which case phpBB uses the server's PHP mail() function),
or do you have "Use SMTP" set to "on", and an SMTP server specified?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Thu Sep 20, 2007 3:50 pm

If I open my Board Administration Panel there is a mail settings option at the general board settings (Configuration) window:

Email Settings
Use SMTP Server for email
Say yes if you want or have to send email via a named server instead of the local mail function :

yes or no

And my setting is: no

So I do not use the SMTP server.
I given my yahoo mail address, as the Admin Email Address - also in this window, just one line over.

I hope I was more clearly now .
Adrina

User avatar
Lumpy Burgertushie
Registered User
Posts: 66326
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Please help me! - Problem with the automated mails

Post by Lumpy Burgertushie » Thu Sep 20, 2007 5:55 pm

it doesn't matter what address you have in the email section of the admin panel.

that has nothing to do with what email server your board is using to send email.

the smtp yes or no is what controls that.

now, your original problem was that no emails are going out.

that means that you need to change the smtp from no to yes and put in the smtp server address they told you to use.

then see if the board sends out emails or not.

if not, then try a username and password in those boxes for smtp ( use the same ones your host gave you when you signed up. )

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

adrina
Registered User
Posts: 36
Joined: Tue Aug 07, 2007 4:31 pm

Re: Please help me! - Problem with the automated mails

Post by adrina » Thu Sep 20, 2007 9:55 pm

Thanks Robert for your help.
I changed the set from no to yes, but always I get a general error message, if I posted a new message to any topic. Then I write my username and password but I got same error message.

GENERAL ERROR MESSAGE

DEBUG MOD

So seems this board mail system does not work with or without smtp.
Or I just do not know how I have to set it.

I do not understand...
Thanks
Adrina

Locked

Return to “2.0.x Support Forum”