search interval

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
rantbot
Registered User
Posts: 83
Joined: Sun May 07, 2006 1:37 pm

search interval

Post by rantbot »

Where is the control which sets this -

"You cannot make another search so soon after your last; please try again in a short while."

I found the setting which controls posting intervals, and changed it from the default to a much lower (and much less annoying) value. But I haven't found the one which controls search intervals.
User avatar
RMcGirr83
Former Team Member
Posts: 21902
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: search interval

Post by RMcGirr83 »

You can set it in the ACP->General->configuration...look for flood interval
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
Appreciate the extensions/mods/support then buy me a beerImage
rantbot
Registered User
Posts: 83
Joined: Sun May 07, 2006 1:37 pm

Re: search interval

Post by rantbot »

Yes, "flood interval" is the setting I set down to 5 seconds. That fixed the message posting problem. However my board still won't let searches be done at anything like 5 second intervals.
User avatar
RMcGirr83
Former Team Member
Posts: 21902
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: search interval

Post by RMcGirr83 »

the other flood setting ;)
Noname.jpg
Noname.jpg (11.61 KiB) Viewed 202 times
User avatar
Lumpy Burgertushie
Registered User
Posts: 68550
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: search interval

Post by Lumpy Burgertushie »

and if you dont' have that , then your style and/or your board, is not up to date.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
rantbot
Registered User
Posts: 83
Joined: Sun May 07, 2006 1:37 pm

Re: search interval

Post by rantbot »

Nope, don't have that in my control panel.

The board is new - I set it up about two months ago - but the style is Aqua, which is apparently not well supported or particularly up-to-date.

I have just pasted the missing code into board_config_body.tpl and now it is working properly. Thanks, all.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68550
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: search interval

Post by Lumpy Burgertushie »

rantbot wrote:Nope, don't have that in my control panel.

The board is new - I set it up about two months ago - but the style is Aqua, which is apparently not well supported or particularly up-to-date.

I have just pasted the missing code into board_config_body.tpl and now it is working properly. Thanks, all.
well, if you are missing that, then you are missing other things as well.

try this:

copy subSilver/profile_add_body.tpl,
subSilver/confirm_body.tpl
subSilver/admin/confirm_body.tpl
subSilver/admin/board_config_body.tpl

to your style folders.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
rantbot
Registered User
Posts: 83
Joined: Sun May 07, 2006 1:37 pm

Re: search interval

Post by rantbot »

Lumpy Burgertushie wrote:well, if you are missing that, then you are missing other things as well.

try this:

copy subSilver/profile_add_body.tpl,
subSilver/confirm_body.tpl
subSilver/admin/confirm_body.tpl
subSilver/admin/board_config_body.tpl

to your style folders.
Aqua isn't missing any of these files.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68550
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: search interval

Post by Lumpy Burgertushie »

rantbot wrote:
Lumpy Burgertushie wrote:well, if you are missing that, then you are missing other things as well.

try this:

copy subSilver/profile_add_body.tpl,
subSilver/confirm_body.tpl
subSilver/admin/confirm_body.tpl
subSilver/admin/board_config_body.tpl

to your style folders.
Aqua isn't missing any of these files.
It is probably missing the confirm files.

however, I did not mean that it was missing those other files, I meant that they are not up to date and copying the current version of subSilver files over the top of them will rewrite them with the updated versions.

I didn't think about this before, but if the aqua style is not based on subSilver, then you may not want to do this.

where did you get the aqua style from? I will check it out for you.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68550
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: search interval

Post by Lumpy Burgertushie »

ok, I just checked it.

copy the subSilver/admin/board_config_body.tpl
and the subSilver/admin/confirm_body.tpl

to the aqua folder and you should be fine.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
rantbot
Registered User
Posts: 83
Joined: Sun May 07, 2006 1:37 pm

Re: search interval

Post by rantbot »

Lumpy Burgertushie wrote:ok, I just checked it.

copy the subSilver/admin/board_config_body.tpl
and the subSilver/admin/confirm_body.tpl

to the aqua folder and you should be fine.
We're still talking at cross-purposes here.

I have substantially modified the aqua template my boards use. However the problem doesn't seem to have been any of my modifications. I still have all the unmodified aqua files for comparison.

Unmodified aqua includes files

aqua/confirm_body.tpl
aqua/admin/board_config_body.tpl

Both are similar but not identical to the same files in subSilver.

The original unmodified aqua version of board_config_body.tpl contains the code

Code: Select all

<tr>
<td class="row1">{L_FLOOD_INTERVAL} <br /><span class="gensmall">{L_FLOOD_INTERVAL_EXPLAIN}</span></td>
<td class="row2"><input class="post" type="text" size="3" maxlength="4" name="flood_interval" value="{FLOOD_INTERVAL}" /></td>
</tr>
The subSilver version of board_config_body.tpl contains the code

Code: Select all

<tr>
<td class="row1">{L_FLOOD_INTERVAL} <br /><span class="gensmall">{L_FLOOD_INTERVAL_EXPLAIN}</span></td>
<td class="row2"><input class="post" type="text" size="3" maxlength="4" name="flood_interval" value="{FLOOD_INTERVAL}" /></td>
</tr>
<tr>
<td class="row1">{L_SEARCH_FLOOD_INTERVAL} <br /><span class="gensmall">{L_SEARCH_FLOOD_INTERVAL_EXPLAIN}</span></td>
<td class="row2"><input class="post" type="text" size="3" maxlength="4" name="search_flood_interval" value="{SEARCH_FLOOD_INTERVAL}" /></td>
</tr>
The two fragments are identical except that the aqua version is simply missing the entire part for the search flood interval box and setting. So I just copied that part of the code from the subSilver version and pasted it into the aqua version. Now the flood control interval setting appears in my aqua control panel, as it should. Ta-da, problem solved.

The confirm_body.tpl files in both styles seem to be essentially identical, except that the aqua version has some aqua-specific images added to the tables. I haven't modified aqua/confirm_body.tpl at all, as everything seems to be working fine at the moment.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68550
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: search interval

Post by Lumpy Burgertushie »

my point was , that if your aqua files were missing that code, then they are/were out of date. that means that they are missing other bits of code as well.

there have been several updates to the subSilver files in the last few versions of phpbb.

many, if not most, of the styles out there have not been updated to have the correct code in them. ( aqua apparently being one of them. )

now, it is certainly your business whether you update your files or not, but that is what I was suggesting that you do.

luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
Locked

Return to “2.0.x Support Forum”