EasyMOD alpha3 v0.0.8 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu » Sun May 25, 2003 1:14 am

the amount of work behind this is HUGE!!!!

big thanks to Nuttzy99
Nitrotech - Alpha stage... Your own fully customisable forum! and site!

User avatar
Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 1:28 am

Nuttzy.....

i installed it......

but when i go to install a mod that's compliant...it doesnt work...i get errors......

Code: Select all

Warning: mkdir() failed (Permission denied) in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1403

Warning: chmod failed: No such file or directory in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1404

Warning: mkdir() failed (No such file or directory) in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1403

Warning: chmod failed: No such file or directory in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1404

Warning: mkdir() failed (Permission denied) in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1429

Warning: chmod failed: No such file or directory in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1430

Warning: mkdir() failed (No such file or directory) in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1429

Warning: chmod failed: No such file or directory in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1430

Installation Failed
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ.

Critical Error

Could not open [includes/functions.php.txt] for writing.
MOD script line #123
any help here guys?
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

User avatar
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 2:16 am

Ok, we'll take each user one at a time here ;) First up is Ptirhiik...
Ptirhiik - RPGnet-fr wrote: A very first comment : set the root zip dir to admin, not mod, or you will be sure than people will install it at the root ;)
Hrmmm... not sure if I want to do that, but I'll include a screen pic of the layout just in case ;) - to do: screenie
2003/05/24 : issue with the directory under windows/easyPHP :
Current working directory: c:\documents and settings\pierrot\bureau\site\forum_mod\admin\mods\easymod
My best bet is about the case in the dir name : the dir name is verified to have the upper case in it.
I'll be sure to make it case insensitive in the next version. - to do: code insensitivity - no! can't do this!
2003/05/24 : Sys warning on close and chmod not muted :
Yeah I was aware of these. Was easier to leave them than to fix the actual problem ;) It's alpha so its acceptable :P - to do: fix the root cause
2003/05/25: pack language duplication issue : as easy mod install on all language the $lang[] keys, installing a foreign pack after makes lines to be duplicated.
I think I understand what you are saying. You install a MOD and all goes well, you then install another lang pack for that MOD and it creates dupe entries. I would say this is more of a MOD Template issue than an EM issue. We are going to need to come up with a consistent way of installing lang packs. This has been discussed a bit by the MOD Team already but nothing solid yet. We are going to need an entire system similar to what I've done with BBCodes. I don't feel like doing this yet :lol: - to do: nothing yet
2003/05/25: issues on finding lines althought they exists exactly
I actually trim left and right and then do a strstr. This I'll have to see for myself. What MOD is giving a problem?
- It seems to miss the upload process to get a mod dir to the process dir. Also the remove a mod from the non install list missing too.
Not sure what you are alking about. Tell me what your write and copy methods are and I may better understand.
- loose of tabulation on the display step 1 of 3 of mod installation
Not sure what you mean. Please explain further.
- sql not execute warning although there's no sql request to perform in the first mod I try :)
Heh, well this step isn't going away. If there are no SQL lines it will say so, but for this version there was no need to get into that ;)
- no process achieve at all (neither parsing it seems) after a copy failed (despite I don't see why it fails, but you mentioned issues on it ;)). I've tried with categories hierarchy 1.1.0
I'll need to know your write and copy methods selected.
- all the FIND/PROCESS doesn't seem to be performed in a file when an error has been encountered : some of them seem not to be taken, even if there is no problems with.
Processing will completely halt if FIND fails in a core file. If a FIND fails in a non-English lang or non-subSilver theme file then the rest of the processing is not (and cannot be) done. So what files are giving you the issue?

phew! Answer those questions for me and let me know anything else you may see.

Next up will be wGEric when I get a chance :P

Thanks!
-Nuttzy :cool:
Last edited by Nuttzy99 on Sun May 25, 2003 7:46 pm, edited 1 time in total.
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 2:38 am

wGEric wrote: 2003/05/24 : INVALID PASSWORD SUPPLIED
Grrrrrr!!!! I tested this so many times and then I stop setting the password so I could save a little time. I must have broken it :evil: - to do: simple fix
2003/05/24 - Issue with installing BBCode
Nope, not an error. EM no longer handles the BBcode thing. You'll have to install the multi-bbcode MOD beforehand.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
Pit
Security Consultant
Posts: 2056
Joined: Sat Oct 13, 2001 8:17 pm
Location: kµlt øƒ Ø™
Contact:

Post by Pit » Sun May 25, 2003 2:38 am

Ptirhiik - RPGnet-fr wrote:
Nuttzy99 wrote:(../..)Remember it is EasyMOD for the folder name and its case sensitive(../..)
Not on windows ;). Perhaps you should simply get it to lowercase, as it usually done ;).

I think you'll find most webservers are case sensitive regardless of OS ;)

As for programs having uppercase characters in the default directory name..hmm, I can't think of any, can you? ;)
Image
super fun rainbow colour sig

User avatar
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 3:14 am

GPHemsley wrote: Password doesn't seem to work right.
Yup, I know to fix that now.
but it couldn't find one of the lines, thus causing installation to halt.... Even though it said it continued and finished properly.
If it fails on a core file, then it halts. If it fails on a non-english lang file or non-subSilver theme file, then it throws a warning, stops processing that particular file, but continues processing everything else. The idea is that just b/c it fails on some obscure theme, that should not hold up everything else. You always have the option of not continuing the install if it is too big a deal.
Constant IN_PHPBB already defined [...] on line 24
Sounds like you have a previous version of EM installed and still have the entry in consants.php. Is that right?
Warning: fclose(): + chmod()
Yup, I already discussed these. Just ignore them ;)
OK, the Not Found error was because of the MODded board, but I don't think it should halt when that happens.... Opinions?
If it can't find something then without question it needs to fail.
I never changed anything except through installing it three times... I used it to completely proofread my New Post Type MOD. :D
You must have not used a password on the third time, that's the only way it will work right now :lol: Good to hear you found it useful ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Sun May 25, 2003 3:17 am

First at all, I've tried on three of my mods :
- Split topic type, which is a very simple one,
- Group moderatorZ, more sophisticated,
- Categories hierarchy, which is the hughe one.

Language issue appears of course on the 3 of them. The 2 first ones were installed correctly, other reports are about the categories hierarchy.

Settings:
o reading : server
o writing : server
o moving : copy
o no ftp set (as I'm on the local computer)
o brand fresh new phpBB2.0.4, with "official" language french pack installed.

Language entries duplicate :
you've got the point : the only fixes I can see is to remove from the original file the $lang[] key that will be added by the language pack, or let the user choose which language files/templates files will be modified by an english language/subsilver template mod. I don't check it at this time, but the problems is certainly the same with templates.

issues on finding lines
This I'll have to see for myself. What MOD is giving a problem?
Categories hierarchy, on index.php. Is the trim() performed on searched and readed lines ?

upload process
Actualy this will be an "add" button on the "Unprocessed MODs" screen, in order to upload a mod dir to the admin/mod dir. Also a remove button could be of some use ;).

loose of tabulation on the display step 1 of 3 of mod installation
All indentation tabs (#15) are removed from the code. This could be rather confusing when you have to check on an error ie.

all the FIND/PROCESS doesn't seem to be performed in a file when an error has been encountered
what files are giving you the issue?
index.php, categories hierarchy mod, on the display of the first pass.


I keep by my side further request, as mentioning in the header of each phpBB file the date of modding and the name/version of the mod, building also a changelog list, those kind of thing that will be more for the beta stage ;).
Last edited by Ptirhiik on Sun May 25, 2003 3:21 am, edited 1 time in total.

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 3:20 am

Nuttzy99 wrote:
Constant IN_PHPBB already defined [...] on line 24
Sounds like you have a previous version of EM installed and still have the entry in consants.php. Is that right?

The only version I have ever installed was this one... Of course I did it 3 times, so....
Nuttzy99 wrote:
I never changed anything except through installing it three times... I used it to completely proofread my New Post Type MOD. :D
You must have not used a password on the third time, that's the only way it will work right now :lol: Good to hear you found it useful ;)

What I meant was, the password that I had entered the first two times (which didn't work afterward) worked after the third installation, where I never entered a password! 8O Go figure....
Last edited by GPHemsley on Sun May 25, 2003 3:22 am, edited 1 time in total.

User avatar
LLivingLarge
Registered User
Posts: 37
Joined: Mon May 19, 2003 3:20 am

Post by LLivingLarge » Sun May 25, 2003 3:20 am

I'm getting parsing errors and CHMOD is not being verified.

User avatar
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 3:45 am

Kazer0 wrote:
read access :: OK
write access :: OK
root path write :: failed
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: failed
FTP extension :: OK
copy access :: OK
Judging from this, write=server and move=FTP should work fully automated for you. The script should work also. You don't need to chmod -R 777 everything... just everything from the "mods" folder down.
Reading Server
Writing On Screen
Moving Copy
If you write on screen then you MUST manually move. Copy doesn't work by magic, the files have to already be on the server ;)

And those fclose and chmod warnings have been discussed and you can ignore them.
I tried it all now. I keep getting that error in the ACP.
BTW, Is it supposed to say
MOD ainstall

in the acp?
Sounds like through all the problems you had that lang_easymod.php never got moved into language/lang_english directory.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Sun May 25, 2003 3:49 am

Technically it should install anything that passes the MOD Template specs.
A parser that validates MOD Templates can be found here: http://smigit.www2.dotnetplayground.com/validator.aspx

I'm gonna test this as soon as I can nuttzy 8)

User avatar
Kazer0
Registered User
Posts: 876
Joined: Sun Nov 10, 2002 2:05 am
Location: {postrow.POSTER_FROM}
Contact:

Post by Kazer0 » Sun May 25, 2003 3:50 am

I hope its my turn soon.
Andrew Charron || alexis support forum || Specializing in phpBB website template integration
Hurry up, my feash is siek.
AndrewCharron.com version 5 released!

User avatar
Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 3:54 am

Nuttzy99 wrote:
Kazer0 wrote:
read access :: OK
write access :: OK
root path write :: failed
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: failed
FTP extension :: OK
copy access :: OK
Judging from this, write=server and move=FTP should work fully automated for you. The script should work also. You don't need to chmod -R 777 everything... just everything from the "mods" folder down.
Reading Server
Writing On Screen
Moving Copy
If you write on screen then you MUST manually move. Copy doesn't work by magic, the files have to already be on the server ;)

And those fclose and chmod warnings have been discussed and you can ignore them.
I tried it all now. I keep getting that error in the ACP.
BTW, Is it supposed to say
MOD ainstall

in the acp?
Sounds like through all the problems you had that lang_easymod.php never got moved into language/lang_english directory.

-Nuttzy :cool:


that's your turn!!lol, i should be up next
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 3:59 am

Davidls wrote: Technically it should install anything that passes the MOD Template specs.
A parser that validates MOD Templates can be found here: http://smigit.www2.dotnetplayground.com/validator.aspx

I'm gonna test this as soon as I can nuttzy 8)

It's not updated for the new template....

Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu » Sun May 25, 2003 4:05 am

im having trouble connecting to my ftp.

When I get the ftp info wrong it jsut says: FTP ERROR: login failed

but when I get the ftp info right it eather doesnt load the next page or it takes ages and whne it does load it says: Fatal error: Maximum execution time of 30 seconds exceeded in /home/decoder/public_html/cacfe/admin/mods/EasyMOD/admin_easymod_functions.php on line 1250

I am running phpBB 2.0.4 and MySQL
Nitrotech - Alpha stage... Your own fully customisable forum! and site!

Locked

Return to “[2.0.x] MOD Writers Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests