EasyMOD alpha3 v0.0.8 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
User avatar
espenhh
Registered User
Posts: 215
Joined: Sun Mar 17, 2002 8:27 pm
Location: Norway
Contact:

Post by espenhh » Sun May 25, 2003 5:15 pm

In step 4 of the installer:

Code: Select all

Warning: fclose(): supplied argument is not a valid stream resource in /hsphere/local/home/serqevx/serqevx.com/espenhh/EM/admin/mods/EasyMOD/admin_easymod_functions.php on line 1576
Warning: chmod() [function.chmod]: No such file or directory in /hsphere/local/home/serqevx/serqevx.com/espenhh/EM/admin/mods/EasyMOD/admin_easymod_functions.php on line 1593
Warning: fclose(): supplied argument is not a valid stream resource in /hsphere/local/home/serqevx/serqevx.com/espenhh/EM/admin/mods/EasyMOD/admin_easymod_functions.php on line 1576
Warning: chmod() [function.chmod]: No such file or directory in /hsphere/local/home/serqevx/serqevx.com/espenhh/EM/admin/mods/EasyMOD/admin_easymod_functions.php on line 1593
Looks like there is some mistakes here :P or is it me

BTW; great thing, this easymod. (if it works ;))
ALT du trenger til phpBB - på Norsk!
Besøk phpbb.no:
Image

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Sun May 25, 2003 5:25 pm

Changelog : I think it would be more convenient to store this in a txt cumulative file (as for history), or in a topic (deluxe version ;)). But let's talk about this when we will be in the beta stage : it's more avanced functions adding discuss than making the product going into a beta stage : I will make it back to your attention when the beta will be opened :).
Last edited by Ptirhiik on Sun May 25, 2003 5:25 pm, edited 1 time in total.

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 5:25 pm

Espenhh, he already addressed those issues... Just ignore them! :D

User avatar
espenhh
Registered User
Posts: 215
Joined: Sun Mar 17, 2002 8:27 pm
Location: Norway
Contact:

Post by espenhh » Sun May 25, 2003 5:40 pm

GPHemsley wrote: Espenhh, he already addressed those issues... Just ignore them! :D


It's okay with some warnings for me, but easymod dont show up in the adminpanel!!!!!!!! That's confusing!!!!

Nothing I can do to fix this. It's really strange that I cant make it with this warning, but all you other can... Hmm :?
ALT du trenger til phpBB - på Norsk!
Besøk phpbb.no:
Image

LLivingLarge
Registered User
Posts: 37
Joined: Mon May 19, 2003 3:20 am

Post by LLivingLarge » Sun May 25, 2003 5:45 pm

Nuttzy, I can't find those directories you told me to delete.

Super Saiyan Gecko
Registered User
Posts: 77
Joined: Wed Mar 12, 2003 9:20 am
Location: Planet Vegeta
Contact:

Post by Super Saiyan Gecko » Sun May 25, 2003 6:56 pm

Ummm, hi. I was told to come here with this problem. I just installed EasyMOD tried to install a mod called "online_offline_1_2_0.mod"
But through the prosses I was told by a mate to just keep going on and it would everything itself.

On the first page it said

MOD Data
MOD Title: Online/Offline in viewtopic.php 1.2.1 online_offline_1_2_0.mod
Author: romans1423 romans1423@hotmail.com Rick Beckman www.spiritsword.com
Processed Themes: subSilver; Crisp
Processed Languages: english
Files Edited: 6
Commands Processed: 18
Unprocessed Commands: 0



The follwing commands were not recognized by EasyMOD and were ignored. The MOD script line number is displayed.
Unprocessed Commands


EasyMOD successfully processed the following commands:
Commands Processed
OPEN line #41
viewtopic.php

FIND line #47
u.user_allowavatar, u.user_allowsmile,

AFTERADD line #53

u.user_allow_viewonline, u.user_session_time,


FIND line #59
$template->assign_block_vars('postrow', array(

BEFOREADD line #65

//Online/Offline
if (($postrow[$i]['user_session_time'] >= ( time() - 300 )) && ($postrow[$i]['user_allow_viewonline']))
{
$on_off_hidden = '<img src="' . $images['icon_online'] . '" alt="' . $lang['Online'] . '" title="' . $lang['Online'] . '" border="0" />';
}
else if (($postrow[$i]['user_allow_viewonline']) == 0)
{
$on_off_hidden = '<img src="' . $images['icon_hidden'] . '" alt="' . $lang['Hidden'] . '" title="' . $lang['Hidden'] . '" border="0" />';
}
else if ($poster_id == ANONYMOUS)
{
$on_off_hidden = '';
}
else
{
$on_off_hidden = '<img src="' . $images['icon_offline'] . '" alt="' . $lang['Offline'] . '" title="' . $lang['Offline'] . '" border="0" />';
}


FIND line #87
'POSTER_AVATAR' => $poster_avatar,

AFTERADD line #93

'POSTER_ONLINE' => $on_off_hidden,


OPEN line #99
language/lang_english/lang_main.php

FIND line #105
//
// Viewonline
//

BEFOREADD line #113

//
// Online/Offline
//
$lang['Offline'] = 'Offline';
$lang['Online'] = 'Online';
$lang['Hidden'] = 'Hidden';


OPEN line #124
templates/subSilver/subSilver.cfg

FIND line #130
?>

BEFOREADD line #136

$images['icon_online'] = "$current_template_images/{LANG}/icon_online.gif\" width=\"59\" height=\"18";
$images['icon_offline'] = "$current_template_images/{LANG}/icon_offline.gif\" width=\"59\" height=\"18";
$images['icon_hidden'] = "$current_template_images/{LANG}/icon_hidden.gif\" width=\"59\" height=\"18";


OPEN line #144
templates/subSilver/viewtopic_body.tpl

FIND line #150
{postrow.PROFILE_IMG}

BEFOREADD line #156

{postrow.POSTER_ONLINE}


COPY line #162
copy icon_online.gif to templates/subSilver/images/lang_english/online.gif
copy icon_offline.gif to templates/subSilver/images/lang_english/offline.gif
copy icon_hidden.gif to templates/subSilver/images/lang_english/hidden.gif

CLOSE line #170



On the second page it said:



Database Alterations - DISABLED

Pseudo SQL Allow
NOTE: SQL processing has been disabled in Alpha 3 and no alterations to your database will actually be preformed. It will be implemented in Beta 1. Press "Complete Installation" to continue.




And then it finally said:




General Error
Could not obtain EasyMod information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax near 's online status in viewtopic.php.', 1053887862, '2.0.4', 'subSilver; Crisp', 'en' at line 2

INSERT INTO phpbb_easymod ( mod_file, mod_title, mod_version, mod_author_handle, mod_author_email, mod_author_url, mod_author_name, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited) VALUES ( 'online_offline_1_2_1//online_offline_1_2_0.mod', 'Online/Offline in viewtopic.php', '1.2.1', 'romans1423', 'romans1423@hotmail.com', 'Rick Beckman', 'www.spiritsword.com', 'This MOD outputs graphically a user's online status in viewtopic.php.', 1053887862, '2.0.4', 'subSilver; Crisp', 'english', 6)

Line : 2102
File : /home/virtual/site50/fst/var/www/html/forums/admin/admin_easymod.php

So ummm, what happen´? what do I doo, and does it look bad???
Signature edited for violation of Forum Rules

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP &amp; MySQL
Contact:

Post by Questions » Sun May 25, 2003 7:08 pm

that means that the SQL database function in EasyMOD is disabled which means that you have to manually alter or add the tables.....

easymod doesnt do it by its self.....

and the last part of your error means that there is no EasyMOD Table in your phpmyadmin
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:15 pm

LLivingLarge wrote: Nuttzy, I can't find those directories you told me to delete.
You have a seriously wierd problem. I definitely want to track it down though. Just give a bit (maybe tomorrow) to send you something to help figure out what is going on. You'll become my new guinea pig and by solving your problem we'll probably help out many in the future with the same problem. Hang in there ;) But if you can't wait then you could always set write=download and move=manual. Would not be automated though :( So hopefully you can wait a bit and we'll get an automated method working for you ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:20 pm

Questions wrote:

Code: Select all

Warning: Unable to create '..//'

Critical Error: COPY ERROR: could not move file [./mods/board_msg_xl/board_message_xl.php] to [..//]
...looks to me to be an error with the MOD itself. If you post the line from the MOD script where it tries to copy board_message_xl.php then I'll take a look ;)
FIND FAILED: In file [includes/usercp_register.php] could not find:

$location = $userdata['user_from'];

MOD script line #240
Most likely you have another MOD installed that has modified this line already. You might want to manually search for "$location = " (without the quotes) to see what the line now looks like. I'd be interested in knowing what MOD changed that line too.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Sun May 25, 2003 7:25 pm

Nuttzy99 wrote: Eventually you'll probably end up providing more support for it than I do, Mr. phpBB Guru :lol:


no problem for me if i can help :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:25 pm

Ptirhiik - RPGnet-fr wrote: I will make it back to your attention when the beta will be opened :).
Please do ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:28 pm

espenhh wrote: It's okay with some warnings for me, but easymod dont show up in the adminpanel!!!!!!!! That's confusing!!!!

Nothing I can do to fix this. It's really strange that I cant make it with this warning, but all you other can... Hmm :?
No, some others are getting the message too, but they are ignoring it b/c it is harmless.

You do have a big problem though if MOD Center is not appearing in the ACP. Sounds like it did not install correctly. What did you use for the write and move methods? Also, please post the scan info the installer displays on the left side of the first page so I can see what is going on ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:33 pm

Super Saiyan Gecko wrote: INSERT INTO phpbb_easymod ( mod_file, mod_title, mod_version, mod_author_handle, mod_author_email, mod_author_url, mod_author_name, mod_description, mod_process_date, mod_phpBB_version, mod_processed_themes, mod_processed_langs, mod_files_edited) VALUES ( 'online_offline_1_2_1//online_offline_1_2_0.mod', 'Online/Offline in viewtopic.php', '1.2.1', 'romans1423', 'romans1423@hotmail.com', 'Rick Beckman', 'www.spiritsword.com', 'This MOD outputs graphically a user's online status in viewtopic.php.', 1053887862, '2.0.4', 'subSilver; Crisp', 'english', 6)

So ummm, what happen´? what do I doo, and does it look bad???
Damn! Looks like a legit 8-legged fiend :( I thought I had squished this bug in the previous version, but obviously not. I'll be sure to fix this, but you don't need to wait for me. Just edit the MOD script and remove the single quote in "user's online status" from the description field of the MOD script.

to do: str_replace ' with '' on EM insert

Good find ;)
-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP &amp; MySQL
Contact:

Post by Questions » Sun May 25, 2003 7:35 pm

ok, first of all, i just wanted to remind you that the db alterations task is disabled...lol...so i had to manually do that, no biggie.....

here's an error i got at the very end(for the board message xl mod)

Code: Select all

Warning: Unable to create '..//': Is a directory in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1708 


General Error 
Critical Error: COPY ERROR: could not move file [./mods/board_msg_xl/board_message_xl.php] to [..//] 
ATTEMPING REMAINDER OF POST PROCESS

and also for the country flags......

Code: Select all

 
Installation Failed 
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ. 



  
Critical Error 

FIND FAILED: In file [includes/usercp_register.php] could not find: 

$location = $userdata['user_from']; 

MOD script line #240
whats going on??


thanks Nuttzy
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:48 pm

Nuttzy99 wrote:
Ptirhiik - RPGnet-fr wrote:2003/05/24 : issue with the directory under windows/easyPHP :
Current working directory: c:\documents and settings\pierrot\bureau\site\forum_mod\admin\mods\easymod
My best bet is about the case in the dir name : the dir name is verified to have the upper case in it.
I'll be sure to make it case insensitive in the next version. - to do: code insensitivity - no! can't do this!


What was I thinking? Of course this must remain case sensitive. It's a directory and when moving or accessing files I'll need the EXACT path name. So people will have to use "EasyMOD" not "easymod", sorry ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Locked

Return to “[2.0.x] MOD Writers Discussion”