[phpBB Debug] PHP Notice Problem -Please Help!!!-

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

[phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

I have phpbb 3.1 installed and I was trying to install the gallery mod and I must have "empty" some of the sessions files form my "phpmyadmin" so know when I go to my site I get this error message. Is there anyone that could please walk me through some trouble shooting or something, I have worked my butt of on this site and I hope it's not forever messed up. I have all of my files backed up and I have tryed replacing them all but that doesn't do anything. Please Help! :cry:

[phpBB Debug] PHP Notice: in file /includes/session.php on line 424: session::include_once(./includes/auth/auth_.php) [function.session-include-once]: failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/session.php on line 424: session::include_once() [function.include]: Failed opening './includes/auth/auth_.php' for inclusion (include_path='.:/usr/local/php5/lib/php')
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
Language file /common.php couldn't be opened.

This is the data i have for the request:
Your board's URL: http://www.spartansofolympus.com/
Version of phpBB3: phpbb 3.0.1
Was this a fresh install or a update/upgrade/conversion? update from 3.0.0
Did you use an automated wizard provided by your host to install phpBB? No
MODs you have installed: Filebase Mod 2.0, Media Gallery, [Beta]Donation MOD with PayPal IPN Ver 1.0.4, Activity Stats MOD (Highway of Life), Simple Quick Reply, & ACP Announcement Centre
When the problem started: 1 day ago (July 12, 2008)
Your level of expertise: Basic
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

You are missing

Code: Select all

$acm_type = 'file';
from your config.php
User avatar
stickerboy
Former Team Member
Posts: 7349
Joined: Mon Mar 29, 2004 2:27 pm
Location: Airdrie, UK (127.0.0.1)
Name: Kenny Cameron
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by stickerboy »

If this happened after you installed a MOD, you should ask the MOD author in their support thread for help :)
I'm a web-designing code-decrypting tech-support musician
|| Twitter || Flickr || phpBB Snippets ||
Formerly known as cherokee red
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

Brf wrote:You are missing

Code: Select all

$acm_type = 'file';
from your config.php

How do I add that? This is what my config file consists of-
<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysql';
$dbhost = '';
$dbport = '';
$dbname = 'spart12_forum';
$dbuser = *******';
$dbpasswd = **********'

$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>
Last edited by slidewayz88 on Sun Jul 13, 2008 2:45 pm, edited 1 time in total.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

Check this atricle: http://www.phpbb.com/kb/article/rebuild ... gphp-file/
I do not know why you would be missing that line.
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

Does my config file look ok? I rebuilt it and it still doesn't work
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

Oh wait. That is a different problem.
You are missing your auth_method from your config table. You must have deleted it or something.
Last edited by Brf on Sun Jul 13, 2008 2:54 pm, edited 1 time in total.
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

ok good, how would I replace it? (Im just really hoping this works lol)

P.S. This was not because of the MOD I tried to install it was a stupid mistake I made that I dont know how to fix.
Last edited by slidewayz88 on Sun Jul 13, 2008 2:55 pm, edited 1 time in total.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

Well... Where did it go? If you deleted a bunch of rows from your config table, you will have to put them back.
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

I'm not sure I emptied them in my "phpmyadmin" can I get them back or set them up again
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

Well.... restore from a backup or reinstall.
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

I didn't make a back of my database just my phpbb3 files for the site so what would be the best way for me to reinstall the phpbb database and modules

This is what I did:
Do you really want to :
TRUNCATE TABLE `phpbb_config`
and then I clicked yes
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

If you do not have a backup, then you will need to reinstall, unless your host has made a backup for you.
slidewayz88
Registered User
Posts: 15
Joined: Mon Mar 24, 2008 7:26 am

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by slidewayz88 »

when u say reinstall u mean phpbb 3 right?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [phpBB Debug] PHP Notice Problem -Please Help!!!-

Post by Brf »

This is phpBB3 support isn't it?
Locked

Return to “[3.0.x] Support Forum”