[ABD] Custom Title MOD

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Hi!

I am doing this line in the SQL:

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;

Can someone explain this to me better?

This is what I have put so far:

Field: user_custom_title
Type: VARCHAR
Length/Values: 255
Null: not null


I'm not sure what I should put for the default.
Leave it blank?
or am I putting "AFTER user_rank" or something?

What I did, before I started this column "row", I put the the option to insert it after the "user_rank" row.
Is that the correct thing? and the default blank?

Please reply quickly anyone.
I'm in the middle of installing and am waiting for any help.

Thanks!
-Andrew
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: [BETA] Custom Title MOD

Post by Gremlinn »

Why don't you paste that code into a SQL query window and run it?
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Hi,

I'm a noob to MySQL Databases.

I'm not sure how these things work.

I did try to do something like that.

I'll see how it works out.

Thanks.
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Hi again!

I believe I have successfully installed the MOD.
But now I can't find where to set the permissions.

I activated the MOD already in the General Tab:

Custom title settings

Here you can set all default settings for custom titles.



But now I can find our how to set the permissions for the user groups.

As the owner said himself:
The other big thing is that, by default, no one has title-editing permissions, so you need to make sure to assign those permissions to groups/roles/users/whatever. In most cases, I'd recommend assigning the "can change custom title" permission to the standard user role. People with other needs will have to adjust accordingly. (Just make sure not to give the "can ignore post and membership requirements" permission to everybody.)


Can anyone point me out exactly where is that option?

I went in:
User administration => Groups’ permissions.

And I do not see anything to do with Custom title settings.

Please help me our someone.

And also,
exactly what part of the Users CP will this option appear?
Because I do not see it there right now, either.
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Ok,
By reading the other posts I was able to find the permissions as show below.

Image

But every time press the "Submit" Button, after checking "Can edit own custom title"
I see the usual green confirmation screen, but when I check the options again, it is the same.
The radio button is set to no again.

What can be causing this?

I got an SQL error once, but I never say it again after that.

Please help someone.
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

DIY Instructions
1) Clear the cache by clicking the appropriate option in the ACP. In addition, visit the "Templates" section of the "Styles" section of the ACP and click on "Refresh" for each of your templates. Otherwise, the templates may not update and you may get database errors.
What exactly do you mean by:
Clear the cache by clicking the appropriate option in the ACP"

I know how to refresh the Themes, Templates and Image Cache. But can you please explain how to clear this cache you are talking about here?
May this be causing a problem?


Also I noticed this odd thing:
Image

What is this "Choose module mode" all about?
By default it is set to "A"
I try to change it, and I get the Green Screen confirmation that it was successful.

But when I check back, it is stuck on "A" still.

What is up with that?
What are those letter A's there?


I think my problem with this MOD, is that the options are not updating.

I tried altering other similar options, and they are all saved as normal.

Can the maker of this Mod or anyone, please tell me why you think my options for this Mod is not updating?

There has to be some sort of explanation...
Please answer anyone!
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
Kharon
Registered User
Posts: 235
Joined: Thu Oct 26, 2006 5:27 pm

Re: [BETA] Custom Title MOD

Post by Kharon »

Hi

yes,I did check my file (ucp_pm_viewmessage.php & ucp_pm_viewmessage.html ) but file is not the problem .. and I did SQL changes

sorry,my english
thanks
Gremlinn wrote:What are you waiting for? Are you re-checking your edits in the ucp_pm_viewmessage.php file like Aexoden suggested? I did not have a problem installing this mod, all the edits where there. Might I also suggest checking your users table for a column for custom_title? Make sure you did the SQL changes.
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

I think I got everything working,
but I still can't find where the users are allowed to edit their Custom Titles...

Is it supposed to be in: User Control Panel => Profile?

I don't see it there.

Someone please help!
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

EpsilonX5 wrote:I think I got everything working,
but I still can't find where the users are allowed to edit their Custom Titles...

Is it supposed to be in: User Control Panel => Profile?

I don't see it there.

Someone please help!
Why can't someone answer my question?

I haven't been able to get this Mod working since I've tried to install it.

This is very frustrating...
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Custom Title MOD

Post by ham1299 »

EpsilonX5 wrote:
EpsilonX5 wrote:I think I got everything working,
but I still can't find where the users are allowed to edit their Custom Titles...

Is it supposed to be in: User Control Panel => Profile?

I don't see it there.

Someone please help!
Why can't someone answer my question?

I haven't been able to get this Mod working since I've tried to install it.

This is very frustrating...
Yes, that is where it should be. Here's a screen shot:

Image


I'm not sure if it shows up if permissions aren't set, though. Have you set the permissions?
Heather
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Yes I have set the individual Permissions for everyone to use this Modification.

Please look at this screen shot:
Image

I posted this already above, but no one has responded to it yet.

This seems to be the possible source of my problem.

When I change that A to Custom Title Settings and I press submit.

I see the confirmation "Green" confirmation message.
But when I check back the option again.
It is reset to A again.

Something looks really wrong with that...

To get there, I went to:
System ->
Administration Control Panel ->
General ->
Board configuration ->
Custom title settings ->
Edit Button


Then I see:
Choose module mode:
Choose the modules mode being used.

Can anyone else please check this option and post what yours is set as?

And any idea why my settings is not updating?

Thanks.
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
ham1299
Registered User
Posts: 613
Joined: Mon Sep 11, 2006 2:12 am
Location: USA
Contact:

Re: [BETA] Custom Title MOD

Post by ham1299 »

Gosh, I don't know. I'm sorry. I have no idea why it would be doing that. Did you go through your edits and make sure you did them correctly?
Heather
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Yeah I'm pretty sure I went through them correctly.

I don't really make errors installing my Mods.

I'll try to check again and see if I find an error.

Can you please tell me what your settings look like for that option I showed in the screenshot?

Thanks for your help.
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: [BETA] Custom Title MOD

Post by Gremlinn »

Did you apply the template changes?
EpsilonX5
Registered User
Posts: 59
Joined: Sat Jul 26, 2008 4:24 am

Re: [BETA] Custom Title MOD

Post by EpsilonX5 »

Yes I have done all of that many many times since I've installed this Custom Title Mod.

I have even installed other Mods after this.

I have refreshed Template, Themes, cache, but it still won't work...
Andrew Emmanuel Davis
Image
Make your hi5 Profile the coolest!: hi5 Profile Generator
Find all the hi5 Codes you need: ★ hi5 Codes ★
Visit my hi5 Profile: Andrew's hi5 Profile
Locked

Return to “[3.0.x] Abandoned MODs”