[RC] NewsSync 1.5.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Fri Oct 24, 2003 6:49 am

Okay this only worked once for me, then Installed the pseudo_cron.php hack and now the graphics are missing in the forums and also the admin panel for newssync just comes up with a blank screen.

I have tried everything in this thread but still no luck... here's my config file

Code: Select all

// ***
// Directory Settings
// ***
//
// $newsSync_rootdir is the absolute path to where you installed NewsSync
// this can exist anywhere (even outside of docroot) - must end in /
//
$newsSync_rootdir = "/import_fs2/home/edcnz/taf/public_html/newssync/";

//
// $phpbb_root_path is the FULL path to phpBB (must end in /)
//
$phpbb_root_path = "/import_fs2/home/edcnz/taf/public_html/PostNuke/modules/PNphpBB2/"; 

//
// data directory (this can be anywhere) must end in /
//
$newsSync_datadir = "/import_fs2/home/edcnz/taf/public_html/temp/"; 

// ***
// PHPNUKE Integration Settings
// ***
$newsSync_enable_phpnuke_mod = false;
// full path the phpNUKE
$newsSync_NUKE_PATH = "";

// ***
// POSTNUKE Integration Settings
// ***
$newsSync_enable_postnuke_mod = true;
// set newsSync_POSTNUKE_PATH to the absolute path of postnuke
$newsSync_POSTNUKE_PATH = "/import_fs2/home/edcnz/taf/public_html/PostNuke/";

This was working fine until I installed the pseudo_cron part into the common.php file now I get the above problems.

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow » Fri Oct 24, 2003 3:09 pm

Lurchnz wrote: Okay this only worked once for me, then Installed the pseudo_cron.php hack and now the graphics are missing in the forums and also the admin panel for newssync just comes up with a blank screen.

I have tried everything in this thread but still no luck... here's my config file


This was working fine until I installed the pseudo_cron part into the common.php file now I get the above problems.


were you running from the command line or from the NewsSync/status page.

before you use pseudo_cron, you MUST be able to run from the Status page

if you cannot then it is a permission problem. set permissions for the webserver user (apache, nobody, or whatever) to r+x all newssync files and r+w data directory.

-k

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Fri Oct 24, 2003 7:27 pm

Everything was working fine until I setup pseudo_cron after that I got blank pages when trying to access it from admin. I could run everything from from the NewsSync/status page and it looked all okay.

Also the graphics are missing in the forum, they are looking at the below path but if I take pseudo_cron line out of common.php it works fine again. I also get strange errors which flash really quickly when I try to add or change an avatar after adding pseudo_cron :(

Code: Select all

http://www.mywebsite.net/import_fs2/home/edcnz/taf/public_html/PostNuke/modules/PNphpBB2/templates/PNTheme/images/folder.gif
Wierd?

The newssync directory, I've tried alsorts of permissions on that. Currently it's 777, the same for the data folder.
Last edited by Lurchnz on Fri Oct 24, 2003 7:29 pm, edited 1 time in total.

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Fri Oct 24, 2003 7:28 pm

oh I can't access newssync either way now, with or without pseudo_cron :(

mood
Registered User
Posts: 18
Joined: Tue Apr 15, 2003 11:20 am
Location: Zurich-Switzerland

install-settings - update-path-blank screen

Post by mood » Sat Oct 25, 2003 10:27 am

When trying to upgrade from 1.0.4 , I enter the correct paths, above and in my web server's root directory and no matter what, I always get a blank screen.

Using W2K-Sambar-PHP 4.3.3

Is there a way to do the update manually?
or debug it?

or do you have a better idea?

thanks

Alex

mood
Registered User
Posts: 18
Joined: Tue Apr 15, 2003 11:20 am
Location: Zurich-Switzerland

IGNORE: install-settings - update-path-blank screen

Post by mood » Sat Oct 25, 2003 11:21 am

Pls ignore my post before this.

I had a permissions things (on windows ? :-)))

sorry for the noise

Alex

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Sat Oct 25, 2003 12:30 pm

What permissions did you change??? I have tried ever permission setting I can think of :(

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Sat Oct 25, 2003 12:55 pm

SQL fault.. corrupt data in the end :) Now just have to get newssync to start ;)

mood
Registered User
Posts: 18
Joined: Tue Apr 15, 2003 11:20 am
Location: Zurich-Switzerland

Post by mood » Sat Oct 25, 2003 3:47 pm

I had changed NTFS permissions in a parent directory,the web server's service account wasn't allowed to read or write that directory.

anyway..so far so good..the update worked like a charm and so far the gateway is threading nicely between the news server, a mail list and phpBB.

wish you all a good weekend

Alex

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Sun Oct 26, 2003 1:55 am

Convert Subject From
Using regular express, see php function preg_replace.
Convert Subject To
Second half of convert subject.
Convert Body Text From
Using regular express, see php function preg_replace.
Convert Body Text To
Second half of Convert Body Text

What are the settings for these, or is it not needed? I have triple checked everything else in my setup and can't see any reason why it's not talking to the news server. Could it be a problem with the web host?

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Re: newssync RC4 available

Post by Lurchnz » Mon Oct 27, 2003 3:21 am

wineknow wrote: fixed the issue reported with postnuke integration.
- the install now works, as well as, the administration pages [same problem]
- this hopefully is the last build before releasing 1.5.0

The biggest issues reported are the go_newssync script, and editing the newssync_config.php file...

-- In 1.5.1 I will add the ability to create the newssync_config.php automatically, as well as, to create the go_newssync file.


Bring on 1.5.1 :)

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

final RC - RC5 now available

Post by wineknow » Mon Oct 27, 2003 7:01 pm

RC5 is now available

the following changes:
- fixed bug in not being able to set NOSPAM in GUI
- removed the "sync phpBB OUT" option...as it is not supported anyway.
- tweeked the schema for messages that are July 2000 and before -- would not be ordered properly (database sorting issue)
- for all NewsSync RC users you need to do the following SQL update:

Code: Select all

ALTER TABLE `newssync_cache` CHANGE `nntp_num` `nntp_num` INT NOT NULL;
ALTER TABLE `newssync_cache` CHANGE `nntp_date` `nntp_date` INT NOT NULL 

Lurchnz
Registered User
Posts: 10
Joined: Fri Oct 24, 2003 6:45 am

Post by Lurchnz » Tue Oct 28, 2003 4:17 am

Okay...

My config file :

Code: Select all


// $newsSync_rootdir is the absolute path to where you installed NewsSync

// this can exist anywhere (even outside of docroot) - must end in /

//

$newsSync_rootdir = "/import_fs2/home/edcnz/taf/public_html/newssync_1.5.0rc5/";



//

// $phpbb_root_path is the FULL path to phpBB (must end in /)

//

//$phpbb_root_path = "/import_fs2/home/edcnz/taf/public_html/PostNuke/modules/PNphpBB2/";



//

// data directory (this can be anywhere) must end in /

//

$newsSync_datadir = "/import_fs2/home/edcnz/taf/public_html/newssync_1.5.0rc5/data/"; 



// ***

// PHPNUKE Integration Settings

// ***

$newsSync_enable_phpnuke_mod = false;

// full path the phpNUKE

$newsSync_NUKE_PATH = "";



// ***

// POSTNUKE Integration Settings

// ***

$newsSync_enable_postnuke_mod = true;

// set newsSync_POSTNUKE_PATH to the absolute path of postnuke

$newsSync_POSTNUKE_PATH = "/import_fs2/home/edcnz/taf/public_html/PostNuke/";

I have setup the paths in the go-newssync file, I can acces it under admin but it is not creating a log file or showing me what it is doing.

I do not have access to run the go-newssync file so I am using pseudo_cron.php. When I've installed this in the common file all the graphics in the forum are lost. If I do a properties on any of them it's looking here for them:

http://taf.revolutionx.net/import_fs2/h ... /PNphpBB2/... and so on

I can fix this problem if I change the location of the PNphpBB2 module in the newssync config file over to using an http addy but of course I don't know what effect this has on newssync.

But still unable to see any log, which is my main worry. I have checked the permissions on the folders (newssync and the data/temp folder) and have even set them to 777 to see if that would help but no luck so changed them back.

I do not have an option for the psuedo_Cron in the admin panel for newssync am I suppose to?

Code: Select all

Message Conversions Settings 
Cyrillic Text Conversion
Convert cyrillic text. See php function convert_cyr_string for more details. This is done before Subject and Body conversion below.  nonekoi8-riso8859-5x-cp866x--mac-cyrillic  
Convert Subject From
Using regular express, see php function preg_replace.  
Convert Subject To
Second half of convert subject.  
Convert Body Text From
Using regular express, see php function preg_replace.  
Convert Body Text To
Second half of Convert Body Text 
What settings if any are needed in the above sections? Can not find any documentation for this either.

Any... any help would be much appreciated!

aklabs
Registered User
Posts: 4
Joined: Tue Oct 28, 2003 10:45 pm

Post by aklabs » Tue Oct 28, 2003 11:07 pm

Hi, I've installed the newsync mod and I must say that it is great stuff. Thank you, thank you, thank you!

But I'm confused. Why does it skip sticky and anonuncement topics and do not sync them with the newsgroups? :( It's normal to ignore polls, but sticky notes are very useful.

With best regards, Alexander.

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow » Tue Oct 28, 2003 11:30 pm

aklabs wrote: Hi, I've installed the newsync mod and I must say that it is great stuff. Thank you, thank you, thank you!

But I'm confused. Why does it skip sticky and anonuncement topics and do not sync them with the newsgroups? :( It's normal to ignore polls, but sticky notes are very useful.

With best regards, Alexander.


by default it ignores everying but Normal Messages but you can change that setting...

take a look "somewhere" in newssync_const.php - I am not logged into my server right now but if you can't find it please PM me and I can help...

-k

Post Reply

Return to “[2.0.x] MODs in Development”