[BETA] Advanced Points System v.0.9.2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Anti-Spam Guide
Locked
Alex.Prisoner
Registered User
Posts: 61
Joined: Tue Mar 27, 2007 9:17 pm

Re: [BETA] Points System v.0.8.2

Post by Alex.Prisoner » Tue Feb 17, 2009 2:18 am

Okay I have a few problems wondering if someone here could help me

In the ACP when I clicked .Mods I got this
SQL ERROR [ mysql4 ]

Table 'zaffcast_aavatar.POINTS_CONFIG_TABLE' doesn't exist [1146]

SQL

SELECT * FROM POINTS_CONFIG_TABLE

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/acp/acp_points.php
LINE: 23
CALL: dbal_mysql->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_points->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

And on my index.php I get this
Fatal error: Call to undefined function last_donors() in /home/zaffcast/public_html/aavatar.co.cc/forums/index.php on line 148

TornFaun
Registered User
Posts: 1
Joined: Sun Feb 10, 2008 3:54 am

Re: [BETA] Points System v.0.8.2

Post by TornFaun » Tue Feb 17, 2009 3:39 am

Did you run the install script?

User avatar
woipi90
Registered User
Posts: 908
Joined: Mon Feb 16, 2009 5:32 pm
Location: Austria

Re: [BETA] Points System v.0.8.2

Post by woipi90 » Tue Feb 17, 2009 11:23 am

when will the next v. be available....

will the instal.xml be available for automod????


grz woipi
My mods: Ultimate Board Clubs
Support: only for the UBCS!
-----
function be_friends($uid, $u){return ($u == $user->['user_id']) ? false : true;}
$this->be_friends($uid, $user->['user_id']) ? $allow_pm : echo "You failed again";

Adrian1
Registered User
Posts: 630
Joined: Tue Jul 15, 2008 11:21 am
Contact:

Re: [BETA] Points System v.0.8.2

Post by Adrian1 » Tue Feb 17, 2009 12:48 pm

woipi90 wrote:when will the next v. be available....

will the instal.xml be available for automod????


grz woipi
Yes it wil be. I will also integrate it with UML.
RPG MOD for phpbb3

Alex.Prisoner
Registered User
Posts: 61
Joined: Tue Mar 27, 2007 9:17 pm

Re: [BETA] Points System v.0.8.2

Post by Alex.Prisoner » Tue Feb 17, 2009 11:22 pm

TornFaun wrote:Did you run the install script?
Yes I did


Sonny? :?

The-Lord
Registered User
Posts: 103
Joined: Thu Jan 31, 2008 12:13 pm

Re: [BETA] Points System v.0.8.2

Post by The-Lord » Thu Feb 19, 2009 10:17 pm

The PhpBB arcade detects it correctly but it does not work correctly with it.

I have set to charge the user 5 pnts per gameplay and 1000 pnts if they break the high score.

It does not give the 1000 pnts on beating the highscore. Both the charge and reward are at 5 points. It seems it is taking the gameplay charge as the reward too. Any suggestions would be helpful.

User avatar
mehrdad_epark.ir
Registered User
Posts: 87
Joined: Thu Jul 31, 2008 3:08 pm

Re: [BETA] Points System v.0.8.2

Post by mehrdad_epark.ir » Fri Feb 20, 2009 7:03 am

I install this MOd .but Madule of this MOD dont show in the ACP .
I install madules manually but these dont show too

Adrian1
Registered User
Posts: 630
Joined: Tue Jul 15, 2008 11:21 am
Contact:

Re: [BETA] Points System v.0.8.2

Post by Adrian1 » Fri Feb 20, 2009 12:08 pm

mehrdad_epark.ir wrote:I install this MOd .but Madule of this MOD dont show in the ACP .
I install madules manually but these dont show too
Set the right permission(for acces it at ACP Points)
RPG MOD for phpbb3

User avatar
mehrdad_epark.ir
Registered User
Posts: 87
Joined: Thu Jul 31, 2008 3:08 pm

Re: [BETA] Points System v.0.8.2

Post by mehrdad_epark.ir » Sat Feb 21, 2009 4:33 am

Adrian1 wrote:
mehrdad_epark.ir wrote:I install this MOd .but Madule of this MOD dont show in the ACP .
I install madules manually but these dont show too
Set the right permission(for acces it at ACP Points)
ok.thanks
but my " Administrative permissions " shows like it:
Image

Image

:?
how van I fix this problem ?

User avatar
woipi90
Registered User
Posts: 908
Joined: Mon Feb 16, 2009 5:32 pm
Location: Austria

Re: [BETA] Points System v.0.8.2

Post by woipi90 » Tue Feb 24, 2009 4:55 pm

i've corrected the modx-install.xml file to a automod compatible xml filebut i don't know if it functions for everyone because i've also installed other mods....

adrian: should i post it for you so that you can take a look on it and include it in the next version????

thanks for this great mod adrian....


grz woipi
My mods: Ultimate Board Clubs
Support: only for the UBCS!
-----
function be_friends($uid, $u){return ($u == $user->['user_id']) ? false : true;}
$this->be_friends($uid, $user->['user_id']) ? $allow_pm : echo "You failed again";

Adrian1
Registered User
Posts: 630
Joined: Tue Jul 15, 2008 11:21 am
Contact:

Re: [BETA] Points System v.0.8.2

Post by Adrian1 » Tue Feb 24, 2009 6:02 pm

woipi90 wrote:i've corrected the modx-install.xml file to a automod compatible xml filebut i don't know if it functions for everyone because i've also installed other mods....

adrian: should i post it for you so that you can take a look on it and include it in the next version????

thanks for this great mod adrian....


grz woipi
yes..
thanks...
RPG MOD for phpbb3

sbfc93
Registered User
Posts: 50
Joined: Sat Dec 13, 2008 1:50 pm

Re: [BETA] Points System v.0.8.2

Post by sbfc93 » Wed Feb 25, 2009 10:09 pm

Is there anyway to edit the amount of points earned per topic/post?

User avatar
daGrevis
Registered User
Posts: 146
Joined: Sat Jan 10, 2009 7:41 am
Location: Latvia

Re: [BETA] Points System v.0.8.2

Post by daGrevis » Fri Feb 27, 2009 11:03 am

Yes, in forums chapter. :lol:

Spyroboy
Registered User
Posts: 14
Joined: Fri Dec 12, 2008 9:24 pm

Re: [BETA] Points System v.0.8.2

Post by Spyroboy » Fri Feb 27, 2009 3:45 pm

I need help. I installed this mod and it works fine. The members get points and all that, but I am unable to configure the settings in the ACP because the mods don't show up. I have set the permissions so that I am authorized to use the mods, and it shows that I can, but under the Permissions Masks section it shows the Points mod as red, which means I can't use them, but where you can set it, it says I can. I can't figure out how to fix this. I've purged the cache and it still didn't work. Please help me out :cry:



I'm having the same problem as him, I set the permission so that I can use them and when I go back to make sure they are set it shows the points tab as green, but under the Permissions Masks section it shows it as red, like shown below in this guys point

mehrdad_epark.ir wrote:
Adrian1 wrote:
mehrdad_epark.ir wrote:I install this MOd .but Madule of this MOD dont show in the ACP .
I install madules manually but these dont show too
Set the right permission(for acces it at ACP Points)
ok.thanks
but my " Administrative permissions " shows like it:
Image

Image

:?
how van I fix this problem ?

Adrian1
Registered User
Posts: 630
Joined: Tue Jul 15, 2008 11:21 am
Contact:

Re: [BETA] Points System v.0.8.2

Post by Adrian1 » Fri Feb 27, 2009 5:07 pm

The add to them this permission, from ACP->Permission->Admin Permission and change it to yes.
RPG MOD for phpbb3

Locked

Return to “[3.0.x] MODs in Development”