Quick reply for phpBB3

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in the Customisations Database.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: This forum is only for the announcement of new releases and/or updates of MODs. Any MOD support should be obtained through the Customisations Database in the support area designated for each MOD.

A direct link to support for each MOD is in the first post of the respective topic.
Locked
rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Sat Mar 07, 2009 5:22 pm

windrider07 wrote:Don't have nor use the stock reply form.
I mean... :) regular reply box, available with PostReply button.

windrider07
Registered User
Posts: 60
Joined: Thu May 08, 2008 10:26 pm

Re: Quick reply for phpBB3

Post by windrider07 » Sat Mar 07, 2009 6:07 pm

Yes of course I have the Post Reply form on my forums.

rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Sun Mar 08, 2009 2:52 am

windrider07
OK. So,
windrider07 wrote:My issue: Smilies, even when turned on, are coded incorrectly. Their links, instead of putting in the emote symbol, bring me back to the top of the page as if it was a link anchoring to the top of the page. Also, when I click Submit, it does not immediately post...I have to refresh like 3 times to see that my post went through.
rxu wrote:Do you have similar problems with the stock reply form?
And did you try to use subsilver2 installation instruction to install this QR MOD?
And yes, Hestia has slightly different template (in comparison with subsilver2), so it's possible that custom quick_reply.html for Hestia will be needed.

t-perry
Registered User
Posts: 16
Joined: Tue May 13, 2008 12:18 pm
Contact:

Re: Quick reply for phpBB3

Post by t-perry » Tue Mar 10, 2009 2:31 pm

does this work for 3.0.4 ??

as in common.php i cant find

Code: Select all

 'ACP_QUICK_ACCESS' 
and in viewtopic_body.html

Code: Select all

<!-- IF not postrow.U_POST_AUTHOR --><strong>{postrow.POST_AUTHOR_FULL}</strong><!-- ELSE -->{postrow.POST_AUTHOR_FULL}<!-- ENDIF -->
that is not there?

juport
Registered User
Posts: 23
Joined: Thu Feb 26, 2009 8:23 pm

Re: Quick reply for phpBB3

Post by juport » Tue Mar 10, 2009 2:44 pm

This Modification doesn't work with phpBB 3.0.4!


// EDIT:
Only with edits!
My translated modifications:
- Advertisement Management [GERMAN-LINK]
- Quick Reply for phpBB3 [GERMAN-LINK]
- More modifications in german? Click >> here <<
Übersetzte Modifikationen in Deutsch findest du in der JUPORT-Community

t-perry
Registered User
Posts: 16
Joined: Tue May 13, 2008 12:18 pm
Contact:

Re: Quick reply for phpBB3

Post by t-perry » Tue Mar 10, 2009 2:49 pm

well i got it working just my ACP is not quite rite menus are coming out with acp_ infront of each tab.

post link to edits pls?

rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Tue Mar 10, 2009 3:22 pm

juport wrote:This Modification doesn't work with phpBB 3.0.4!
For me, it works with 3.0.4 pretty fine :)
t-perry wrote:well i got it working just my ACP is not quite rite menus are coming out with acp_ infront of each tab.
You have to make edits in language/your_language/acp/common.php in accordin to the MOD installation instruction.

rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Tue Mar 10, 2009 3:29 pm

Here's the German translation kindly made by juport.

Code: Select all

COPY
de/mods/quick_reply.php to de/mods/quick_reply.php

OPEN
language/de/acp/common.php

FIND
	'ACP_QUICK_ACCESS'

AFTER, ADD
    // Added with Quick reply for phpBB3 MOD
       'ACP_QUICK_REPLY'         => 'Schnellantwort',
       'LOG_CONFIG_QUICK_REPLY'   => '<strong>Geändert: Schnellantwort Einstellungen</strong>',
Attachments

[The extension zip has been deactivated and can no longer be displayed.]


t-perry
Registered User
Posts: 16
Joined: Tue May 13, 2008 12:18 pm
Contact:

Re: Quick reply for phpBB3

Post by t-perry » Tue Mar 10, 2009 3:32 pm

thanks RXU is there not any en edits? as im not german (=

also there is no

Code: Select all

FIND
   'ACP_QUICK_ACCESS'
in common.php in 3.0.4


Attached is an image of my ACP after i have removed every file to do with Quick Reply Mod still not gone back to normal?










it would seem that i didnt edit the includes/functions_user.php would that make a differences?
Attachments
ACP.jpg
ACP.jpg (211.15 KiB) Viewed 1495 times
Last edited by t-perry on Tue Mar 10, 2009 4:01 pm, edited 1 time in total.

rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Tue Mar 10, 2009 3:59 pm

t-perry wrote:in common.php in 3.0.4
There are several common.php files in phpBb3, we need the language file for Administration control panel, for English the file is language/en/acp/common.php.
t-perry wrote:after i have removed every file to do with Quick Reply Mod still not gone back to normal?
Looks like you don't have your language installed :)

t-perry
Registered User
Posts: 16
Joined: Tue May 13, 2008 12:18 pm
Contact:

Re: Quick reply for phpBB3

Post by t-perry » Tue Mar 10, 2009 4:05 pm

its defo installed! must of been corrupt as when i reinstalled the back up of common.php it went back to normal.

Going to try again now! wish me luck :lol:

wbmike2
Registered User
Posts: 4
Joined: Wed Mar 11, 2009 5:11 am

Re: Quick reply for phpBB3

Post by wbmike2 » Wed Mar 11, 2009 5:15 am

Hi,
I just tried installing this and I am encountering a problem.
When I try to run install.php I get these errors:

Warning: include(./common.php) [function.include]: failed to open stream: No such file or directory in /home/.doglet/wbmike2/vtecjunkies.com/forum/install/install.php on line 17

Warning: include() [function.include]: Failed opening './common.php' for inclusion (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php') in /home/.doglet/wbmike2/vtecjunkies.com/forum/install/install.php on line 17

Fatal error: Call to a member function session_begin() on a non-object in /home/.doglet/wbmike2/vtecjunkies.com/forum/install/install.php on line 20

I can rename the install directory and my website seems to function normally, but I really wanted this quick reply feature to work. Can anybody tell me where went wrong??

Thanks!

rxu
Extensions Development Team
Posts: 2945
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: Quick reply for phpBB3

Post by rxu » Wed Mar 11, 2009 9:24 am

wbmike2
install.php script has to be uploaded to your board's root folder. In your case I guess the URL has to be vtecjunkies.com/forum/install.php ;)

wbmike2
Registered User
Posts: 4
Joined: Wed Mar 11, 2009 5:11 am

Re: Quick reply for phpBB3

Post by wbmike2 » Wed Mar 11, 2009 4:11 pm

rxu wrote:wbmike2
install.php script has to be uploaded to your board's root folder. In your case I guess the URL has to be vtecjunkies.com/forum/install.php ;)

it worked! awesome!
thanks a lot man! I always wanted a quick reply on my page.
Keep up the good work..

ScanWalker
Registered User
Posts: 129
Joined: Wed Jan 07, 2009 5:38 pm

Re: Quick reply for phpBB3

Post by ScanWalker » Thu Mar 12, 2009 9:14 pm

My style is a SubSilver2 based style, but there is problem with the second one i should add after.

It looks like this in that part i should find.

Code: Select all

<!-- IF postrow.RANK_TITLE -->
				<tr>
					<td class="postdetails">{postrow.POSTER_AVATAR}</td>
				</tr>
			<!-- ENDIF -->
			<!-- IF postrow.RANK_IMG -->
				<tr>
					<td>{postrow.RANK_TITLE}</td>
				</tr>
			<!-- ENDIF -->
Annybody know whats wrong, cus' right now i can't see any topics.

www.scanwalkers.com

Locked

Return to “[3.0.x] MOD Database Releases”