DM-RPG, So it begins

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Darkmonkey
Former Team Member
Posts: 1707
Joined: Fri Oct 24, 2003 3:48 pm
Location: Where the trout streams flow and the air is nice

Post by Darkmonkey »

not sure, i havent really used 2.2 yet, i would rather wait until its is done.
spyderone
Registered User
Posts: 14
Joined: Wed Oct 15, 2003 12:53 am
Location: michigan
Contact:

Post by spyderone »

darkmonkey wrote: lol, it sounds good, but it be more like-

schoolwork/homework/work on site/run forum/visit forums/eat/sleep/make mod/die of pressure...


Gotta make some time for the ladies :wink:
Darkmonkey
Former Team Member
Posts: 1707
Joined: Fri Oct 24, 2003 3:48 pm
Location: Where the trout streams flow and the air is nice

Post by Darkmonkey »

but of course 8)
theanimewizard
Registered User
Posts: 646
Joined: Tue Jul 08, 2003 9:24 pm
Contact:

Post by theanimewizard »

I agree, not a lot of ppl will upgrade. I will NEVER upgrade.. NEVERRRRRRRRRRRRRRRRRRRRRRRRRRRR

i still have 2.0.4 right now ... and its all good
Darkmonkey
Former Team Member
Posts: 1707
Joined: Fri Oct 24, 2003 3:48 pm
Location: Where the trout streams flow and the air is nice

Post by Darkmonkey »

well, this well be built on 2.0.6 :?
seteo-bloke
I've Been Banned!
Posts: 281
Joined: Tue Jan 28, 2003 1:41 pm

Post by seteo-bloke »

theanimewizard wrote: I agree, not a lot of ppl will upgrade. I will NEVER upgrade.. NEVERRRRRRRRRRRRRRRRRRRRRRRRRRRR

i still have 2.0.4 right now ... and its all good


Ditto!. I definately won't upgrade my current main board from 2.04, but I'll probably use the next upgrade on other boards.
User avatar
NoahK
Registered User
Posts: 217
Joined: Wed Nov 12, 2003 4:49 am
Location: Atlanta, GA
Contact:

Post by NoahK »

I think part of the reason that Zarath's mods may "appear" buggy is that he originally designed the shop, et cetera for 2.0.3... plus he may use a different browser where <font color=whatever> works, instead of the <style color:#whatever>

Okay so let me get this straight...

Moogies mod allows for PvM
Zarath's mod allows for PvP (with PvM in alpha)
This mod will allow for both PvP and PvM?
Come play Final Fantasy Tactics: Online!
Features:
- Pick one of 351 class combinations. Battle 150 different monsters. Find over 2,200 weapons, armor, and items. Fight in tournaments or play the Gil Slots. Anything goes!
Darkmonkey
Former Team Member
Posts: 1707
Joined: Fri Oct 24, 2003 3:48 pm
Location: Where the trout streams flow and the air is nice

Post by Darkmonkey »

no, version 1 will be user Vs user, but if i make a version 2, its will most likely have a training ground or something. its just ive too much on my plate at the moment.
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

Err. you're all incorrect and you should read the GPL much better before you try to act like you know it. IF a script uses GPL code, then it needs to be released under the GPL. If a script does not use any GPL code, then it does not need to be released under the GPL.

As such, there are loopholes in the GPL as follows.

If you create a script that uses the GPL functions from phpBB and release it under the GPL (a function script only), add a permissions comment on the script allowing a non-GPL script to use the script, it is 100% legal not to release the scripts under the GPL.


If anyone did buy my mods and re-released them (or sold them) it would be illegal unless they redistributed the GPL function script only. Nice try though. :)


Zarath
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

Err, since I didn't read the whole thread first (sorry for the double post) as a contiuation...

Darkmonkey, if you're going to use the bank modification can you email me so I can send you the latest (unreleased) version of it. It's much tidier and all DBAL complient etc. Just incase there's some change that you're not expecting.


To everyone else, I'm sure almost all of you are using at least one of my shop/bank/lottery modifications which I didn't need to release ANY of them. If I didn't, you would all be sitting there with blank forums (at least until wGEric released his store mod) and not have anything. So really, stop your bitching.
Kharay, if you're recoding my entire shop mod and keeping 0% of my code, why are you even using it? Instead of just starting from scratch? That is so asinine it's amazing. Not only that, if you plan on releasing it you didn't ask for permission which is a break in the phpBB ethics as well, ala hypocritical. I don't think the coding of it really matters, as long as it's not vulnerable and it works what do you have to worry about? Not only that, I wrote the shop a long time ago, don't you think coding abilities evolve? So who are you judge my current abiltiies?

If you don't like my mods, don't use them. No one forced you to go download them and use them. No one is forcing you to buy my mods. My pay-mods do NOT rely on a points system, I don't know where you got that from all my FREE mods rely on a points system and I could very easily write my own one if I wanted but when I originally started writing mods for phpBB that points system was already released and I figured I would make something that could use it for all the people that had already installed it.

When you release mods, get at least 10 emails a day from idiots asking for help for over a solid year never letting up, then I think you can start criticizing other people on their ethics.

Really, it's the attitudes exactly like this that makes me not want to release any updates/future mods I write... and I don't think I will after the next bank. It's sad a few people can ruin it for everyone else.


Zarath
gopunkyourself
Registered User
Posts: 122
Joined: Mon Dec 01, 2003 9:41 pm

Post by gopunkyourself »

lol.
If I didn't, you would all be sitting there with blank forums


I seriously doubt that and im almost positive someone else wouldve made a shop mod anyway.
Not only that, if you plan on releasing it you didn't ask for permission which is a break in the phpBB ethics as well, ala hypocritical.


whoever said he was gonna release it?
When you release mods, get at least 10 emails a day from idiots asking for help for over a solid year never letting up, then I think you can start criticizing other people on their ethics.


who are you to talk about phpbb ethics after saying something completely ridiculous like this? i mean you dont even wanna support your mods correctly. those 'idiots' are the people you made the mod for. to be honest when i first installed it i asked you for some help via a post and i believe you told me "you couldnt help". I had to go to someone who had nothing to do with this mod that YOU wrote for help which i find completely ridiculous anyway.
if you're going to use the bank modification can you email me so I can send you the latest (unreleased) version of it. It's much tidier and all DBAL complient etc.


Ok you dont release the good code but you release the 'less tidy and not completely dbal complient version' and dont even support it fully and correctly? nice choice. and on top of this all you make people pay for your mods when everyone else releases their mods that are fully dbal compliant and coded as best as they can be. i mean you're here talking about phpbb ethics when you dont even use them. If you wanna be greedy or whatever thats your choice, but thats obviously not phpbb ethics when everyone else releases them for free and puts the same, if not more work into their mods.



Dark monkey this will be completely standalone and no fixes for compatability with moogies mod?

Btw any status updates?
Darkmonkey
Former Team Member
Posts: 1707
Joined: Fri Oct 24, 2003 3:48 pm
Location: Where the trout streams flow and the air is nice

Post by Darkmonkey »

To be honest lads, i couldnt care less about this GPL dispute, all i know is my mod will be FREE.

So anyway, on with business....

1. Yes, this mod will be completely standalone, nothing to do with moogies. and before it will be released it will go through the most rigourous (sp) beta testing you have ever seen.

2. STATUS =

Phase 1 is currently about 40% in compeletion, once it is finished i will open up the test boards, running my newest version of my mod, to take any suggestions (and in the end, support).

Anyways.. off to work on the admin panel for the RPG profiles

Later :D
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

gopunkyourself, you are an idiot. First I said IF that implies a possibility and not a solid fact, learn English.

Second, I have no idea what your problem was, but it was more than likely a template problem reguarding XML/XHTML which has aboslutely nothing to do with my mod, but rather a problem in your template. I have never _ever_ told anyone to "go find someone else" or that "I can't help you" unless it is something reguarding another mod I haven't used.

I never said I don't answer those emails, I answer EVERY one of the emails sent to me. Therefore I do support my mods, even though they were released a long time ago. Again, learn to read.
I never wrote the mods or even released them for any of you. I wrote the mods for MYSELF and released them because several other people had tried and failed to do them. I sat and watched them all fail and finally wrote my own. I never expected people to be this stupid. So stupid they don't even check the install instructions and make sure they upload all the templates (which has been at least 30% of the emails over the last month).
Once again, when you write your own mods and release them you can start criticizing other people.

Third, perhaps you should learn what UPDATING is. I never said I "held back the good code" infact, I even said coding abilitys evolve, mine definately does. I also said I WAS releasing the next bank version.

Again, you're an idiot. Read a post properly before you try look smart.


Zarath
Napoleon
Registered User
Posts: 413
Joined: Thu Jul 18, 2002 11:31 am

Post by Napoleon »

darkmonkey wrote: To be honest lads, i couldnt care less about this GPL dispute, all i know is my mod will be FREE.

So anyway, on with business....

1. Yes, this mod will be completely standalone, nothing to do with moogies. and before it will be released it will go through the most rigourous (sp) beta testing you have ever seen.

2. STATUS =

Phase 1 is currently about 40% in compeletion, once it is finished i will open up the test boards, running my newest version of my mod, to take any suggestions (and in the end, support).

Anyways.. off to work on the admin panel for the RPG profiles

Later :D


Can't wait. It looks like it's gonna be a great contribution to the phpBB community. :D Do you plan on using sounds?
gopunkyourself
Registered User
Posts: 122
Joined: Mon Dec 01, 2003 9:41 pm

Post by gopunkyourself »

learn English.
Read a post properly before you try look smart.

lol nice...way to take your own advice. also way to spam up the place no one cares what you have to say for yourself its not right that you charge for your mod. and i thought you were a mod or something so why are you so ignorant? you dont have to resolve everything with your 2nd grade insults.
Second, I have no idea what your problem was, but it was more than likely a template problem reguarding XML/XHTML which has aboslutely nothing to do with my mod, but rather a problem in your template. I have never _ever_ told anyone to "go find someone else" or that "I can't help you" unless it is something reguarding another mod I haven't used.


how about no? my problem was a parse error when i first started modding my forum which has enough to do with your mod that you shouldve helped. i wish i still had the reply to show how much of a ****head you were being no offense but you were incredibly rude,especially to someone who was just beginning to learn php.
When you release mods, get at least 10 emails a day from idiots asking for help for over a solid year never letting up, then I think you can start criticizing other people on their ethics.

dont see any IF in that sentence hmm and why would you call your mod users idiots... that makes me feel great about using your mods :wink:

enough of this, keep being ignorant with your attitude towards the people who use your mods, it doesnt change the fact that no one thinks its right that you charge for your mods.

dark monkey - there is a PvsP currently being developed too, im not sure how far along it is but they have some coding down. would you like a link or some contact info to cooperate on a PvsP?
Locked

Return to “[2.0.x] MODs in Development”