Avatar Crash!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Layth
Registered User
Posts: 27
Joined: Wed Dec 18, 2002 12:55 pm

Avatar Crash!

Post by Layth » Sat Mar 06, 2004 6:14 pm

Peace,

For no reason all the avatars on my forum have stopped functioning/appearing. I tried to open the "avatar"file but got the message:

550 avatars Permission denied

Here is some message that a user got back when uploading her avatar:
Warning: move_uploaded_file(./images/avatars//3361054334048e0f408f6d.jpg): failed to open stream: Permission denied in /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/usercp_avatar.php on line 227

Warning: move_uploaded_file(): Unable to move '/tmp/phpxjydd7' to './images/avatars//3361054334048e0f408f6d.jpg' in /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/usercp_avatar.php on line 227

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/page_header.php on line 478

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/page_header.php on line 484

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/free-minds.org/httpdocs/forum/includes/page_header.php on line 485


What to do??

Layth

User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion » Sat Mar 06, 2004 6:22 pm

It was working perfectly before ?
I notice an extra '/' in your upload folder setting - did you change that in the Admin Panel recently ?
In Admin Panel -> Configuration, Check if there is a trailing slash in the 'Avatar Storage Path'.
(ie if its
images/avatars/
change it to
images/avatars
)
See if that helps.

Layth
Registered User
Posts: 27
Joined: Wed Dec 18, 2002 12:55 pm

Post by Layth » Sat Mar 06, 2004 7:09 pm

Peace,
It was working perfectly before ?
I notice an extra '/' in your upload folder setting - did you change that in the Admin Panel recently ?
In Admin Panel -> Configuration, Check if there is a trailing slash in the 'Avatar Storage Path'.


No luck...The avatars are still not showing (I think it has something to do with the "avatar" file being innacessible through ftp)

Layth

iwakura
Registered User
Posts: 1
Joined: Sat Mar 06, 2004 9:35 pm

Post by iwakura » Sat Mar 06, 2004 9:38 pm

i am having a similar problem.

we just got our forums back online, as we were switching servers. i haven't done anything much more extensive than just messing a little bit in the admin panel, so i'm not extremely knowledgable. anyway, when trying to upload an avatar, i got the following message:
Warning: copy(./images/avatars/1135466356404a2bd56de00.jpg): failed to open stream: Permission denied in /home/virtual/site352/fst/var/www/html/forum/includes/usercp_avatar.php on line 227

Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site352/fst/var/www/html/forum/includes/usercp_avatar.php:227) in /home/virtual/site352/fst/var/www/html/forum/includes/page_header.php on line 474

Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site352/fst/var/www/html/forum/includes/usercp_avatar.php:227) in /home/virtual/site352/fst/var/www/html/forum/includes/page_header.php on line 476

Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site352/fst/var/www/html/forum/includes/usercp_avatar.php:227) in /home/virtual/site352/fst/var/www/html/forum/includes/page_header.php on line 477


avatars from the gallery work ok, but i can't upload them.

anyone know how to fix this?

edit: i didn't mention that i also can't add them from the admin control panel either.

User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion » Sun Mar 07, 2004 7:08 am

That is a permission error.
You have to CHMOD the avatars folder to 777.
This can be achieved in most FTP clients (usually its along the procedure of right clicking on the folder, selecting properties, and setting permissions to '777')
Sometimes you can set permissions on folders in your hosting control panel.

Layth>> Also double check that also. Although it was working before, I don't think the permissions would suddenly change.

flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 » Sun Mar 07, 2004 5:02 pm

you also have to create a folder to upload them to.
images/avatars/gallery/yourfoldername
and they all have to be chmod 666 or777

Locked

Return to “2.0.x Support Forum”