Adding a table to template but only in forum home

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Grimmjow
Registered User
Posts: 25
Joined: Mon May 26, 2008 8:35 am

Adding a table to template but only in forum home

Post by Grimmjow »

Hi,

I'm modifying subsilver2 to add a shoutbox on the top of the forum list, and I'm adding the proper code to overall_header.html

The problem is that the shoutbox appears for every page the user navigates, private messages, profile, etc. I'd like to make it appear only when the forum home is loaded, maybe I should add a conditional comment

Code: Select all

<!-- IF ...
But I don't know where to look for a reference about those commands, could anyone help about it? Thanks
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51682
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Adding a table to template but only in forum home

Post by stevemaury »

What file are you putting the code in? Should be index_body.html or maybe viewforum_body.html, depending on where you want it.

EDIT - I now have read your post three times and am still unclear. Do you want the shoutbox on the index page, the forum page or in a particular forum?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
Grimmjow
Registered User
Posts: 25
Joined: Mon May 26, 2008 8:35 am

Re: Adding a table to template but only in forum home

Post by Grimmjow »

Hi, sorry for me not being enough clear :(

Now that you made me re-read my post, maybe you gave me a clue for the answer.

I want the shout box only in the forum index... so maybe I have to edit index_body.html instead of overall_header.html as I did instead?

Thanks
CSS colorizer, a script to automatically change colors inside a cascading style sheet.
Locked

Return to “[3.0.x] Support Forum”