Scrolling problems with long posts in IE

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Scrolling problems with long posts in IE

Post by CassieT »

Ever since we upgraded from version 2 to 3, posting and editing long posts has become a nightmare.

When a post reaches a certain length, if you take your cursor out of the text input box, the post jumps right back up to the beginning, as if it's spring loaded. The only foolproof way to get the cursor back down to the end is to press the down arrow as if our lives depend upon it. This only happens in Internet Explorer.

Has anybody else experienced this? It's not usually the users who suffer, just the admins when we do our weekly roundups, and we can get round it by using FireFox, so it' not the end of the world, but it's incredibly annoying...

gtraddict
Registered User
Posts: 33
Joined: Wed Feb 11, 2009 4:52 pm

Re: Scrolling problems with long posts in IE

Post by gtraddict »

I have experienced this as well.
Anyone have any ideas how to fix this?

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Scrolling problems with long posts in IE

Post by CassieT »

It's still happening to me, too. I don't even bother trying with IE now, I just go straight to Firefox.

It's a major pain though :evil:

Datamigo
Registered User
Posts: 4
Joined: Thu Feb 12, 2009 8:37 pm

Re: Scrolling problems with long posts in IE

Post by Datamigo »

Has anyone figured this out?
I have some members complaining about it as well...

User avatar
noth
Registered User
Posts: 2483
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Scrolling problems with long posts in IE

Post by noth »

it even happens on this site

as soon as a post is long, it becomes a nightmare to edit it

you can no longer even see what you're writing because the unwanted scrolling takes the visible message higher than where your cursor is

I started seeing this at 3.0.5 but maybe it was there before

I believe many users are seeing this but not bothering to report it

I have resorted to copying and pasting a whole post, editing it notepad then posting the whole lot back from notepad, it's that crazy :evil:

Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Scrolling problems with long posts in IE

Post by Pit$Bull »

Add this to your overall_header.html
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

User avatar
noth
Registered User
Posts: 2483
Joined: Fri Jan 07, 2005 7:10 pm
Location: North Surrey
Contact:

Re: Scrolling problems with long posts in IE

Post by noth »

thank you Pitsbull, sounds brilliant

could you please explain a little what it does? :D

Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Scrolling problems with long posts in IE

Post by Pit$Bull »

Emulates IE7

UberDragon
Registered User
Posts: 10
Joined: Sat Feb 12, 2005 10:56 pm

Re: Scrolling problems with long posts in IE

Post by UberDragon »

I'm having this same problem - it seems to only happen in IE (I'm running IE 8). I tried adding the suggested meta tag above, but this has not solved the problem.

Any other insights on how I can make the reply box stop jumping to the middle of long messages?

Thanks!

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51351
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Scrolling problems with long posts in IE

Post by stevemaury »

Have you Refreshed the template in the ACP, Styles tab?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

atigrado
Registered User
Posts: 12
Joined: Thu Feb 01, 2007 3:02 am
Location: Canada
Contact:

Re: Scrolling problems with long posts in IE

Post by atigrado »

As UberDragon, I added the meta tag in the overall_header.html.

I refreshed and its not working.

Note: There is two OverallHeader... one in the folfer admin/theme/...

another int the As defect Style Folder/ theme/...

I changed in both... not working.
Please think and learn about GLOBAL WARMING...

User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Scrolling problems with long posts in IE

Post by ric323 »

atigrado wrote:As UberDragon, I added the meta tag in the overall_header.html.

I refreshed and its not working.

Note: There is two OverallHeader... one in the folfer admin/theme/...

another int the As defect Style Folder/ theme/...

I changed in both... not working.
Don't worry about the file in the adm folder, just the one in your styles folder.
Is it this board you are talking about? http://pasionxeneize.com.ar/foro/
I've just had a look, and that board is NOT sending that string in the header, so you have missed a step.
The file you should edit is at

Code: Select all

http://pasionxeneize.com.ar/foro/styles/designBB/template/overall_header.html
and it does contain the suggested string, so you haven't refreshed the style correctly.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

atigrado
Registered User
Posts: 12
Joined: Thu Feb 01, 2007 3:02 am
Location: Canada
Contact:

Re: Scrolling problems with long posts in IE

Post by atigrado »

ric323 wrote:
atigrado wrote:As UberDragon, I added the meta tag in the overall_header.html.

I refreshed and its not working.

Note: There is two OverallHeader... one in the folfer admin/theme/...

another int the As defect Style Folder/ theme/...

I changed in both... not working.
Don't worry about the file in the adm folder, just the one in your styles folder.
Is it this board you are talking about? http://pasionxeneize.com.ar/foro/
I've just had a look, and that board is NOT sending that string in the header, so you have missed a step.
The file you should edit is at

Code: Select all

http://pasionxeneize.com.ar/foro/styles/designBB/template/overall_header.html
and it does contain the suggested string, so you haven't refreshed the style correctly.


How do you refresh the Style?

Thanks ric323 !!
Please think and learn about GLOBAL WARMING...

User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Scrolling problems with long posts in IE

Post by ric323 »

Either:
ACP -> Styles -> Templates
Click on "Refresh" to the right of the template you are using

or

Click on "Run now" next to "Purge cache" on the first page of the ACP.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

atigrado
Registered User
Posts: 12
Joined: Thu Feb 01, 2007 3:02 am
Location: Canada
Contact:

Re: Scrolling problems with long posts in IE

Post by atigrado »

ric323 wrote:Either:
Click on "Run now" next to "Purge cache" on the first page of the ACP.
I did this one, didn't work.
ric323 wrote:ACP -> Styles -> Templates
Click on "Refresh" to the right of the template you are using.
Next to the Template Name I have :

Desactivar | Exportar | Borrar | Vista previa

There is not Refresh o Refrescar.

:cry:
Please think and learn about GLOBAL WARMING...

Locked

Return to “[3.0.x] Support Forum”