"Upload Attachment" tab missing.

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
angelfish
Registered User
Posts: 47
Joined: Tue Jul 29, 2008 5:37 am

"Upload Attachment" tab missing.

Post by angelfish »

I have recently found a problem on my forum with the "Upload Attachment" tab in reply posts.
I, myself, have no problems nor does the moderator, but regular members say that the tab does not appear when they go to post a photo. Can someone help me with this please as I'm not sure how to fix it.

Thanks
Sue
Last edited by ric323 on Sun Feb 22, 2009 8:12 am, edited 1 time in total.
Reason: Topic icon changed
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: "Upload Attachment" tab missing.

Post by ric323 »

It's a permission problem. You haven't given the "registered users" group permission to upload attachments to those forum.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
angelfish
Registered User
Posts: 47
Joined: Tue Jul 29, 2008 5:37 am

Re: "Upload Attachment" tab missing.

Post by angelfish »

Okay, thanks.
Could you please tell me how I can do that. And also, is that something I have to do for every new member ???


Thanks
Sue
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: "Upload Attachment" tab missing.

Post by karlsemple »

Admin control panel -> permissions tab -> forum based permissions -> forum permissions


Select the forum or forums in question and then then submit, on the next screen you need to slect the registered users group and click to add or edit permissions (probably edit) and then on the right click the advanced permissions link in turn for each forum you wish to set permissions for and then then you should get tabs for setting various permissions types. Click the content tab and make sure that the permissions to attach files is set to yes, if it is not then set it to yes and submit the permissions change :)
Image
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22841
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: "Upload Attachment" tab missing.

Post by Mick »

Beaten to it AGAIN! ;)

You could also do that for the users group, instead of per forum, if you want users to be able to do it globally.
Last edited by Mick on Sun Feb 22, 2009 6:45 am, edited 1 time in total.
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: "Upload Attachment" tab missing.

Post by ric323 »

Enter your ACP, go to the "Permissions" tab, select "Forum permissions", then pick one of your forums.
Under "Groups", select the "Registered Users" group, click on "Edit permissions"

Now, you can either:
just select the role "Standard Access + Polls",
or you can click on "Advanced permissions", select the "Content" tab, and change "Can attach files" to "Yes".

Check that forum is working how you want, then in the ACP, "Forums" tab, you can edit each forum's settings, and use the "Copy permissions from" feature to copy from the forum which you first corrected.

Edit: the "gun typer" beat me also. :)
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions
angelfish
Registered User
Posts: 47
Joined: Tue Jul 29, 2008 5:37 am

Re: "Upload Attachment" tab missing.

Post by angelfish »

Thankyou so much to all who quickly answered my post. I have followed the intructions, so all should be well on my forum now.


Sue
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22841
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: "Upload Attachment" tab missing.

Post by Mick »

ric323 wrote:the "gun typer" beat me also. :)
Ha ha, it's a jungle out there :lol:
"The more connected we get the more alone we become" - Kyle Broflovski©
Locked

Return to “[3.0.x] Support Forum”