[Fix] headers already sent at Lycos/MultiMania/Tripod/CFP

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
zoid
Registered User
Posts: 743
Joined: Fri Oct 12, 2001 6:29 am
Location: $SCRIPT_NAME
Contact:

[Fix] headers already sent at Lycos/MultiMania/Tripod/CFP

Post by zoid »

New link to the Knowledge Base (Lycos Multimania Tripod)
New link to the Knowledge Base (Coolfreepages)

Since this is - especially in the last time - a frequently appearing question, here is how to solve it.

If you run phpbb2 on a Tripod/MultiMania or Lycos account, you might encounter a "Warning: Cannot add header information - headers already sent in *****" message. This happens because of the banners shown by Tripod & Lycos. A detailed fix is at http://www.phpbb.com/phpBB/viewtopic.php?t=14152.

Thank you for your attention,
Alexander

keywords: tripod lycos multimania headers already set by register page update change profile
Last edited by zoid on Sat May 04, 2002 9:57 am, edited 2 times in total.
Whatever you want to know, please do a Image Search before asking :).

Run your own Chatcommunity
>> PINO - Client/Server Chat for Windows <<
programhouze
Registered User
Posts: 148
Joined: Sun Apr 07, 2002 4:41 am

Post by programhouze »

Also, keeping this on the same Lycos.co.uk problem list. I know this error here is not necessarily a Lycos.co.uk problem but a problem that came up for someone while on Lycos.co.uk.
Warning: Failed opening './includes/sessions.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in common.php on line 120

Warning: Failed opening './includes/auth.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in common.php on line 121

Warning: Failed opening './includes/functions.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in common.php on line 122

Warning: Failed opening './includes/db.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in common.php on line 123

Fatal error: Call to undefined function: append_sid() in common.php on line 131



I can't seem to find the correction to this problem after searching through 60 pages. But, I'm that type of guy, to help people to lol. I just can't find it for some odd reason...I did see that same problem though some where, I just can't find it now lol. Dang!

I will put them here along with the specific answers to help others. :wink: Its just these problems above I can't seem to find now, but if a developer or moderator has the answer, please drop the answers for that. Thanks to Zoid, now we might have fewer questions arrise for these Lycos.co.uk problems coming in the Support Forum. Zoid your the greatest! :D :wink:


the_houze
Last edited by programhouze on Sat May 04, 2002 8:12 pm, edited 1 time in total.
zoid
Registered User
Posts: 743
Joined: Fri Oct 12, 2001 6:29 am
Location: $SCRIPT_NAME
Contact:

Post by zoid »

It seems common.php does not find the files in the includes directory. Are they definitely there?

Alexander
Whatever you want to know, please do a Image Search before asking :).

Run your own Chatcommunity
>> PINO - Client/Server Chat for Windows <<
User avatar
Black Fluffy Lion
Former Team Member
Posts: 6057
Joined: Sat Dec 15, 2001 11:37 am

Post by Black Fluffy Lion »

I'd just like to add a fix to a similar problem with coolfreepages:

At the top of each page you'll probably be getting something like
Warning: Cannot add header information - headers already sent by (output started at /users/coolfreepage.com/onlinecafe/ phpBB2/config.php:19) in /users/coolfreepage.com/onlinecafe/phpBB2/includes/sessions.php on line 186


To fix it simply delete the javascript after the ?> in config.php, leaving only 19 lines in the file.
ShadowRaven
Registered User
Posts: 929
Joined: Tue Apr 16, 2002 5:33 pm
Location: Kansas
Contact:

Post by ShadowRaven »

the_houze: That's not a Lycos problem. My board's on Lycos, too, and I've never seen any errors like that on my board.
programhouze
Registered User
Posts: 148
Joined: Sun Apr 07, 2002 4:41 am

Post by programhouze »

ShadowRaven, oops, I should have explained myself better lol. I fixed it above. I didn't mean it as a Lycos.co.uk problem particularly but as an error that did come up for someone on Lycos.co.uk. Yeah, I don't get those errors either so it must be something they are doing wrong or something then. Thanks though ShadowRaven for pointing that out for me, I was wasted lastnight on Vodka lol hahaha. :D :wink: Well, back to helping people. :wink:


the_houze
A Really Cool Name
Registered User
Posts: 31
Joined: Mon May 06, 2002 8:51 pm
Location: A really cool place
Contact:

Headers Fix

Post by A Really Cool Name »

Black Fluffy Lion wrote: I'd just like to add a fix to a similar problem with coolfreepages:

At the top of each page you'll probably be getting something like
Warning: Cannot add header information - headers already sent by (output started at /users/coolfreepage.com/onlinecafe/ phpBB2/config.php:19) in /users/coolfreepage.com/onlinecafe/phpBB2/includes/sessions.php on line 186


To fix it simply delete the javascript after the ?> in config.php, leaving only 19 lines in the file.

Thanks.. just read this fix.. and I will try it today... :)
bimmer528
Registered User
Posts: 28
Joined: Fri Apr 05, 2002 3:53 pm

Post by bimmer528 »

Is there a way to edit the mod, so that the full text of each article does not show up and have just a link with the article name?

http://ctf.toclan.org
ColetasSoft
Registered User
Posts: 45
Joined: Tue Jan 29, 2002 3:10 am
Location: Madrid, Spain
Contact:

Post by ColetasSoft »

Vegetapika wrote: ADVICE!
Dont install any board on lycos or tripod, because you if you do that also if your board run perfect without errors you can register into your forum, but you cannot login!!!!



Say what? I have my board on tripod (in fact I have two hosted on tripod), and I can log in without any problems (cookies do funny things, like work in netscape 6 but not in explorer 6, but that´s different from not being able to log in).
Loyalty above all else, except Honor.
Semper Fi. Leave no Man behind
User avatar
roly
Registered User
Posts: 775
Joined: Fri Jan 04, 2002 7:13 am
Location: Australia

Post by roly »

I renamed the thread to include MultiMania which is also owned by Lycos which is in french and has a different URL but uses the same servers as Tripod
User avatar
marja
Registered User
Posts: 19
Joined: Tue May 21, 2002 8:41 pm
Location: The Netherlands
Contact:

Post by marja »

Putting the @ in front of the header-lines in page_header.php workt!
Only one message left :
Warning etc ....header already send in posting.php line 568.
Where do i put the @ in posting.php????(what line)
Gozer
Registered User
Posts: 4
Joined: Wed May 29, 2002 8:55 am

Post by Gozer »

marja wrote: Putting the @ in front of the header-lines in page_header.php workt!
Only one message left :
Warning etc ....header already send in posting.php line 568.
Where do i put the @ in posting.php????(what line)


There is a fix explained in one of the lasts posts of this thread:
http://phpbb.com/phpBB/viewtopic.php?t=14152
programhouze
Registered User
Posts: 148
Joined: Sun Apr 07, 2002 4:41 am

Post by programhouze »

Yeah the fix is in there for that error on line 568 I believe it is in posting.php. But, if you'd like, I could send you the file that is already to go, but you probably have it fixed yourself by now lol. Just thought I would lay this on the table hehe.


programhouze
edddy
Registered User
Posts: 3
Joined: Wed Jun 12, 2002 8:55 pm

error

Post by edddy »

i have this

Warning: Cannot add header information - headers already sent by (output started at /data/members/free/tripod/nl/v/u/u/vuurwerkplaza/htdocs/forum1/index.php:2) in sessions.php on line 280

Warning: Cannot add header information - headers already sent by (output started at /data/members/free/tripod/nl/v/u/u/vuurwerkplaza/htdocs/forum1/index.php:2) in sessions.php on line 281
ikb
Registered User
Posts: 2
Joined: Wed May 15, 2002 9:55 pm

Post by ikb »

i Downloaded phpbb_fetch_posts formy site and
Warning: Cannot add header information - headers already sent by (output started at /data/members/free/tripod/es/i/k/b/ikbnetwork/htdocs/ikb.php:7) in sessions.php on line 182

Warning: Cannot add header information - headers already sent by (output started at /data/members/free/tripod/es/i/k/b/ikbnetwork/htdocs/ikb.php:7) in sessions.php on line 183


so i havent forun a solution for this would you helpme? :oops: :oops:
Locked

Return to “2.0.x Support Forum”