Automatic thumbnails on index

Looking for a MOD? Have a MOD request? Post here for help. (Note: This forum is community supported; phpBB does not have official MOD authors)
Suggested Hosts
Locked
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

Bug fixed! Thank you. :)
To rebuild the thumb-index (and delete unecessary thumbs) go to:
ACP > Posting > Orphaned attachments and click [submit]
Nothing to do to don't have to delete all the thumbs everytime and to have to create them again opening every pages of the forums?
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

you only have to do this when a big code is changing in future..
and, you dont have to do this "all the time", this is only a interim arrangement.
this place in "orphaned attachment" is a compromise till the acp of this Mod is ready ;)
the rest is finetuning :arrow:
Last edited by 4_seven on Thu Dec 17, 2009 2:06 am, edited 1 time in total.
Current Mods | Mod Base | php(BB) programming | No help via PM
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

Oki :)
martinchos
Registered User
Posts: 6
Joined: Thu Nov 12, 2009 4:36 pm

Re: Automatic thumbnails on index

Post by martinchos »

4_seven wrote:
URL file-access is disabled in the server configuration
it say it in itself. sorry, nothing i can do this time ;)
if i find a alternative version for those restricted boards, i told ya

edit:

i find a way, bcs. it must be safe as standard version:

find

in viewforum.php

Code: Select all

if (!empty($remote_clr_pic) && getimagesize($remote_raw_pic)){
replace with

Code: Select all

if (!empty($remote_clr_pic)){
find

Code: Select all

copy($remote_raw_pic, $phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic);
after add

Code: Select all

if (getimagesize($phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic)){
find

Code: Select all

$image->save($phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic);}}}}
replace with

Code: Select all

$image->save($phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic);}}
else{
unlink($phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic;)}}}}
yess thanks 4seven very apreciated is work now :D :D
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

little optical-update for dead-links

reason: showing span/div on dead-links (but img not present)

open viewforum.php

find

Code: Select all

			'S_THUMB_IMG_PRESENT'		=> (!empty($remote_clr_pic)) ? true : false,
after add

Code: Select all

			'S_THUMB_DEAD_LINK'         => (file_exists($phpbb_root_path . 'images/viewforum_thumbs/' . '_' . $remote_clr_pic)) ? true : false,
open

styles/xxxxxxx/template/viewforum_body.html

find all

Code: Select all

<!-- IF topicrow.S_THUMB_IMG_PRESENT -->
replace all with

Code: Select all

<!-- IF topicrow.S_THUMB_IMG_PRESENT and topicrow.S_THUMB_DEAD_LINK -->
- clear all caches

- ready

- main instruction will be updated
Current Mods | Mod Base | php(BB) programming | No help via PM
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

I've got an other little problem: when I click on the button "view first unread post" (next to a title) in a forum where thumbnails are not activated, I've got this message: "The requested topic does not exist" and the adress is like this: "http://.../forum/viewtopic.php?&view=unread#unread".

If i do the same action in a forum where thumbnails are activated, no problem, I can go to the first unread post clicking on it.
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

inikad wrote:I've got an other little problem: when I click on the button* "view first unread post" (next to a title)
can u make a screen of this button*, i did not find it :|
Current Mods | Mod Base | php(BB) programming | No help via PM
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

It is in red color wit a little black arrow, just next to the titles when there is a new reply in a topic since your last visit.

Image
Last edited by inikad on Fri Dec 18, 2009 12:07 am, edited 1 time in total.
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

hm, i've got not a hunch, what effects this :?:

must figure it out these days.

i've never use this function, so thanks for the hint...
Current Mods | Mod Base | php(BB) programming | No help via PM
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

With this button, you can go to the last unread message of a topic since the last time you read it. In my own style, the function is more "visible" (button bigger than in prosilver) and used by a lot by members to don't have to look for new replies since the last time. Really usefull with big topics with a lot of pages.
Last edited by inikad on Fri Dec 18, 2009 12:19 am, edited 1 time in total.
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

one moment..

ok, was an code-think-error

have smuggled an unneed variable in this "else" ;)

find

Code: Select all

else{
$remote_clr_pic = '';
$remote_raw_pic = '';
$view_topic_url_params = '';
$rowz['post_id'] = '';}
replace with

Code: Select all

else{
$remote_clr_pic = '';
$remote_raw_pic = '';
$rowz['post_id'] = '';}
instruction was shortly updated
Current Mods | Mod Base | php(BB) programming | No help via PM
inikad
Registered User
Posts: 110
Joined: Mon Dec 15, 2008 1:44 pm

Re: Automatic thumbnails on index

Post by inikad »

Problem fixed! ;)
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

Slim Version 0.0.2 added

http://sekuro.se.funpic.de/phpbb3/viewt ... ?f=8&t=327

- changes in viewforum.php only

Happy Xmas @ all
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: Automatic thumbnails on index

Post by 4_seven »

Just 4 Info
[DEV] Last X [attachments] on Forum v.0.0.1

........

Demos:
Standard Script: http://4seven.kilu.de/phpbb3/index.php
Crawl Script: http://4seven.kilu.de/phpbb3/viewforum.php?f=10

.........

[DEV] Thread
http://sekuro.se.funpic.de/phpbb3/viewt ... ?f=8&t=337
Note: "First Topic [attachment] on Forum Index" follows > Middle of January
Current Mods | Mod Base | php(BB) programming | No help via PM
Locked

Return to “[3.0.x] MOD Requests”