Mibbit was working now wont

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 1:55 am

Hi again
tnx for the great help before

I managed to get a chat window working well in my forum, in a test post.. but as soon as i was happy with the test i decided to delete that test post and make a forum specialy for the chat room.. i made a new post , and repeated the same steps as i did (bb code in post) .. but now all i see is text in my post not the chat window.. it was working perfectly a few seconds ago.

http://www.fractalscapes.net/forum/phpB ... fb7179#p47


this is what i am typeing into the post:

Code: Select all

Please dont forget to choose a nick, "Guest" may be already taken on the undernet network

[mibbit]server=irc.undernet.org&channel=%23pangaea&nick=Guest%3F%3F[/mibbit]

[mimg]http://www.fractalscapes.net/Forum/micons/m-icons-chat.png,44,44[/mimg]

this is the acp code

Code: Select all

[mibbit]{SIMPLETEXT}, {TEXT1}, {TEXT2}[/mibbit]

Code: Select all

<iframe width="680" height="600" scrolling="no" frameborder="0" src="http://embed.mibbit.com/?server=irc.undernet.org&channel=%23pangaea&nick=Guest&customprompt={TEXT2}&customloading=Contacting%20the%20IRC%20server...&settings=1529ea977baeb4471a913b48465ca96e">
    </iframe>

Code: Select all

Mibbit: [mibbit]irc.domain.com, channel, custom%20text[/mibbit]
Remember i had this working perfectly untill i wanted to move the post

anyway hope somone can help :)

regards
pan
Last edited by ric323 on Fri Jan 29, 2010 11:13 am, edited 1 time in total.
Reason: Topic icon changed

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Mibbit was working now wont

Post by ric323 » Fri Jan 29, 2010 2:07 am

If this is the ACP code:

Code: Select all

[mibbit]{SIMPLETEXT}, {TEXT1}, {TEXT2}[/mibbit]
Then shouldn't the usage be:

Code: Select all

[mibbit]server=irc.undernet.org, channel=%23pangaea, nick=Guest%3F%3F[/mibbit]
rather than

Code: Select all

[mibbit]server=irc.undernet.org&channel=%23pangaea&nick=Guest%3F%3F[/mibbit]

Edit: Actually, you seem to be ignoring the first two parameters, and only using TEXT2 anyway.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 2:11 am

Howdy ric323 :)

i put the spaces in but still no window

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Mibbit was working now wont

Post by ric323 » Fri Jan 29, 2010 2:41 am

and the commas?
(You need them, because you have them in the first window in the ACP definition.)
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 7:27 am

my posting edit:

Code: Select all

[mibbit]server=irc.undernet.org,channel=%23pangaea,nick=Guest%3F%3F[/mibbit]

[mibbit]server=irc.undernet.org, channel=%23pangaea, nick=Guest%3F%3F[/mibbit]

[mibbit]server=irc.undernet.org channel=%23pangaea nick=Guest%3F%3F[/mibbit]

what the post is displaying when i press submit
[mibbit]server=irc.undernet.org,channel=%23pangaea,nick=Guest%3F%3F[/mibbit]

[mibbit]server=irc.undernet.org, channel=%23pangaea, nick=Guest%3F%3F[/mibbit]

[mibbit]server=irc.undernet.org channel=%23pangaea nick=Guest%3F%3F[/mibbit]
its showing text just like how i typed it there, not a window, have u any ideas how to fix this, it was al workking fine beforfe i made a new post.

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Mibbit was working now wont

Post by ric323 » Fri Jan 29, 2010 8:59 am

OK, I can fix it, but there are some things that should be corrected.
Do you always want the "server" to be "irc.undernet.org",
the "channel" to be "%23pangaea" (= "#pangaea")
and the "nick" to be "Guest%3F%3F" (= "Guest??")

At present, the "TEXT2" field is just being used to display a custom prompt. IS that all you want to appear between the "mibbit" tags?
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 9:13 am

hi ric and thanks again for your support

yes to all of the above, the connct deatils will never change

regards
pan

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 10:41 am

Ok i think i manged to get this working, i tryed endless differnt combos and have found this to work:
[mibbit]irc.undernet.org, %23pangaea, Guest%3F%3F[/mibbit]
:) :)

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Mibbit was working now wont

Post by ric323 » Fri Jan 29, 2010 10:51 am

BBCode usage

Code: Select all

[mibbit]{SIMPLETEXT}[/mibbit]
HTML replacement

Code: Select all

<iframe width="680" height="600" scrolling="no" frameborder="0" src="http://embed.mibbit.com/?server=irc.undernet.org&channel=%23pangaea&nick=Guest%3F%3F&customprompt={SIMPLETEXT}&customloading=Contacting%20the%20IRC%20server...&settings=1529ea977baeb4471a913b48465ca96e"></iframe>
Test post

Code: Select all

[mibbit]Welcome to MIBBIT[/mibbit]
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 11:01 am

Cheers ric :)

just while im at it, i was curious about one thing.. i know undernet will only allow 2 max conncections from one ip addres, my question is, will thie mibbit chat window treat each user on my forum thats using the chat window as a unique ip? ( there own ip) or dose the mibbit chat window connected via my web servers ip no matter who is using it. Is it also possible not to NOT show that perticular topic page (with the chat window) to users how have not registered?

anyway, endless thanks ric ur a legend!

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Mibbit was working now wont

Post by ric323 » Fri Jan 29, 2010 11:07 am

I know nothing about mibbit, but their server will be seeing the IP address of the person who is viewing the page, NOT that of your server.
It woll be trying to connect all of them as "Guest??". I don't know if that is a problem, or normal.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Mibbit was working now wont

Post by Pangaea » Fri Jan 29, 2010 11:10 am

but their server will be seeing the IP address of the person who is viewing the page, NOT that of your server.

Fantastic!!

yes, the guest thing is akward, but i have instructions on the page its embedded that you must change nick.. im sure as time goes on ill find a better way of doing it

regards
(a very happy camper indeed) pan

Locked

Return to “[3.0.x] Support Forum”