"Force reactivation" for all users.

Looking for a MOD? Have a MOD request? Post here for help. (Note: This forum is community supported; phpBB does not have official MOD authors)
Ideas Centre
King Rhyono
Registered User
Posts: 74
Joined: Fri Dec 31, 2010 9:42 pm
Contact:

Re: "Force reactivation" for all users.

Post by King Rhyono » Fri Jan 07, 2011 7:05 pm

In phpMyAdmin go to the SQL tab to enter code and enter this

Code: Select all

UPDATE  `DATABASE_NAME`.`phpbb_users` SET  `user_type` =  '1' WHERE  `phpbb_users`.`user_id` != 2 AND user_type != 2;
Change DATABASE_NAME to the name of the db your forum is in. This will also not deactivate user 2 (should be you) and won't deactivate bots.
PM me if you want me to do some work for hire (can do: support, maintenance, and mod requests).

User avatar
robra
Registered User
Posts: 147
Joined: Thu Dec 09, 2010 2:09 am
Location: Brazil

Re: "Force reactivation" for all users.

Post by robra » Sat Mar 05, 2011 4:09 pm

It coulb be called "Force reactivate mass" or "Mass reactivation". ;)

ddejc
Registered User
Posts: 2
Joined: Tue Nov 29, 2011 3:05 am

Re: "Force reactivation" for all users.

Post by ddejc » Tue Nov 29, 2011 3:07 am

King Rhyono does SET `user_type` = '1' mean that users will become inactive until they will reactivate their user account over email?

User avatar
robra
Registered User
Posts: 147
Joined: Thu Dec 09, 2010 2:09 am
Location: Brazil

Re: "Force reactivation" for all users.

Post by robra » Thu Oct 30, 2014 9:26 pm

Hi guys.
Sorry to delay after many past time since I open this thread but only now I needed to return this issue and now my doubt is small.
I did what the King Rhyono said and the test user has deactivated, but when I tried generate a new reactivation link, a message appears saying that I cannot do that because my register was deactivated manually an only administrator could activate it. I change too the user_inactive_reason field of 1 to 0 but this not worked. I only need to solve the issue of get the reativation link when the users are deactivated by SQL.
Any idea how to do that?

Thanks.

Locked

Return to “[3.0.x] MOD Requests”