Administration Menu isn't there, help =(

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
sektor
Registered User
Posts: 4
Joined: Sat Jul 31, 2004 2:12 pm

Administration Menu isn't there, help =(

Post by sektor »

I installed PHP board no problem but now its configering it.. I was looking at the torturials and noticed I don't have some of the comands in the administration screen

I only have

Administration
Admin Index
Forum Index
Preview Forum


Why arn't I getting the rest, on the installation I put down my user name as the admin, but thats all i'm getting, what can I do to fix it?
User avatar
primedomain
Former Team Member
Posts: 25944
Joined: Sat Dec 15, 2001 10:23 am

Post by primedomain »

Please fill out the Support Request Template

In paricular we need to know:
- which template?
- have you made sure that *all* files in the /admin folder have been uploaded correctly?
sektor
Registered User
Posts: 4
Joined: Sat Jul 31, 2004 2:12 pm

Post by sektor »

URL: http://81.99.81.238/Sintrixus/
Template(s) used: SubSilver
Any and all MODs: None Except from what was in the install zip
Do you use a port of phpBB: No
Version of phpBB: 2.0.10
Version of PHP: Not Sure
Which database server and version: 8O
Host: http://81.99.81.238/
Did someone install this for you/who: No
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: No
Have you searched for your problem: No
If so, what terms did you try:
State the nature of your problem: I'm not getting all my admin options
Do you have a test account for us: No


I'm not sure if all the admin files are uploaded. I'll put the names all down.

admin_board.php
admin_db_utilities.php
admin_disallow.php
admin_forum_prune.php
admin_forumauth.php
admin_forums.php
admin_groups.php
admin_mass_email.php
admin_ranks.php
admin_smilies.php
admin_styles.php
admin_ug_auth.php
admin_user_ban.php
admin_users.php
admin_words.php
index.php
page_footer_admin.php
page_header_admin.php
pagestart.php

Thats ALL the files that are in the admin folder.
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

Make sure all the admin files are CHMOD to 644.
That MAY help.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
sektor
Registered User
Posts: 4
Joined: Sat Jul 31, 2004 2:12 pm

Post by sektor »

All the admin folders are on CHMOD 644 and it still doesn't give me all my admin stuff, e.g. configeration so I can make the new topics and rename the title bar, ect.
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

There should be 39 files in the /subSilver/admin/directory .
Check that.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
sektor
Registered User
Posts: 4
Joined: Sat Jul 31, 2004 2:12 pm

Post by sektor »

Yeah, theres 39 files, are they to be all CHMOD to 644 too?
mail2dude
Registered User
Posts: 2
Joined: Tue Aug 24, 2004 12:57 am
Location: Hamburg, Germany
Contact:

Incomplete Admin Panel

Post by mail2dude »

URL: http://www.lumato.de/development/
Template(s) used: SubSilver
Any and all MODs: None
Do you use a port of phpBB: No
Version of phpBB: 2.0.10
Version of PHP: Should be 4.x
Which database server and version:
Host: http://195.158.54.8/
Version: MySQL 3.23.43-nt
Did someone install this for you/who: No
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: No
Have you searched for your problem: Yes
If so, what terms did you try: Aministration AND Menu
State the nature of your problem: Only options I have in the Admin Panel are Forum Index, Admin Index and Preview Forum
Do you have a test account for us: Yes

I am thankful for any help I can get!

Toby
mail2dude
Registered User
Posts: 2
Joined: Tue Aug 24, 2004 12:57 am
Location: Hamburg, Germany
Contact:

Check everything I found in this forum

Post by mail2dude »

I have checked everything I found in this forum twice, and it still won't work. Another thing I have noticed is that the language pack doesn't seem to work work either.
If anyone has an idea, please contact me!

I found out one more thing by analyzing the phperror document in my admin folder. The only problem is that I have no clue what it means, so I will just post it here:

Code: Select all

[24-Aug-2004 03:46:16] PHP Warning:  ksort() expects parameter 1 to be array, null given in D:\kunden\lumato.de\development\admin\index.php on line 86

[24-Aug-2004 03:46:16] PHP Warning:  Variable passed to each() is not an array or object in D:\kunden\lumato.de\development\admin\index.php on line 88
Locked

Return to “2.0.x Support Forum”