[BETA] Medal System MOD 1.0.1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment!
Scam Warning
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: [BETA] Medal System MOD 1.0.1

Post by Oyabun1 »

loo10ant wrote:installing it using Adobe Brackets to edit the files
I'd suggest using an editor that in known to work for all phpBB text files, can't say that Adobe Brackets falls into that class yet, see Tools needed to set up and customise phpBB for some suggestions.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
loo10ant
Registered User
Posts: 2
Joined: Wed Feb 12, 2014 11:54 am

Re: [BETA] Medal System MOD 1.0.1

Post by loo10ant »

Oyabun1 wrote:I'd suggest using an editor that in known to work for all phpBB text files, can't say that Adobe Brackets falls into that class yet, see Tools needed to set up and customise phpBB for some suggestions.
This worked brilliantly, running perfectly for me. Thank you so much for the suggestions. I didn't realize i was being such a noob
lasdlt
Registered User
Posts: 1
Joined: Sun Feb 16, 2014 6:08 pm

Re: [BETA] Medal System MOD 1.0.1

Post by lasdlt »

I am having trouble accessing the Medals Control Panel. If I am logged into my board, then navigate to /medals.php, I can see the table of my currently created medals. However, I am not logged in. After using the link on that page to log in successfully, the only option I have is to return to the board index. If I navigate back to the MCP, I am no longer logged in!

Does anyone have any information regarding this issue? Thanks for your help.
XBB Griever 6
Registered User
Posts: 14
Joined: Sat Feb 08, 2014 6:30 am

Re: [BETA] Medal System MOD 1.0.1

Post by XBB Griever 6 »

Does anybody know if there is any other style that this Mod would work with? I am using the 360Elite style and I really like it. I have played with the colors a little a Prosilver but I can't get the colors quite right to make it look enough like the 360Elite. My HTML-fu is not very strong so its a trial and error method with me big time. Thanks in advance.
5hocK
Registered User
Posts: 3139
Joined: Wed Nov 23, 2011 7:00 pm
Location: UK

Re: [BETA] Medal System MOD 1.0.1

Post by 5hocK »

XBB Griever 6 wrote:I have played with the colors a little a Prosilver but I can't get the colors quite right to make it look enough like the 360Elite.
Tested this style and it looks fine to me, it's using inheritance for almost everything; which area looks wrong?
XBB Griever 6
Registered User
Posts: 14
Joined: Sat Feb 08, 2014 6:30 am

Re: [BETA] Medal System MOD 1.0.1

Post by XBB Griever 6 »

5hocK wrote:
XBB Griever 6 wrote:I have played with the colors a little a Prosilver but I can't get the colors quite right to make it look enough like the 360Elite.
Tested this style and it looks fine to me, it's using inheritance for almost everything; which area looks wrong?
I've been playing around with it some more and I got it pretty close. The biggest concern is in the viewforum pages, I can't figure out how to change the color for the actual forum box (the box surrounding the forum topics. It says "Topics, Replies, Views, and Last Post"). I can start up a new thread though if I need to, I don't wanna take up to much of the Medals System MOD 1.0.1 thread here.
5hocK
Registered User
Posts: 3139
Joined: Wed Nov 23, 2011 7:00 pm
Location: UK

Re: [BETA] Medal System MOD 1.0.1

Post by 5hocK »

XBB Griever 6 wrote:The biggest concern is in the viewforum pages
The Mod doesn't affect viewforum, can you post a link?
XBB Griever 6
Registered User
Posts: 14
Joined: Sat Feb 08, 2014 6:30 am

Re: [BETA] Medal System MOD 1.0.1

Post by XBB Griever 6 »

5hocK wrote:The Mod doesn't affect viewforum, can you post a link?
It's not the Mod or anything, that's why I'm not wanting to take up too many post on this thread. Its just the color scheme of the style itself.
5hocK
Registered User
Posts: 3139
Joined: Wed Nov 23, 2011 7:00 pm
Location: UK

Re: [BETA] Medal System MOD 1.0.1

Post by 5hocK »

You could post in the support section for the style (top right) https://www.phpbb.com/customise/db/style/360elite/
ti9327
Registered User
Posts: 1
Joined: Tue Mar 11, 2014 4:42 am
Location: United States
Name: David

Re: [BETA] Medal System MOD 1.0.1

Post by ti9327 »

Experiencing a strange issue. I am using this mod on phpbb 3.0.12 and am experiencing an interesting issue. When I award a medal, everyone who gets it has a duplicate entry when viewing in the viewtopic_body. For the life of me I cannot find where the issue lies. Even when I look at it using prosilver skin, I see the same result.

Image
Untitled-1 by CP9327, on Flickr
XBB Sandman 6
Registered User
Posts: 1
Joined: Wed Mar 19, 2014 6:21 pm

Re: [BETA] Medal System MOD 1.0.1

Post by XBB Sandman 6 »

I have two different sections of this mod one for ribbons and one for medals. These both display under the avatar when user posts. I wish to only display the ribbons as the medals take up a lot room. I still wish to award medals and view them when viewing a user profile.

Is it possible to have the mod not show medals but only ribbons on the side? But show in awarded to member still? I tried making a new category but the settings are limited and do not allow me to distinguish between the two.

Is there some way to get it how I am asking?
BioLogIn
Registered User
Posts: 172
Joined: Sun Jan 06, 2008 10:51 am

Re: [BETA] Medal System MOD 1.0.1

Post by BioLogIn »

Hey Jessica. Thanks for picking up this mod!

Please correct me if I'm wrong, but from looking at the current code it seems like you still have open that exploit that allowed users to nominate others for any medal id, even if that medal has nominations disabled or even if that medal doesn't exist at all. Suggested fix looks like this:

FIND

Code: Select all

generate_text_for_storage($message, $uid, $bitfield, $m_flags, $allow_bbcode, $allow_urls, $allow_smilies);
ADD BEFORE

Code: Select all

 if ($medals[$medal_id]['nominated'] == 0)
 {
	trigger_error(sprintf($user->lang['CANNOT_AWARD_UNNOMINATED'], append_sid('medals.php?m=nominate&u=' . $user_id)));
 }
And add appropriate lang var (CANNOT_AWARD_UNNOMINATED in this example) in /language/../mods/info_medals_mod.php
Last edited by BioLogIn on Sat Mar 22, 2014 10:21 pm, edited 1 time in total.
User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica

Re: [BETA] Medal System MOD 1.0.1

Post by Jessica »

Thanks the report. The fix has been made (thank you 5hock!!) and the new package will be uploaded soon.
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein
EliteOps
Registered User
Posts: 15
Joined: Mon Mar 10, 2014 10:40 pm
Location: Here

Re: [BETA] Medal System MOD 1.0.1

Post by EliteOps »

Can i edit or add more images to the medals ?
Dread86
Registered User
Posts: 1
Joined: Mon Mar 24, 2014 3:00 am

Re: [BETA] Medal System MOD 1.0.1

Post by Dread86 »

Having trouble installing this with Automod. Actually, I'm having trouble directly after uploading the .zip with Automod. Basically it uploads fine but when I try to go to my Automod tab I get the following:

XML error: not well-formed (invalid token) at line 1. View the file ./../store/mods/Medal-System-Mod-master/install.xml in a web browser for a more detailed error message.

Any ideas?

Return to “[3.0.x] MODs in Development”