admin/index.php redirects to forum index (can't go to panel)

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

admin/index.php redirects to forum index (can't go to panel)

Post by PaulWV »

URL: http://www.wrestleview.com/wvcgiwv/phpboard
Template(s) used: SilverBlack
Any and all MODs: none
Do you use a port of phpBB: no
Version of phpBB: : 2.0.10
Version of PHP: Not sure
Which database server and version: MySQL 4.0.18
Host: Frognet
Did someone install this for you/who: Me
Is this an upgrade/from what to what: from 2.0.4 to 2.0.10
Is this a conversion/from what to what:
Have you searched for your problem: yes
If so, what terms did you try: Administration panel
State the nature of your problem: (I have it below)
Do you have a test account for us: none
If so, please have it ready in case a Support Team Member asks for it.

The only problem is once I am logged in (since I am the admin), I click on "Go to Administration Panel" at the bottom of the page, but it doesn't take me to the admin panel, all it does is it redirects me to the forum index. http://www.wrestleview.com/wvcgiwv/phpb ... 1681623239
Last edited by PaulWV on Thu Sep 02, 2004 5:35 pm, edited 1 time in total.
User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion »

When you log in as admin, and go to the folder directly,
http://www.wrestleview.com/wvcgiwv/phpboard/admin/
do you still get redirected to the index page ?
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

Post by PaulWV »

When I go to that it takes me there:

http://www.wrestleview.com:/wvcgiwv/php ... 7587e89855

Once I log in, it works. But, when I click on the admin link while logged in, it redirects me back to the forum. I must be logged out to access it, it's weird.
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

Post by PaulWV »

Hope someone can help :)
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

Post by PaulWV »

Everything else is running fine on the board except that admin link. It keeps redirecting me to the main page.

I searched everywhere for a solution, I still couldn't find it. I found two topics on here with the same problem, but 0 replies.
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

in includes/page_tail.php please find the line that begins with:

Code: Select all

$admin_link
Should be near the begining. Post the complete line here.
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

Post by PaulWV »

Thanks for replying. Here is the code:

Code: Select all

$admin_link = ( $userdata['user_level'] == ADMIN ) ? '<a href="' . append_sid("admin/index.$phpEx") . '">' . $lang['Admin_panel'] . '</a><br /><br />' : '';
User avatar
koro_guitarist
Registered User
Posts: 180
Joined: Sun May 11, 2003 11:22 pm
Location: England
Contact:

Post by koro_guitarist »

Try this:

Code: Select all

$admin_link = ( $userdata['user_level'] == ADMIN ) ? '<a href="admin/index.' . $phpEx . '?sid=' . $userdata['session_id'] . '">' . $lang['Admin_panel'] . '</a><br /><br />' : '';
PaulWV
Registered User
Posts: 47
Joined: Wed Jan 29, 2003 1:51 pm

Post by PaulWV »

Thanks, it worked!

Just curious.. why does it add "?sid=c0247c7137d6cd1f0a637089e3d1fceb" to the url?

Example:
wrestleview.com/phpbb/admin/index.php?sid=c0247c7137d6cd1f0a637089e3d1fceb
geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

that is your session ID it is how phpBB keeps track of you. Someitmes it is in a cookie sometime in the URL
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

But in the Admin panel, it is always in the URL because of potential security problems with cookies.

Just FYI, not terribly important :P
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
User avatar
koro_guitarist
Registered User
Posts: 180
Joined: Sun May 11, 2003 11:22 pm
Location: England
Contact:

Post by koro_guitarist »

PaulWV wrote: Thanks, it worked!


I know it's late, but you're welcome. I'm happy to help. :)
Locked

Return to “2.0.x Support Forum”