Cannot disable Topic Icons for New Posts and some responses

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
starshine1000
Registered User
Posts: 209
Joined: Mon Aug 11, 2014 10:05 am

Cannot disable Topic Icons for New Posts and some responses

Post by starshine1000 »

I don't want to use Topic Icons at all. Unfortunately I selected to have them when I created the forums, but I since changed my mind. Now I can't turn them off.
  • I have disabled topic icons for ALL forums on my board.
  • I double checked every single forum twice - the "No" option is definitely ticked for all forums, see below.
  • I have refreshed the theme and purged the cache.
  • Logged out user and logged in again.
  • Tried different browsers
  • Emptied browser cache.
But the Topic Icons aren't going away! :x

For some responses to existing topics they are not there. But for all New topics, they appear.
I can't find any more settings for Topic Icons and need advise!
Want to get rid of the topic icons!

Environment: phpb 3.0.12; Theme: we_clearblue; Language: Swedish

ILLUSTRATION:

Topic Icons disabled for the forum I am about to create a new thread in:


Image

Topic Icons appear anyway, as I try to create a new thread in the forum in question. Repeated in all forums on my board.

Image
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 52386
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Cannot disable Topic Icons for New Posts and some respon

Post by stevemaury »

The icons display, but I don't think with those settings you can actually use them in posts. The reason they display is that the template for creating posts is the same as the one for creating PMs. See this in styles/prosilver/template/posting_editor.html:

Code: Select all

<!-- IF S_SHOW_TOPIC_ICONS or S_SHOW_PM_ICONS -->
To see if I am right, first try creating a new topic and selecting a topic icon and see if it actually shows. If not, and you don't want them displayed at all, in the ACP, Private message settings, set Enable use of topic icons in private messages: to No.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
User avatar
Lumpy Burgertushie
Registered User
Posts: 68697
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Cannot disable Topic Icons for New Posts and some respon

Post by Lumpy Burgertushie »

on all of my boards, when I disable the icons they don't show up, period.

IF I disable only the forums, then they don't show up in posting for that forum but still show up in PMs.

If I disable for PMs they don't show up in PM.

If yours are still showing up when you try to post then it must be something else you have changed on the board that is causing this.

what MODs do you have installed?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 52386
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Cannot disable Topic Icons for New Posts and some respon

Post by stevemaury »

Yeah, you're right. Further down in that file is this code:

Code: Select all

<!-- IF S_SHOW_TOPIC_ICONS -->{L_NO_TOPIC_ICON}<!-- ELSE -->{L_NO_PM_ICON}<!-- ENDIF -->
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
User avatar
starshine1000
Registered User
Posts: 209
Joined: Mon Aug 11, 2014 10:05 am

Re: Cannot disable Topic Icons for New Posts and some respon

Post by starshine1000 »

stevemaury wrote:The icons display, but I don't think with those settings you can actually use them in posts. The reason they display is that the template for creating posts is the same as the one for creating PMs. See this in styles/prosilver/template/posting_editor.html:

Code: Select all

<!-- IF S_SHOW_TOPIC_ICONS or S_SHOW_PM_ICONS -->
Thanks for the feedback!

To see if I am right, first try creating a new topic and selecting a topic icon and see if it actually shows. If not, and you don't want them displayed at all, in the ACP, Private message settings, set Enable use of topic icons in private messages: to No.

NOTE
: I am user WE_CLEARBLUE template, and not prosilver or subsilver.

OK, at present - they still show. I don't want them in PMs either so I'll go in there and disable them.

Image


@Lumpy: These are the MODs that I have

Image
User avatar
starshine1000
Registered User
Posts: 209
Joined: Mon Aug 11, 2014 10:05 am

Re: Cannot disable Topic Icons for New Posts and some respon

Post by starshine1000 »

I disabled Topic Icons for PMs but STILL no joy!

Could there be some dodgy inheritance going on behind the scenes? Initially I set the forums to inherit properties, but later I disabled it. I'm beginning to think that this is a bug, or at least unintended behaviour.

Can I manually just remove the code?
I'm never going to want it again, so I don't care...
User avatar
starshine1000
Registered User
Posts: 209
Joined: Mon Aug 11, 2014 10:05 am

Re: Cannot disable Topic Icons for New Posts and some respon

Post by starshine1000 »

stevemaury wrote:The icons display, but I don't think with those settings you can actually use them in posts. The reason they display is that the template for creating posts is the same as the one for creating PMs. See this in styles/prosilver/template/posting_editor.html:

Code: Select all

<!-- IF S_SHOW_TOPIC_ICONS or S_SHOW_PM_ICONS -->
To see if I am right, first try creating a new topic and selecting a topic icon and see if it actually shows. If not, and you don't want them displayed at all, in the ACP, Private message settings, set Enable use of topic icons in private messages: to No.

What if I just delete that snippet? Will the icons go away?
User avatar
Lumpy Burgertushie
Registered User
Posts: 68697
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Cannot disable Topic Icons for New Posts and some respon

Post by Lumpy Burgertushie »

no, it can't be a bug because you are the only one having this problem.

it is most likely due to one or more of the MODs that you have been installing trying to get other things to work.

go back to automod, uninstall any of the MODs that you are not going to use.

see what happens.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

I am pleased to announce that I have completed the first item on my bucket list. I have the bucket.
User avatar
starshine1000
Registered User
Posts: 209
Joined: Mon Aug 11, 2014 10:05 am

Re: Cannot disable Topic Icons for New Posts and some respon

Post by starshine1000 »

Lumpy Burgertushie wrote:no, it can't be a bug because you are the only one having this problem.

it is most likely due to one or more of the MODs that you have been installing trying to get other things to work.

go back to automod, uninstall any of the MODs that you are not going to use.

see what happens.


robert
Thank you! Ok this goes at the bottom of my to-do list for the site.
At some point I'll do it it. But I understand what you mean and it makes sense.
I'm sure it's my fault that it isn't behaving as intended... I've been back and forth so much with various tweaks.

It's not a showstopper exactly. I'm just annoyed that it is defying me.
I guess I could get some really elegant icons and just run with it.
The MODs really are a can of worms - you can break things even uninstalling them!
Plus, some of it is configured, so I don't want to play around with the bits I'm actually happy with.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 71007
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Cannot disable Topic Icons for New Posts and some respon

Post by KevC »

starshine1000 wrote:The MODs really are a can of worms - you can break things even uninstalling them!
Plus, some of it is configured, so I don't want to play around with the bits I'm actually happy with.
The other possible issue is that you're trying to make multiple changes at once. In the last couple of days you've had a ton of topics open, changing many different things and if you don't do one, make sure it's ok, then do the next, you're never quite sure what affects what and then you find something doesn't work but it's hard to trace where or why. Most users probably won't even notice the MODs. It's better to get them in and then decide what changes you need once they're settled in.
-:|:- Support Request Template -:|:-
Image
"Use of unnecessary violence in the apprehension of the Blues Brothers has been approved"
Locked

Return to “[3.0.x] Support Forum”