504 Gateway Timeout Error - FIXED

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
Locked
elgrandoc
Registered User
Posts: 50
Joined: Sun Aug 31, 2014 4:49 pm
Location: Hartlepool, UK
Name: Karl Williams
Contact:

504 Gateway Timeout Error - FIXED

Post by elgrandoc » Fri Mar 13, 2015 9:23 pm

Right then. Over the last 3 months I've posted various times about a constant error I was getting with my phpBB forum.

The error was a 504 "Gateway Timeout" error that occurred sporadically when users were posting, creating new user accounts or sending private messages. Now the data submitted (the post, the registration and/or the message) was actually posted, but users were clicking back and submitting again.

This resulted in a very high number of duplicate posts, the most of which I had was 5 in a row. But it also meant that new users signing up were thinking there was a problem and not realising their accounts were actually active.

I had tried a LOT of things, but today I finally fixed it.

I did a backup of all tables EXCEPT config and config_text. I then renamed the directory from "forum" to "oldforum" and did a completely fresh install. I copied over all the required files from the old directory (ie avatar images, style changes, back ups), and then did a restore in the new forum from the old.

This has restored all my users, posts, forums, messages, extensions, settings etc all from the back up, but it has left the nasty 504 error behind. The forum is now also much more responsive, with quicker loading times between screens and posting immediately rather than hanging.

To say this is a relief is an understatement.

Just to clarify, these are the steps I had been through previously to try and remove the error:

Changed the cookie settings to reflect the subdomain that I was using
Removing extensions installed
Purged the cache (a lot)
Checked all files that had been modified
Reverted back to using the standard URL rather than using the subdomain
Checked database using php My Admin, checked, optimised and repaired all tables
... a lot of other things I can't remember.

So, if anyone else get's this problem. Try this solution. I installed a test version first, and started migrating a few tables at a time. Each time I did it, I got the error when the config file was transferred. So, I eliminated that from my transfer and all is well. Once I knew what to do, took me all of 5 minutes to transfer and get up and running again. Happy days.

Locked

Return to “[3.1.x] Support Forum”